summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2002-12-20 22:31:04 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2002-12-20 22:31:04 +0000
commit9f2d084001a8284abcf45331faa33e23465ae72f (patch)
tree57b9745a668a43ecc18a145f69116ff145587a08 /sys-apps/logwatch
parentAdded mips to keywords (diff)
downloadhistorical-9f2d084001a8284abcf45331faa33e23465ae72f.tar.gz
historical-9f2d084001a8284abcf45331faa33e23465ae72f.tar.bz2
historical-9f2d084001a8284abcf45331faa33e23465ae72f.zip
Initial import. Bug #8223
Diffstat (limited to 'sys-apps/logwatch')
-rw-r--r--sys-apps/logwatch/ChangeLog8
-rw-r--r--sys-apps/logwatch/files/digest-logwatch-4.2.11
-rw-r--r--sys-apps/logwatch/logwatch-4.2.1.ebuild92
3 files changed, 101 insertions, 0 deletions
diff --git a/sys-apps/logwatch/ChangeLog b/sys-apps/logwatch/ChangeLog
new file mode 100644
index 000000000000..f9fbc943fad9
--- /dev/null
+++ b/sys-apps/logwatch/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sys-apps/logwatch
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/ChangeLog,v 1.1 2002/12/20 22:31:04 jhhudso Exp $
+
+*logwatch-4.2.1 (20 Dec 2002)
+
+ 20 Dec 2002; Jared Hudson <jhhudso@gentoo.org> : Initial import. Ebuild
+ submitted by Alessandro Pisani <alextxm@tin.it>.
diff --git a/sys-apps/logwatch/files/digest-logwatch-4.2.1 b/sys-apps/logwatch/files/digest-logwatch-4.2.1
new file mode 100644
index 000000000000..6a3d0abe5962
--- /dev/null
+++ b/sys-apps/logwatch/files/digest-logwatch-4.2.1
@@ -0,0 +1 @@
+MD5 b0ba7785397a29a94715e9710b13340d logwatch-4.2.1.tar.gz 55071
diff --git a/sys-apps/logwatch/logwatch-4.2.1.ebuild b/sys-apps/logwatch/logwatch-4.2.1.ebuild
new file mode 100644
index 000000000000..8ea863aa7fcc
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-4.2.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/logwatch-4.2.1.ebuild,v 1.1 2002/12/20 22:31:04 jhhudso Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LogWatch, a customizable log analysis system"
+SRC_URI="ftp://ftp.kaybee.org/pub/linux/${P}.tar.gz"
+HOMEPAGE="http://www.logwatch.org/"
+
+DEPEND="virtual/glibc
+ virtual/cron
+ virtual/mta
+ sys-devel/perl
+ net-mail/mailx"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="as-is"
+
+src_install() {
+ dodir /usr/share/logwatch
+ dodir /usr/share/logwatch/conf
+ dodir /usr/share/logwatch/conf/logfiles
+ dodir /usr/share/logwatch/conf/services
+ dodir /usr/share/logwatch/scripts
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+
+ # correct install directory into script
+ cat ${S}/scripts/logwatch.pl | sed -e "s/my \$BaseDir = \"\/etc\/log.d\";/my \$BaseDir = \"\/usr\/share\/logwatch\";/" > ${S}/scripts/logwatch.tmp_install
+ exeinto /usr/share/logwatch/scripts
+ newexe scripts/logwatch.tmp_install logwatch.pl
+
+ exeinto /usr/share/logwatch/scripts/logfiles
+ for i in scripts/logfiles/* ; do
+ if [ $(ls $i | wc -l) -ne 0 ] ; then
+ file="`echo $i | awk -F/ '{ print $3 }'`"
+ dodir /usr/share/logwatch/scripts/logfiles/$file
+
+ exeinto /usr/share/logwatch/scripts/logfiles/$file
+ for l in scripts/logfiles/$file/* ; do
+ subfile="`echo $l | awk -F/ '{ print $4 }'`"
+ newexe $l $subfile
+ done
+ fi
+ done
+
+ exeinto /usr/share/logwatch/scripts/services
+ for i in scripts/services/* ; do
+ file="`echo $i | awk -F/ '{ print $3 }'`"
+ newexe $i $file
+ done
+
+ exeinto /usr/share/logwatch/scripts/shared
+ for i in scripts/shared/* ; do
+ file="`echo $i | awk -F/ '{ print $3 }'`"
+ newexe $i $file
+ done
+
+ insinto /usr/share/logwatch/conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/conf/logfiles
+ for i in conf/logfiles/* ; do
+ doins $i
+ done
+
+ insinto /usr/share/logwatch/conf/services
+ for i in conf/services/* ; do
+ doins $i
+ done
+
+ dodoc README License HOWTO-Make-Filter
+ doman logwatch.8
+ }
+
+pkg_postinst() {
+ einfo "creating a symlink for configuration directory..."
+ ln -snf ${ROOT}usr/share/logwatch/conf ${ROOT}etc/logwatch
+
+ einfo "adding executable to path..."
+ ln -sf ${ROOT}usr/share/logwatch/scripts/logwatch.pl ${ROOT}usr/bin/logwatch
+
+ einfo "adding to cron..."
+ echo "0 0 * * * ${ROOT}usr/share/logwatch/scripts/logwatch.pl 2>&1 > /dev/null" >> ${ROOT}var/spool/cron/crontabs/root
+ }
+
+pkg_postrm() {
+ sed "/^0.*\/usr\/share\/logwatch\/scripts\/logwatch.*null$/d" ${ROOT}var/spool/cron/crontabs/root > ${ROOT}var/spool/cron/crontabs/root.new
+ mv --force ${ROOT}var/spool/cron/crontabs/root.new ${ROOT}var/spool/cron/crontabs/root
+}
+