summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-10-09 06:56:22 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-10-09 06:56:22 +0000
commitad11cd4f88ca9253df15f9cbbf936eb354b63154 (patch)
tree64152751551edad58e051abeafe28310c5789d8d /sys-apps/magneto-core
parentversion bump (diff)
downloadhistorical-ad11cd4f88ca9253df15f9cbbf936eb354b63154.tar.gz
historical-ad11cd4f88ca9253df15f9cbbf936eb354b63154.tar.bz2
historical-ad11cd4f88ca9253df15f9cbbf936eb354b63154.zip
version bump
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/magneto-core')
-rw-r--r--sys-apps/magneto-core/ChangeLog8
-rw-r--r--sys-apps/magneto-core/magneto-core-1.0_rc59.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-apps/magneto-core/ChangeLog b/sys-apps/magneto-core/ChangeLog
index c47a6dc050b8..5e4f3fa2c400 100644
--- a/sys-apps/magneto-core/ChangeLog
+++ b/sys-apps/magneto-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/magneto-core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/ChangeLog,v 1.11 2011/09/18 10:51:39 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/ChangeLog,v 1.12 2011/10/09 06:56:22 lxnay Exp $
+
+*magneto-core-1.0_rc59 (09 Oct 2011)
+
+ 09 Oct 2011; Fabio Erculiani <lxnay@gentoo.org>
+ +magneto-core-1.0_rc59.ebuild:
+ version bump
*magneto-core-1.0_rc53 (18 Sep 2011)
diff --git a/sys-apps/magneto-core/magneto-core-1.0_rc59.ebuild b/sys-apps/magneto-core/magneto-core-1.0_rc59.ebuild
new file mode 100644
index 000000000000..ca7184347ab2
--- /dev/null
+++ b/sys-apps/magneto-core/magneto-core-1.0_rc59.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/magneto-core-1.0_rc59.ebuild,v 1.1 2011/10/09 06:56:22 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python multilib
+
+DESCRIPTION="Entropy Package Manager notification applet library"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+DEPEND=">=sys-apps/entropy-client-services-${PV}"
+RDEPEND="${DEPEND}
+ x11-misc/xdg-utils"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/$(get_libdir)" magneto-core-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/$(get_libdir)/entropy/magneto"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/entropy/magneto"
+}