summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-02-10 19:18:54 +0000
committerMichael Januszewski <spock@gentoo.org>2008-02-10 19:18:54 +0000
commit533da44c74768642ccfe29dae99d14e928376101 (patch)
tree44c5c3491eed48699600ad31c44ea83c8a75584e /sys-apps/memtest86+/files
parentVersion bump to 1.2.2_beta as per bug 200185. (diff)
downloadhistorical-533da44c74768642ccfe29dae99d14e928376101.tar.gz
historical-533da44c74768642ccfe29dae99d14e928376101.tar.bz2
historical-533da44c74768642ccfe29dae99d14e928376101.zip
Version bump (bug #209525).
Package-Manager: portage-2.1.4.1
Diffstat (limited to 'sys-apps/memtest86+/files')
-rw-r--r--sys-apps/memtest86+/files/memtest86+-2.00-hardcoded_cc.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/memtest86+/files/memtest86+-2.00-hardcoded_cc.patch b/sys-apps/memtest86+/files/memtest86+-2.00-hardcoded_cc.patch
new file mode 100644
index 000000000000..449b1bf3ddec
--- /dev/null
+++ b/sys-apps/memtest86+/files/memtest86+-2.00-hardcoded_cc.patch
@@ -0,0 +1,25 @@
+diff -Naurp memtest86+-2.00-orig/Makefile memtest86+-2.00/Makefile
+--- memtest86+-2.00-orig/Makefile 2008-02-10 19:50:30.000000000 +0100
++++ memtest86+-2.00/Makefile 2008-02-10 20:05:30.000000000 +0100
+@@ -8,9 +8,9 @@
+ #
+ FDISK=/dev/fd0
+
+-CC=gcc
+-
+-CFLAGS=-Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC
++CPPFLAGS=-m32
++CFLAGS=-Wall -m32 -march=i486 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector
++ASFLAGS=-32
+
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o linuxbios.o memsize.o pci.o controller.o random.o extra.o \
+@@ -37,7 +37,7 @@ memtest.bin: memtest_shared.bin bootsect
+ memtest_shared.bin -o memtest.bin
+
+ reloc.o: reloc.c
+- $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
++ $(CC) -c $(CFLAGS) -fno-strict-aliasing -fno-stack-protector reloc.c
+
+ test.o: test.c
+ $(CC) -c -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding test.c