summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Gabert <pappy@gentoo.org>2003-09-25 16:29:26 +0000
committerAlexander Gabert <pappy@gentoo.org>2003-09-25 16:29:26 +0000
commitab5e3a8161ff0d555f7a4e7a4939f1e35070db05 (patch)
treed67c2bc70efda1b248d86e8ea8b8250c286bfaad /sys-apps/modutils/modutils-2.4.25.ebuild
parentbugfixes for hardened-gcc (diff)
downloadhistorical-ab5e3a8161ff0d555f7a4e7a4939f1e35070db05.tar.gz
historical-ab5e3a8161ff0d555f7a4e7a4939f1e35070db05.tar.bz2
historical-ab5e3a8161ff0d555f7a4e7a4939f1e35070db05.zip
bugfixes for hardened-gcc
Diffstat (limited to 'sys-apps/modutils/modutils-2.4.25.ebuild')
-rw-r--r--sys-apps/modutils/modutils-2.4.25.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-apps/modutils/modutils-2.4.25.ebuild b/sys-apps/modutils/modutils-2.4.25.ebuild
index d2ed6309f845..915dbc3d310f 100644
--- a/sys-apps/modutils/modutils-2.4.25.ebuild
+++ b/sys-apps/modutils/modutils-2.4.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.25.ebuild,v 1.12 2003/09/07 00:43:02 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.25.ebuild,v 1.13 2003/09/25 16:29:18 pappy Exp $
inherit flag-o-matic
@@ -23,8 +23,12 @@ src_compile() {
filter-flags -fPIC
# http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
- has_version 'sys-devel/hardened-gcc' && append-flags '-yet_exec'
-
+ # we disable etdyn because of assembler and extra add fstackprotector plus the necessary libs
+ if has_version 'sys-devel/hardened-gcc'
+ then
+ append-flags "-yet_exec -fstack-protector -Wl,$(gcc-config -L)/libgcc.a -Wl,/lib/libc.so.6"
+ fi
+
myconf=""
# see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
#