summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-01-14 22:59:41 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-01-14 22:59:41 +0000
commit481b60ee9f632673e8f515571ffde612481fbbd8 (patch)
tree741fc556fc4341b12fd5bfa63dd4e2f5ae0f97ed /sys-apps/quota/quota-3.10.ebuild
parentVersion bumped and adding a note about services. Closes 21835 (diff)
downloadhistorical-481b60ee9f632673e8f515571ffde612481fbbd8.tar.gz
historical-481b60ee9f632673e8f515571ffde612481fbbd8.tar.bz2
historical-481b60ee9f632673e8f515571ffde612481fbbd8.zip
Version bumped and adding a note about services. Closes 21835
Diffstat (limited to 'sys-apps/quota/quota-3.10.ebuild')
-rw-r--r--sys-apps/quota/quota-3.10.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-apps/quota/quota-3.10.ebuild b/sys-apps/quota/quota-3.10.ebuild
new file mode 100644
index 000000000000..d6f8a71b50e4
--- /dev/null
+++ b/sys-apps/quota/quota-3.10.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/quota/quota-3.10.ebuild,v 1.1 2004/01/14 22:59:31 mholzer Exp $
+
+IUSE="nls tcpd"
+
+S=${WORKDIR}/quota-tools
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~amd64 ~ia64"
+
+DEPEND="virtual/glibc
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # patch to prevent quotactl.2 manpage from being installed
+ # that page is provided by man-pages instead
+ epatch ${FILESDIR}/${PN}-no-quotactl-manpage.patch
+
+ sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
+}
+
+src_install() {
+ dodir {sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,3,8}}
+ make ROOTDIR=${D} install || die
+# install -m 644 warnquota.conf ${D}/etc
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+ dodoc doc/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/quota.rc quota
+
+ # NLS bloat reduction
+ use nls || rm -rf ${D}/usr/share/locale
+}
+
+pkg_postinst() {
+ einfo "with this release, you can configure the used"
+ einfo "ports through /etc/services"
+ einfo
+ einfo "eg. use the default"
+ einfo "rquotad 4003/tcp # quota"
+ einfo "rquotad 4003/udp # quota"
+}