summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-02 16:06:34 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-02 16:06:34 +0000
commit23d164bd8e55d533400701b47f07895aa615ecba (patch)
tree1c0daf3f5a9bdc31a3220f4c820f09dbd316906b /sys-apps/quota
parentVersion bumped. Closes #32363. (diff)
downloadhistorical-23d164bd8e55d533400701b47f07895aa615ecba.tar.gz
historical-23d164bd8e55d533400701b47f07895aa615ecba.tar.bz2
historical-23d164bd8e55d533400701b47f07895aa615ecba.zip
Version bumped. Closes #32363.
Diffstat (limited to 'sys-apps/quota')
-rw-r--r--sys-apps/quota/Manifest4
-rw-r--r--sys-apps/quota/files/digest-quota-3.091
-rw-r--r--sys-apps/quota/quota-3.09.ebuild40
3 files changed, 43 insertions, 2 deletions
diff --git a/sys-apps/quota/Manifest b/sys-apps/quota/Manifest
index 8cf4153c0910..4fba7f1e9d11 100644
--- a/sys-apps/quota/Manifest
+++ b/sys-apps/quota/Manifest
@@ -1,8 +1,8 @@
-MD5 f42449bbad338edc692743bb986360a0 ChangeLog 2740
+MD5 179f515ebdaed7ca6ea18b9645380b5f ChangeLog 2870
MD5 4668abbe04d7918e598bb9b21c831155 quota-3.06-r1.ebuild 884
MD5 bccad1fe62cc1ac9e1828e8dc992b798 quota-3.06.ebuild 820
MD5 74a2d1eb7bc4c80c178d2b5bdaaf3aea quota-3.06-r2.ebuild 1016
-MD5 74a2d1eb7bc4c80c178d2b5bdaaf3aea quota-3.09.ebuild 1016
+MD5 963123c61608b9ea30b6129c45675837 quota-3.09.ebuild 1013
MD5 fe63ca32e32411f6aa067fdc6d451ae9 files/digest-quota-3.06 62
MD5 fe63ca32e32411f6aa067fdc6d451ae9 files/digest-quota-3.06-r1 62
MD5 a26d206672c294341ce1ebed4acc45b1 files/quota.rc 441
diff --git a/sys-apps/quota/files/digest-quota-3.09 b/sys-apps/quota/files/digest-quota-3.09
new file mode 100644
index 000000000000..6b8068800435
--- /dev/null
+++ b/sys-apps/quota/files/digest-quota-3.09
@@ -0,0 +1 @@
+MD5 f723962e0c4783837d9f38f59a748bca quota-3.09.tar.gz 190819
diff --git a/sys-apps/quota/quota-3.09.ebuild b/sys-apps/quota/quota-3.09.ebuild
new file mode 100644
index 000000000000..b76ae1c21df7
--- /dev/null
+++ b/sys-apps/quota/quota-3.09.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/quota/quota-3.09.ebuild,v 1.1 2003/11/02 16:06:27 mholzer Exp $
+
+IUSE="nls"
+
+S=${WORKDIR}/quota-tools
+DESCRIPTION="Linux quota tools"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+
+DEPEND="virtual/glibc
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+src_compile() {
+ sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dodir {sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,2,3,8}}
+ make ROOTDIR=${D} install || die
+# install -m 644 warnquota.conf ${D}/etc
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+ dodoc doc/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/quota.rc quota
+
+ # NLS bloat reduction
+ use nls || rm -rf ${D}/usr/share/locale
+}