summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoachim Blaabjerg <styx@gentoo.org>2002-12-10 17:49:41 +0000
committerJoachim Blaabjerg <styx@gentoo.org>2002-12-10 17:49:41 +0000
commitf912088385e132ccae9f093144dcb7e4a4b5655f (patch)
tree508b7a95938e4f8229b7f10b3e0d04b48b90dc48 /sys-apps/quota
parentNew version (0.5) (diff)
downloadhistorical-f912088385e132ccae9f093144dcb7e4a4b5655f.tar.gz
historical-f912088385e132ccae9f093144dcb7e4a4b5655f.tar.bz2
historical-f912088385e132ccae9f093144dcb7e4a4b5655f.zip
Uhm. I thought I committed this a couple of days ago. Evidently not. This has an rc script now, fixes bug #5564
Diffstat (limited to 'sys-apps/quota')
-rw-r--r--sys-apps/quota/files/digest-quota-3.06-r11
-rw-r--r--sys-apps/quota/quota-3.06-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/quota/files/digest-quota-3.06-r1 b/sys-apps/quota/files/digest-quota-3.06-r1
new file mode 100644
index 000000000000..ec34953cbbfb
--- /dev/null
+++ b/sys-apps/quota/files/digest-quota-3.06-r1
@@ -0,0 +1 @@
+MD5 13b6a46c61b35fe1c78ab9050cb4e463 quota-3.06.tar.gz 183559
diff --git a/sys-apps/quota/quota-3.06-r1.ebuild b/sys-apps/quota/quota-3.06-r1.ebuild
new file mode 100644
index 000000000000..2982027f1756
--- /dev/null
+++ b/sys-apps/quota/quota-3.06-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/quota/quota-3.06-r1.ebuild,v 1.1 2002/12/10 17:49:41 styx Exp $
+
+S=${WORKDIR}/quota-tools
+DESCRIPTION="Linux quota tools"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc "
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ econf || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dodir {sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,2,3,8}}
+ make ROOTDIR=${D} install || die
+# install -m 644 warnquota.conf ${D}/etc
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+ dodoc doc/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/quota.rc quota
+}