summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-20 23:11:13 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-20 23:11:13 +0000
commit55a2510f30e16f6e416bfadc438b30dff44942b7 (patch)
tree19a82308e40e1c45e5bb1bd5b67559098a4b6480 /sys-apps/sh-utils
parentAlternate implementation of USE dependent NLS compilation (diff)
downloadhistorical-55a2510f30e16f6e416bfadc438b30dff44942b7.tar.gz
historical-55a2510f30e16f6e416bfadc438b30dff44942b7.tar.bz2
historical-55a2510f30e16f6e416bfadc438b30dff44942b7.zip
nuname patch is only applied for non-build situations now
Diffstat (limited to 'sys-apps/sh-utils')
-rw-r--r--sys-apps/sh-utils/sh-utils-2.0.11-r3.ebuild28
1 files changed, 17 insertions, 11 deletions
diff --git a/sys-apps/sh-utils/sh-utils-2.0.11-r3.ebuild b/sys-apps/sh-utils/sh-utils-2.0.11-r3.ebuild
index 887a88c7660b..b128fb03de6a 100644
--- a/sys-apps/sh-utils/sh-utils-2.0.11-r3.ebuild
+++ b/sys-apps/sh-utils/sh-utils-2.0.11-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0.11-r3.ebuild,v 1.1 2002/03/18 13:53:41 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0.11-r3.ebuild,v 1.2 2002/03/20 23:11:13 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Your standard GNU shell utilities"
@@ -13,13 +13,18 @@ RDEPEND="virtual/glibc"
src_unpack() {
unpack ${P}.tar.gz
-
- # patch to add Chipset info. in uname output
- tar zxf ${DISTDIR}/nuname-1.0.tar.gz
+ if [ -z "`use build`" ]
+ then
+ # patch to add Chipset info. in uname output
+ # this is not important for the static version, though
+ # and anyway, it breaks compilation on that version
+ tar zxf ${DISTDIR}/nuname-1.0.tar.gz
+ cd ${S}
+ patch src/uname.c ../nuname/lin_uname_patch
+ rm src/uname.c~
+ mv ../nuname/README ../nuname/README.nuname
+ fi
cd ${S}
- patch src/uname.c ../nuname/lin_uname_patch
- mv ../nuname/README ../nuname/README.nuname
-
# patch to remove Stallman's rant about su and the wheel group
patch doc/sh-utils.texi ${FILESDIR}/${P}-gentoo.diff
rm doc/sh-utils.info
@@ -34,12 +39,12 @@ src_compile() {
if [ -z "`use static`" ]
then
- emake || die
+ make || die
else
- emake LDFLAGS=-static || die
+ make LDFLAGS=-static || die
+ cd doc
+ make
fi
- cd doc
- make
}
src_install() {
@@ -53,6 +58,7 @@ src_install() {
then
# We must use hostname from net-base
rm ${D}/usr/bin/hostname
+
cd ${S}
dodoc AUTHORS COPYING ChangeLog ChangeLog.0 NEWS README THANKS TODO
dodoc ../nuname/README.nuname