summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2003-06-04 20:48:41 +0000
committerHanno Boeck <hanno@gentoo.org>2003-06-04 20:48:41 +0000
commit32a24665fb9b433a07ae56be677eb13afeab65e4 (patch)
treee92acbcde396f737631dd7a41421d3dd37b23600 /sys-apps/usbutils/usbutils-0.11-r1.ebuild
parentUpdating to 20030525, adding architectures (diff)
downloadhistorical-32a24665fb9b433a07ae56be677eb13afeab65e4.tar.gz
historical-32a24665fb9b433a07ae56be677eb13afeab65e4.tar.bz2
historical-32a24665fb9b433a07ae56be677eb13afeab65e4.zip
added updating usb.ids-possibility to usbutils-ebuild
Diffstat (limited to 'sys-apps/usbutils/usbutils-0.11-r1.ebuild')
-rw-r--r--sys-apps/usbutils/usbutils-0.11-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/usbutils/usbutils-0.11-r1.ebuild b/sys-apps/usbutils/usbutils-0.11-r1.ebuild
new file mode 100644
index 000000000000..7064f3ced7f6
--- /dev/null
+++ b/sys-apps/usbutils/usbutils-0.11-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-0.11-r1.ebuild,v 1.1 2003/06/04 20:46:59 hanno Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="USB enumeration utilities"
+SRC_URI="http://usb.cs.tum.edu/download/usbutils/${P}.tar.gz"
+HOMEPAGE="http://usb.cs.tum.edu/"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${P}
+ mv usb.ids usb.ids.orig
+ wget http://www.linux-usb.org/usb.ids
+ if [ ! -f usb.ids ] ; then mv usb.ids.orig usb.ids ; fi
+}
+
+src_compile() {
+ # put usb.ids in same place as pci.ids (/usr/share/misc)
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/misc || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}