summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-10-29 22:47:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-10-29 22:47:05 +0000
commit1ae1067e3c7c644123583accb31964fdaed694a9 (patch)
tree261a791a76befc145bbcd8c099cdf617ebdbbe79 /sys-apps/usbutils/usbutils-0.73.ebuild
parentInitial import, fixing bug #197211, thanks to Alexander Graf for submitting (diff)
downloadhistorical-1ae1067e3c7c644123583accb31964fdaed694a9.tar.gz
historical-1ae1067e3c7c644123583accb31964fdaed694a9.tar.bz2
historical-1ae1067e3c7c644123583accb31964fdaed694a9.zip
Version bump.
Package-Manager: portage-2.1.3.16
Diffstat (limited to 'sys-apps/usbutils/usbutils-0.73.ebuild')
-rw-r--r--sys-apps/usbutils/usbutils-0.73.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/usbutils/usbutils-0.73.ebuild b/sys-apps/usbutils/usbutils-0.73.ebuild
new file mode 100644
index 000000000000..daeb13aa4c1c
--- /dev/null
+++ b/sys-apps/usbutils/usbutils-0.73.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-0.73.ebuild,v 1.1 2007/10/29 22:47:04 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="http://linux-usb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron zlib"
+
+DEPEND="dev-libs/libusb"
+ # zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp update-usbids.sh update-usbids.sh.orig
+ epatch "${FILESDIR}"/${PN}-0.72-update-usbids.patch
+
+ # put usb.ids in same place as pci.ids (/usr/share/misc)
+ sed -i \
+ -e 's:/usr/share/usb.ids:/usr/share/misc/usb.ids:' \
+ lsusb.8 || die "sed lsusb.8"
+ sed -e '/^DEST=/s:=usb.ids:=/usr/share/misc/usb.ids:' \
+ update-usbids.sh > update-usbids
+}
+
+src_compile() {
+ # robbat2 - 2007/10/29
+ # zlib disabled pending a revision of update-usbids from upstream.
+ # $(use_enable zlib) \
+ econf \
+ --datadir=/usr/share/misc \
+ --enable-usbmodules \
+ --disable-zlib \
+ || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dosbin update-usbids || die "update-usbids failed"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ use network-cron || return 0
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/usbutils.cron update-usbids || die
+}