summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-10-03 20:07:54 +0000
committerMike Frysinger <vapier@gentoo.org>2010-10-03 20:07:54 +0000
commita11aaeb03ebd0d36635d5e3e5bf825848b31c1ed (patch)
tree4e89a0785407e8ed70073f11cc4f573d740c2e94 /sys-apps/util-linux
parentVersion bump #332797 by Jon Wilson. (diff)
downloadhistorical-a11aaeb03ebd0d36635d5e3e5bf825848b31c1ed.tar.gz
historical-a11aaeb03ebd0d36635d5e3e5bf825848b31c1ed.tar.bz2
historical-a11aaeb03ebd0d36635d5e3e5bf825848b31c1ed.zip
old
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/util-linux-2.16.2.ebuild97
-rw-r--r--sys-apps/util-linux/util-linux-2.18.ebuild112
2 files changed, 0 insertions, 209 deletions
diff --git a/sys-apps/util-linux/util-linux-2.16.2.ebuild b/sys-apps/util-linux/util-linux-2.16.2.ebuild
deleted file mode 100644
index 3e30a65a5f2e..000000000000
--- a/sys-apps/util-linux/util-linux-2.16.2.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.16.2.ebuild,v 1.11 2010/03/01 17:24:26 ssuominen Exp $
-
-EAPI="2"
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
-inherit eutils toolchain-funcs libtool
-[[ ${PV} == "9999" ]] && inherit git autotools
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-ng-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
- #KEYWORDS=""
-else
- SRC_URI="mirror://kernel/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2
- loop-aes? ( mirror://gentoo/${PN}-2.16.1-loop-aes.patch.bz2 )"
- KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="crypt loop-aes nls old-linux perl selinux slang uclibc unicode"
-
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
- !<sys-libs/e2fsprogs-libs-1.41.8
- !<sys-fs/e2fsprogs-1.41.8
- perl? ( dev-lang/perl )
- selinux? ( sys-libs/libselinux )
- slang? ( sys-libs/slang )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/os-headers"
-
-src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
- autopoint --force
- eautoreconf
- else
- use loop-aes && epatch "${WORKDIR}"/${PN}-2.16.1-loop-aes.patch
- fi
- use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
- elibtoolize
-}
-
-src_configure() {
- econf \
- $(use_enable nls) \
- --enable-agetty \
- --enable-cramfs \
- $(use_enable old-linux elvtune) \
- --disable-init \
- --disable-kill \
- --disable-last \
- --disable-mesg \
- --enable-partx \
- --enable-raw \
- --enable-rdev \
- --enable-rename \
- --disable-reset \
- --disable-login-utils \
- --enable-schedutils \
- --disable-wall \
- --enable-write \
- --without-pam \
- $(use unicode || echo --with-ncurses) \
- $(use_with selinux) \
- $(use_with slang) \
- $(tc-has-tls || echo --disable-tls)
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS NEWS README* TODO docs/*
-
- if ! use perl ; then #284093
- rm "${D}"/usr/bin/chkdupexe || die
- rm "${D}"/usr/share/man/man1/chkdupexe.1 || die
- fi
-
- # need the libs in /
- gen_usr_ldscript -a blkid uuid
- # e2fsprogs-libs didnt install .la files, and .pc work fine
- rm -f "${D}"/usr/$(get_libdir)/*.la
-
- if use crypt ; then
- newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
- newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
- fi
-}
diff --git a/sys-apps/util-linux/util-linux-2.18.ebuild b/sys-apps/util-linux/util-linux-2.18.ebuild
deleted file mode 100644
index 5dfa98dc07e4..000000000000
--- a/sys-apps/util-linux/util-linux-2.18.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.18.ebuild,v 1.3 2010/07/01 17:20:11 vapier Exp $
-
-EAPI="2"
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
-inherit eutils toolchain-funcs libtool flag-o-matic
-[[ ${PV} == "9999" ]] && inherit git autotools
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-ng-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
- #KEYWORDS=""
-else
- SRC_URI="mirror://kernel/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2
- loop-aes? ( http://loop-aes.sourceforge.net/updates/util-linux-ng-2.17.1-20100308.diff.bz2 )"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="crypt loop-aes nls old-linux perl selinux slang uclibc unicode"
-
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
- !<sys-libs/e2fsprogs-libs-1.41.8
- !<sys-fs/e2fsprogs-1.41.8
- perl? ( dev-lang/perl )
- selinux? ( sys-libs/libselinux )
- slang? ( sys-libs/slang )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/os-headers"
-
-src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
- autopoint --force
- eautoreconf
- else
- use loop-aes && epatch "${WORKDIR}"/util-linux-ng-*.diff
- fi
- use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
- epatch "${FILESDIR}"/${P}-ncursesw.patch
- epatch "${FILESDIR}"/${P}-slang.patch #326373
- elibtoolize
-}
-
-lfs_fallocate_test() {
- # Make sure we can use fallocate with LFS #300307
- cat <<-EOF > "${T}"/fallocate.c
- #define _GNU_SOURCE
- #include <fcntl.h>
- main() { return fallocate(0, 0, 0, 0); }
- EOF
- append-lfs-flags
- $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.c -o /dev/null >/dev/null 2>&1 \
- || export ac_cv_func_fallocate=no
- rm -f "${T}"/fallocate.c
-}
-
-src_configure() {
- lfs_fallocate_test
- econf \
- $(use_enable nls) \
- --enable-agetty \
- --enable-cramfs \
- $(use_enable old-linux elvtune) \
- --disable-init \
- --disable-kill \
- --disable-last \
- --disable-mesg \
- --enable-partx \
- --enable-raw \
- --enable-rename \
- --disable-reset \
- --disable-login-utils \
- --enable-schedutils \
- --disable-wall \
- --enable-write \
- --without-pam \
- $(use unicode || echo --with-ncurses) \
- $(use_with selinux) \
- $(use_with slang) \
- $(tc-has-tls || echo --disable-tls)
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS NEWS README* TODO docs/*
-
- if ! use perl ; then #284093
- rm "${D}"/usr/bin/chkdupexe || die
- rm "${D}"/usr/share/man/man1/chkdupexe.1 || die
- fi
-
- # need the libs in /
- gen_usr_ldscript -a blkid uuid
- # e2fsprogs-libs didnt install .la files, and .pc work fine
- rm -f "${D}"/usr/$(get_libdir)/*.la
-
- if use crypt ; then
- newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
- newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
- fi
-}