summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-01-24 08:02:08 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-01-24 08:02:08 +0000
commit34fddef43833b519d7117a9ba95e647c001f9bc5 (patch)
treea0da76103863341116980b14587cc33a56aa7c90 /sys-apps/xfsprogs
parentup-da-to (diff)
downloadhistorical-34fddef43833b519d7117a9ba95e647c001f9bc5.tar.gz
historical-34fddef43833b519d7117a9ba95e647c001f9bc5.tar.bz2
historical-34fddef43833b519d7117a9ba95e647c001f9bc5.zip
new up-to-date XFS utils
Diffstat (limited to 'sys-apps/xfsprogs')
-rw-r--r--sys-apps/xfsprogs/files/digest-xfsprogs-200201241
-rw-r--r--sys-apps/xfsprogs/xfsprogs-20020124.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/sys-apps/xfsprogs/files/digest-xfsprogs-20020124 b/sys-apps/xfsprogs/files/digest-xfsprogs-20020124
new file mode 100644
index 000000000000..432516f563a9
--- /dev/null
+++ b/sys-apps/xfsprogs/files/digest-xfsprogs-20020124
@@ -0,0 +1 @@
+MD5 3b538a21f9d98f0cf7ab1ddde9086623 xfs-cmd-20020124.tar.bz2 1564672
diff --git a/sys-apps/xfsprogs/xfsprogs-20020124.ebuild b/sys-apps/xfsprogs/xfsprogs-20020124.ebuild
new file mode 100644
index 000000000000..d92f7729c7e7
--- /dev/null
+++ b/sys-apps/xfsprogs/xfsprogs-20020124.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/xfsprogs-20020124.ebuild,v 1.1 2002/01/24 08:02:08 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="xfs filesystem utilities"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/e2fsprogs"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} DK_INC_DIR=${D}/usr/include/disk install install-dev || die
+}