summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-01-27 17:35:52 +0000
committerSimon Stelling <blubb@gentoo.org>2006-01-27 17:35:52 +0000
commit186a33ab9c4060ee6af504caa01a07c475558259 (patch)
treea816c72022aceefd67611a3d8103e0c99867bc03 /sys-apps
parentFix modular X deps. (diff)
downloadhistorical-186a33ab9c4060ee6af504caa01a07c475558259.tar.gz
historical-186a33ab9c4060ee6af504caa01a07c475558259.tar.bz2
historical-186a33ab9c4060ee6af504caa01a07c475558259.zip
fix problem stated in bug 118108 comment 6
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dnotify/ChangeLog6
-rw-r--r--sys-apps/dnotify/Manifest5
-rw-r--r--sys-apps/dnotify/dnotify-0.18.0.ebuild11
-rw-r--r--sys-apps/dnotify/files/dnotify-0.18.0-nls.patch10
4 files changed, 28 insertions, 4 deletions
diff --git a/sys-apps/dnotify/ChangeLog b/sys-apps/dnotify/ChangeLog
index e84164f06d67..8096f317f011 100644
--- a/sys-apps/dnotify/ChangeLog
+++ b/sys-apps/dnotify/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/dnotify
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/ChangeLog,v 1.20 2006/01/27 15:41:47 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/ChangeLog,v 1.21 2006/01/27 17:35:52 blubb Exp $
+
+ 27 Jan 2006; Simon Stelling <blubb@gentoo.org>
+ +files/dnotify-0.18.0-nls.patch, dnotify-0.18.0.ebuild:
+ fix problem stated in bug 118108 comment 6
27 Jan 2006; Simon Stelling <blubb@gentoo.org> dnotify-0.18.0.ebuild:
stable on amd64
diff --git a/sys-apps/dnotify/Manifest b/sys-apps/dnotify/Manifest
index baf7936ff72e..d66704bba5cc 100644
--- a/sys-apps/dnotify/Manifest
+++ b/sys-apps/dnotify/Manifest
@@ -1,8 +1,9 @@
-MD5 fcb413e27630f8be35df0767025d0ce6 ChangeLog 2573
+MD5 c0bd2539cbc1cb8f6a10d130086aca32 ChangeLog 2726
MD5 6c7bb398eed508763fbeba9a60fc7f4f dnotify-0.16.0.ebuild 832
MD5 7937cf7aa994fff87966b6f92b3efdb3 dnotify-0.17.1.ebuild 719
-MD5 df6035f54025ecfaa9d7b58305a03073 dnotify-0.18.0.ebuild 718
+MD5 f558dc4574ee2d9214fa873c7b1cb461 dnotify-0.18.0.ebuild 810
MD5 286c6f49267c740d89cc3b9315172301 files/digest-dnotify-0.16.0 66
MD5 064c626efc734f07a2d6f5ce4de5e1f0 files/digest-dnotify-0.17.1 66
MD5 1b56ee3ed03445117aa35b1efb48578a files/digest-dnotify-0.18.0 66
+MD5 00b6b095200c67a67f5f5a8db20311c3 files/dnotify-0.18.0-nls.patch 248
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
diff --git a/sys-apps/dnotify/dnotify-0.18.0.ebuild b/sys-apps/dnotify/dnotify-0.18.0.ebuild
index 662b20a1d35f..e692acaa77bf 100644
--- a/sys-apps/dnotify/dnotify-0.18.0.ebuild
+++ b/sys-apps/dnotify/dnotify-0.18.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/dnotify-0.18.0.ebuild,v 1.7 2006/01/27 15:41:47 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/dnotify-0.18.0.ebuild,v 1.8 2006/01/27 17:35:52 blubb Exp $
+
+inherit eutils
DESCRIPTION="Execute a command when the contents of a directory change"
HOMEPAGE="http://oskarsapps.mine.nu/dnotify.html"
@@ -13,6 +15,13 @@ IUSE="nls"
DEPEND="nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-nls.patch
+}
+
src_compile() {
econf $(use_enable nls) || die "failed to configure"
emake || die "failed to make"
diff --git a/sys-apps/dnotify/files/dnotify-0.18.0-nls.patch b/sys-apps/dnotify/files/dnotify-0.18.0-nls.patch
new file mode 100644
index 000000000000..7721ac1ee411
--- /dev/null
+++ b/sys-apps/dnotify/files/dnotify-0.18.0-nls.patch
@@ -0,0 +1,10 @@
+--- src/gettext.h.orig 2006-01-27 18:23:31.000000000 +0100
++++ src/gettext.h 2006-01-27 18:25:07.000000000 +0100
+@@ -24,6 +24,7 @@
+
+ /* Get declarations of GNU message catalog functions. */
+ # include <libintl.h>
++# include <locale.h>
+
+ #else
+