summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNate Underwood <natey@gentoo.org>2003-06-10 21:45:17 +0000
committerNate Underwood <natey@gentoo.org>2003-06-10 21:45:17 +0000
commit5100d3f971746e5b49cd68094c6be2f14e1642a6 (patch)
tree2552c0ff5265f618c1fb13f96591d8d2079ba9c8 /sys-apps
parentEbuild version bump for new systrace userland sources (diff)
downloadhistorical-5100d3f971746e5b49cd68094c6be2f14e1642a6.tar.gz
historical-5100d3f971746e5b49cd68094c6be2f14e1642a6.tar.bz2
historical-5100d3f971746e5b49cd68094c6be2f14e1642a6.zip
Ebuild version bump for new systrace userland sources
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systrace/Manifest2
-rw-r--r--sys-apps/systrace/files/digest-systrace-1.0-r32
-rw-r--r--sys-apps/systrace/systrace-1.0-r3.ebuild66
3 files changed, 69 insertions, 1 deletions
diff --git a/sys-apps/systrace/Manifest b/sys-apps/systrace/Manifest
index e3124ed9bbe8..8bf38a79cecd 100644
--- a/sys-apps/systrace/Manifest
+++ b/sys-apps/systrace/Manifest
@@ -1,5 +1,5 @@
MD5 8bc5899387c733b60f0c3a5b4bd15990 systrace-1.0-r1.ebuild 1830
-MD5 e5464f6876c350ea044a017a9ebf103e ChangeLog 770
+MD5 8d08e6007f61197d3e87b08886593b9e ChangeLog 927
MD5 2760c8cbd7856c70feb28c383979961e systrace-1.0-r2.ebuild 1799
MD5 d464510a263517aba10ca7bf00c5cadc systrace-1.0-r3.ebuild 1727
MD5 8f7c88d1249a2c3d03176b5b52bb88c3 files/digest-systrace-1.0-r1 147
diff --git a/sys-apps/systrace/files/digest-systrace-1.0-r3 b/sys-apps/systrace/files/digest-systrace-1.0-r3
new file mode 100644
index 000000000000..e3b59b5dc404
--- /dev/null
+++ b/sys-apps/systrace/files/digest-systrace-1.0-r3
@@ -0,0 +1,2 @@
+MD5 deb326542b03c23729a49d291e262406 usr-systrace-2003-06-03.tar.gz 170343
+MD5 991caa03d07abeb2a5e9bb27bfee2123 systrace.c-no_x11-1.0.patch.gz 275
diff --git a/sys-apps/systrace/systrace-1.0-r3.ebuild b/sys-apps/systrace/systrace-1.0-r3.ebuild
new file mode 100644
index 000000000000..f3df0587e22a
--- /dev/null
+++ b/sys-apps/systrace/systrace-1.0-r3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+
+DESCRIPTION="Systrace userland binary"
+HOMEPAGE="http://www.systrace.org"
+SRC_URI="http://www.citi.umich.edu/u/provos/systrace/usr-systrace-2003-06-03.tar.gz
+ http://cvs.gentoo.org/~natey/systrace/patches/systrace.c-no_x11-1.0.patch.gz"
+SLOT="0"
+LICENSE="GPL-2"
+PATCH1="systrace.c-no_x11-1.0.patch"
+INCLUDE="/usr/include/linux/systrace.h"
+S="${WORKDIR}/${P}"
+
+KEYWORDS="~x86"
+IUSE="gtk"
+DEPEND="gtk? ( =x11-libs/gtk+-1.2* =dev-libs/glib-1.2* )"
+
+pkg_setup() {
+ if ! [ -f ${INCLUDE} ] ;
+ then
+ einfo
+ einfo "ERROR: It does not look like you have a systrace capable kernel. If"
+ einfo "this is incorrect, please copy /usr/src/linux/include/linux/systrace.h"
+ einfo "to /usr/include/linux/ and restart the build."
+ einfo
+ einfo "The latest systrace Linux kernel patches can be found at:"
+ einfo
+ einfo "http://www.citi.umich.edu/u/provos/systrace/linux.html"
+ einfo
+ exit 1
+ fi
+}
+
+src_compile() {
+ if [ "`use gtk`" ]
+ then
+ einfo
+ einfo "You are building systrace with gtk support; this version will not"
+ einfo "function without the sys-apps/gtk-systrace package installed. Please"
+ einfo "set the USE=\"-gtk\" to build the non-gui capable version of systrace."
+ einfo
+ sleep 7
+ ./configure --host=${CHOST} || die
+ elif [ -z "`use gtk`" ]
+ then
+ einfo
+ einfo "You are building systrace without gtk support; please set USE=\"gtk\""
+ einfo "to build the gui capable version of systrace."
+ einfo
+ sleep 7
+ cd ${S}
+ epatch ../${PATCH1} || die
+ ./configure --host=${CHOST} || die
+ fi
+
+ emake || die
+}
+
+src_install() {
+ dobin systrace
+ exeinto /usr/bin
+
+ doman systrace.1
+}