summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2002-06-20 06:17:51 +0000
committerMark Guertin <gerk@gentoo.org>2002-06-20 06:17:51 +0000
commit5f06da0614c71cc0ffa767cfe0c8c5cc2927f5c4 (patch)
treeb9d63476475cd85ba48c66f4a25ea1da9a53feba /sys-apps
parentmasked hfsplusutils for testing (diff)
downloadhistorical-5f06da0614c71cc0ffa767cfe0c8c5cc2927f5c4.tar.gz
historical-5f06da0614c71cc0ffa767cfe0c8c5cc2927f5c4.tar.bz2
historical-5f06da0614c71cc0ffa767cfe0c8c5cc2927f5c4.zip
Added initial hfsplusutils build
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hfsplusutils/Changelog10
-rw-r--r--sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild47
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/hfsplusutils/Changelog b/sys-apps/hfsplusutils/Changelog
new file mode 100644
index 000000000000..2c5a82e11b38
--- /dev/null
+++ b/sys-apps/hfsplusutils/Changelog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-apps/hfsplusutils
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hfsplusutils/Changelog,v 1.1 2002/06/20 06:17:51 gerk Exp $
+
+*hfsplusutils-1.0.4 (June 17, 2002)
+
+June 20, 2002; Gerk <gerk@gentoo.org>:
+
+ This is an initial ebuild for hfsplusutils 1.0.4 for ppc machines.
+
diff --git a/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild b/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild
new file mode 100644
index 000000000000..f04b23627db3
--- /dev/null
+++ b/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild,v 1.1 2002/06/20 06:17:51 gerk Exp $
+
+A="hfsplus_1.0.4.src.tar.bz2"
+S=${WORKDIR}/hfsplus-1.0.4
+DESCRIPTION="HFS+ FS Access utils (read only)"
+SRC_URI="http://ftp.penguinppc.org/users/hasi/${A}"
+HOMEPAGE="http://ftp.penguinppc.org/users/hasi/"
+DEPEND="sys-devel/autoconf
+ sys-devel/automake
+ sys-apps/bzip2"
+RDEPEND=""
+LICENSE="GPL"
+SLOT="0"
+
+MAKEOPTS='PREFIX=/usr MANDIR=/usr/share/man'
+
+if [ ${ARCH} = "x86" ] ; then
+ einfo "Sorry, this is a PPC only utility"
+ exit 1
+fi
+
+src_compile() {
+ # This does a autoconf, automake, etc.
+ emake -f Makefile.cvs all || die
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/lib
+ dodir /usr/share/man
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+ mkdir ${D}/usr/share/man/man1
+ cp doc/man/hfsp.man ${D}/usr/share/man/man1/hfsp.1
+}
+