summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaarten Thibaut <murphy@gentoo.org>2002-04-16 01:51:17 +0000
committerMaarten Thibaut <murphy@gentoo.org>2002-04-16 01:51:17 +0000
commit817995caa6d44f750ce6c01fff58c05241426fc8 (patch)
tree20c86c0aeeeb7c1995d4fcd3572aa970d3fe86ce /sys-apps
parentUtilities specific to SPARC architectures (diff)
downloadhistorical-817995caa6d44f750ce6c01fff58c05241426fc8.tar.gz
historical-817995caa6d44f750ce6c01fff58c05241426fc8.tar.bz2
historical-817995caa6d44f750ce6c01fff58c05241426fc8.zip
Boot loader for SPARC (untested)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/silo/files/digest-silo-1.2.51
-rw-r--r--sys-apps/silo/files/silo_1.2.5-1.diff713
-rw-r--r--sys-apps/silo/silo-1.2.5.ebuild22
3 files changed, 736 insertions, 0 deletions
diff --git a/sys-apps/silo/files/digest-silo-1.2.5 b/sys-apps/silo/files/digest-silo-1.2.5
new file mode 100644
index 000000000000..4d20805d7f11
--- /dev/null
+++ b/sys-apps/silo/files/digest-silo-1.2.5
@@ -0,0 +1 @@
+MD5 3d4c0c84873f1ea30c4474892b4a852b silo-1.2.5.tar.bz2 146843
diff --git a/sys-apps/silo/files/silo_1.2.5-1.diff b/sys-apps/silo/files/silo_1.2.5-1.diff
new file mode 100644
index 000000000000..0dbcda8a08cf
--- /dev/null
+++ b/sys-apps/silo/files/silo_1.2.5-1.diff
@@ -0,0 +1,713 @@
+--- silo-1.2.5.orig/bugs/silo
++++ silo-1.2.5/bugs/silo
+@@ -0,0 +1,7 @@
++Bug ID: 34897
++Summary: doesn't comprehend cprboot stuff
++Severity: wishlist
++Package: silo
++Submitter: Adam Di Carlo <adam@onshore.com>
++Date Submitted: Mon, 22 Mar 1999 16:33:00 GMT
++
+--- silo-1.2.5.orig/debian/local/siloconfig
++++ silo-1.2.5/debian/local/siloconfig
+@@ -0,0 +1,103 @@
++#!/usr/bin/perl
++#
++# /usr/sbin/siloconfig configure silo automatically
++# this program is a modified version of liloconfig
++# which is copyright by
++# Author: Bruce Perens <bruce@Pixar.com>
++# Maintainer: Bernd Eckenfels <ecki@debian.org>
++
++# siloconfig (C) 1998 Davide Barbieri <paci@debian.org>
++# (C) 2001 Ben Collins <bcollins@debian.org>
++# this software is GPLed
++
++$|=1;
++
++if ( ! (-f "/etc/fstab") ) {
++ exit(0);
++}
++
++if ($ENV{'DEBIAN_FRONTEND'} eq "noninteractive") {
++ print "\nNon-interactive, skipping silo configuration.\n";
++ exit(0);
++}
++
++print "SILO, the Sparc Improved Linux LOader, sets up your system to boot Linux\n";
++print "directly from your hard disk, without the need for a boot floppy or a net\n";
++print "boot.\n";
++
++@boilerplate = (
++ "# Generated by siloconfig\n",
++ "# (C) 1998 1999 Davide Barbieri <paci\@debian.org>\n",
++ "# partition=3\n",
++ "# install=/boot/boot.b\n",
++ "# map=/boot/map\n",
++ "message=/etc/motd\n",
++ "timeout=20\n",
++ "image=/vmlinuz\n",
++ "label=Linux\n",
++ "read-only\n"
++);
++
++sub asky {
++ print @_,"? [Yes] ";
++ $answer=<STDIN>;
++ return ( !($answer =~ /^[nN].*/) );
++}
++
++sub askn {
++ print @_,"? [No] ";
++ $answer=<STDIN>;
++ return ( $answer =~ /^[yY].*/ );
++}
++
++if (-T "/etc/silo.conf") {
++ # Trust and use the existing silo.conf.
++ print "\n";
++ print "You already have a SILO configuration in the file /etc/silo.conf\n";
++ if ( &asky("Install a boot block using your current SILO configuration") ) {
++ print "Running silo\n";
++ system("/sbin/silo -f");
++ exit(0);
++ } else {
++ print "\n";
++ if ( &askn("Wipe out your old SILO configuration and make a new one") ) {
++ print "Saving configuration in /etc/silo.conf.OLD\n";
++ rename("/etc/silo.conf", "/etc/silo.conf.OLD");
++ } else {
++ print "No changes made.\n";
++ exit(0);
++ }
++ }
++}
++
++# Create a silo.conf if one doesn't exist.
++open(FSTAB, "</etc/fstab");
++while ( $line=<FSTAB> ) {
++ if ( $line =~ m/^\#/ ) {
++ next;
++ }
++ ($device,$filesystem)=split(/[ \t]+/, $line);
++ if ( $filesystem =~ m:^/$: ) {
++ last;
++ }
++}
++if ( ! $filesystem =~ m:^/$: ) {
++ exit(0);
++}
++
++$disk = $device;
++$disk =~ s/[0-9]+$//;
++$partition = $device;
++$partition =~ s/$disk//;
++
++if ( &asky("Install a partition boot record to boot Linux from ", $device)) {
++ print "Creating small silo.conf and running silo.\n";
++ umask(022);
++ open(CONF, ">/etc/silo.conf");
++ chown(0, 0, "/etc/silo.conf");
++ print CONF "partition=".$partition, "\n", "root=".$device, "\n", @boilerplate;
++ close(CONF);
++ system("/sbin/silo -f");
++}
++
++exit(0);
+--- silo-1.2.5.orig/debian/packages.d/silo.in
++++ silo-1.2.5/debian/packages.d/silo.in
+@@ -0,0 +1,10 @@
++%conffiles%
++/etc/silo.conf
++%undocumented%
++siloconfig.8
++silocheck.8
++%postinst%
++#!/bin/sh
++/usr/sbin/siloconfig
++
++#DEBHELPER#
+--- silo-1.2.5.orig/debian/scripts/dbs-build.mk
++++ silo-1.2.5/debian/scripts/dbs-build.mk
+@@ -0,0 +1,92 @@
++#!/usr/bin/make -f
++# Separate tarball/patch build system by Adam Heath <doogie@debian.org>
++# Modified by Ben Collins <bcollins@debian.org>
++
++SHELL := /bin/bash -e
++SOURCE_DIR := build-tree
++STAMP_DIR := stampdir
++PATCH_DIR := debian/patches
++
++patched := $(STAMP_DIR)/patch
++unpacked := $(STAMP_DIR)/unpack
++
++ifdef TAR_DIR
++ BUILD_TREE := $(SOURCE_DIR)/$(TAR_DIR)
++else
++ BUILD_TREE := $(SOURCE_DIR)
++endif
++
++dh_mak_deps := $(shell DH_COMPAT=$(DH_COMPAT) perl debian/scripts/dh_split makedeps)
++dh_gen_deps := $(shell DH_COMPAT=$(DH_COMPAT) perl debian/scripts/dh_split gendeps)
++
++$(dh_mak_deps): $(dh_gen_deps)
++ perl debian/scripts/dh_split
++
++setup: $(dh_mak_deps)
++ dh_testdir
++ @-up-scripts
++ $(MAKE) -f debian/rules $(unpacked) $(patched)
++
++$(patched)/: $(STAMP_DIR)/created $(unpacked)
++ test -d $(STAMP_DIR)/patches || mkdir -p $(STAMP_DIR)/patches
++ @if [ -d "$(PATCH_DIR)" ]; then \
++ mkdir -p $(STAMP_DIR)/log/patches; \
++ for f in `(cd $(PATCH_DIR); find -type f ! -name 'chk-*') | sort | \
++ sed s,'./',,g`; do \
++ stampfile=$(STAMP_DIR)/patches/$$f; \
++ log=$(STAMP_DIR)/log/patches/$$f; \
++ if [ ! -e $$stampfile ]; then \
++ echo -n "Applying patch $(PATCH_DIR)/$$f ... "; \
++ if $(SHELL) debian/scripts/file2cat $(PATCH_DIR)/$$f | \
++ (cd $(BUILD_TREE);patch -p1 --no-backup-if-mismatch) > $$log 2>&1; then \
++ echo successful.; \
++ touch $$stampfile; \
++ else \
++ echo "failed! (check $$log for reason)"; \
++ exit 1; \
++ fi; \
++ else \
++ echo Already applied $(PATCH_DIR)/$$f.; \
++ fi; \
++ done; \
++ fi
++ touch $@
++
++$(unpacked): $(STAMP_DIR)/created
++ mkdir -p $(STAMP_DIR)/sources $(SOURCE_DIR) $(STAMP_DIR)/log/sources
++ @for f in `find . -type f -maxdepth 1 -name \*.tgz -o -name \*.tar.gz -o \
++ -name \*.tar.bz -o -name \*.tar.bz2 | sort | sed s,'./',,g`; do \
++ stampfile=$(STAMP_DIR)/sources/`basename $$f`; \
++ log=$(STAMP_DIR)/log/sources/`basename $$f`; \
++ if [ ! -e $$stampfile ]; then \
++ echo -n "Extracting source $$f ... "; \
++ if $(SHELL) debian/scripts/file2cat $$f | \
++ (cd $(SOURCE_DIR); tar xv) > $$log 2>&1; then \
++ echo successful.; \
++ touch $$stampfile; \
++ else \
++ echo failed!; \
++ exit 1; \
++ fi; \
++ else \
++ echo Already unpacked $$f.; \
++ fi; \
++ done
++ touch $@
++
++make_patch:
++ mv $(BUILD_TREE) $(BUILD_TREE).new
++ rm -rf $(STAMP_DIR)
++ $(MAKE) -f debian/rules $(unpacked) $(patched)
++ifndef TAR_DIR
++ diff -urN $(BUILD_TREE) $(BUILD_TREE).new > new.diff
++else
++ (cd $(SOURCE_DIR) && diff -urN $(TAR_DIR) $(TAR_DIR).new || true) > new.diff
++endif
++ rm -rf $(BUILD_TREE)
++ mv $(BUILD_TREE).new $(BUILD_TREE)
++ @echo; ls -l new.diff
++
++$(STAMP_DIR)/created:
++ test -d $(STAMP_DIR) || mkdir $(STAMP_DIR)
++ touch $(STAMP_DIR)/created
+--- silo-1.2.5.orig/debian/scripts/dh_split
++++ silo-1.2.5/debian/scripts/dh_split
+@@ -0,0 +1,83 @@
++#!/usr/bin/perl
++
++$control = 'debian/control';
++if ( -d 'debian/packages.d' ) {
++ $dir = 'debian/packages.d';
++} else {
++ $dir = 'debian';
++}
++$needclean = 0;
++$needlist = 0;
++$needdeps = 0;
++
++if (defined($ENV{'DH_COMPAT'})) {
++ $dh = $ENV{'DH_COMPAT'};
++} else {
++ $dh = 0;
++}
++
++if (@ARGV) {
++ $temp = shift;
++ if ($temp eq "clean") { $needclean = 1; }
++ elsif ($temp eq "makedeps") { $needlist = 1; }
++ elsif ($temp eq "gendeps") { $needdeps = 1; }
++}
++
++@packages = ();
++$first_package = "";
++
++open (CONTROL, "< $control");
++
++while (<CONTROL>) {
++ if (m/^Package:/) {
++ $package = (split)[1];
++ if ($first_package eq "" and $dh < 2) {
++ $first_package = $package;
++ }
++ if ( -f "${dir}/${package}.in" ) {
++ push @packages, $package;
++ }
++ }
++}
++
++close CONTROL;
++
++while (@packages) {
++ $package = shift(@packages);
++ $inhead = 1;
++ $opened = 0;
++ if ($needdeps) {
++ print "${dir}/${package}.in ";
++ next;
++ }
++ open (IN, "< ${dir}/${package}.in");
++ while (<IN>) {
++ if (m/^\%(.*)\%$/) {
++ if ($needclean) {
++ if ($package ne $first_package) {
++ system("rm -f debian/${package}.${1}");
++ } else {
++ system("rm -f debian/${1}");
++ }
++ } elsif ($needlist) {
++ if ($package ne $first_package) {
++ print "debian/${package}.${1} ";
++ } else {
++ print "debian/${1} ";
++ }
++ } else {
++ $inhead = 0;
++ if ($opened) { close OUT; } else { $opened = 1; }
++ if ($package ne $first_package) {
++ open OUT, "> debian/${package}.${1}";
++ } else {
++ open OUT, "> debian/${1}";
++ }
++ }
++ } elsif (!$inhead) {
++ print OUT $_;
++ }
++ }
++ close OUT;
++ close IN;
++}
+--- silo-1.2.5.orig/debian/scripts/file2cat
++++ silo-1.2.5/debian/scripts/file2cat
+@@ -0,0 +1,13 @@
++#!/bin/sh
++
++if [ "$1" = "" ]; then
++ echo "Usage: file2cat <file>"
++ exit 1
++fi
++
++case "$1" in
++ *.gz|*.Z|*.tgz) cmd=zcat;;
++ *.bz|*.bz2) cmd=bzcat;;
++ *) cmd=cat;;
++esac
++$cmd $1
+--- silo-1.2.5.orig/debian/README.build
++++ silo-1.2.5/debian/README.build
+@@ -0,0 +1,20 @@
++This package uses a form of source build based on DBS. To setup the
++source, run "debian/rules setup". This will extract the pristine source in
++build-dir/, apply patches from debian/patches/ and split the package
++scripts from debian/packages.d/ into their component files.
++
++A few cavaets. Modifying the source in build-tree/ or the package files in
++debian/, will not be preserved after the "clean" target is run. Actual
++files for packages are in debian/packages.d/ and will be regerated after
++being modified.
++
++To create patches for the source, you can remember several steps. There
++are two targes for handling source. The "unpack" target, will simply
++unpack the tarball(s) into build-tree/ and "patch" will apply all patches
++from debian/patches/. If you make any changes you can generate a new patch
++using the "make_patch" target. This will move your current sources under
++build-tree/, unpack the source+patches again, and then generate a diff
++between the two. Note, you should run the "clean" target in the
++build-tree/ source before doing this, to get a clean patch.
++
++Ben
+--- silo-1.2.5.orig/debian/TODO
++++ silo-1.2.5/debian/TODO
+@@ -0,0 +1,4 @@
++- Make use of silocheck so we can ensure older PROM's will be able to boot
++ (1 GB limit thing).
++- Write a visilo program/script that edits the file, then runs
++ siloconfcheck before making it active.
+--- silo-1.2.5.orig/debian/changelog
++++ silo-1.2.5/debian/changelog
+@@ -0,0 +1,231 @@
++silo (1.2.5-1) unstable; urgency=low
++
++ * New upstream version. Fixes a first stage boot loader bug.
++
++ -- Ben Collins <bcollins@debian.org> Fri, 29 Mar 2002 13:36:49 -0500
++
++silo (1.2.4-1) unstable; urgency=low
++
++ * New upstream fixes TILO buglet.
++
++ -- Ben Collins <bcollins@debian.org> Tue, 13 Nov 2001 21:59:00 -0500
++
++silo (1.2.3-1) unstable; urgency=low
++
++ * New upstream, fixes tilo.
++
++ -- Ben Collins <bcollins@debian.org> Fri, 10 Aug 2001 00:32:23 -0400
++
++silo (1.2.2-1) unstable; urgency=low
++
++ * New upstream.
++
++ -- Ben Collins <bcollins@debian.org> Sat, 16 Jun 2001 11:11:45 -0400
++
++silo (1.2.0-1) unstable; urgency=low
++
++ * New upstream.
++
++ -- Ben Collins <bcollins@debian.org> Fri, 8 Jun 2001 12:56:59 -0400
++
++silo (1.1.0-1) unstable; urgency=low
++
++ * New upstream, adds support for tab completion on prom console, and
++ also supports booting fujitsu sparc64 systems.
++ * Added build-depends.
++ * Changed priority from required to important, as per dinstall
++ overrides.
++
++ -- Ben Collins <bcollins@debian.org> Mon, 28 May 2001 14:26:27 -0400
++
++silo (1.0.1-1) unstable; urgency=low
++
++ * New upstream.
++ * Update silo1440k images.
++ * Make siloconfig recognize a non-interactive install, and skip running.
++
++ -- Ben Collins <bcollins@debian.org> Mon, 28 May 2001 10:56:42 -0400
++
++silo (1.0-1) unstable; urgency=high
++
++ * Hey, I'm upstream maintainer now!
++ * New upstream release. All patches merged.
++ * Now includes tilo/maketilo. Replaces older sparc-utils
++
++ -- Ben Collins <bcollins@debian.org> Wed, 23 May 2001 12:30:05 -0400
++
++silo (0.9.9.1-1) unstable; urgency=high
++
++ * Provide the silo1440k base images for boot-floppies. This way, it
++ doesn't have to be included on the root.bin, and we save about 100k
++ * Urgency high, for boot-floppies
++
++ -- Ben Collins <bcollins@debian.org> Thu, 17 May 2001 20:22:15 -0400
++
++silo (0.9.9.0-2) unstable; urgency=high
++
++ * Call confcheck() after chroot()
++
++ -- Ben Collins <bcollins@debian.org> Thu, 17 May 2001 14:36:50 -0400
++
++silo (0.9.9.0-1) unstable; urgency=low
++
++ * Convert to using a db style source format. The silo upstream tarball
++ contains some binary files that get changed during build. This makes
++ it easier to contend with that fact.
++ * Merged the conf check into the silo program itself. Right now it
++ verifies irregardless. Next version I'll make it have an option to
++ turn that off, or ignore failures.
++ * This is not a new upstream. The pools setup does not allow me to do a
++ new full source upload of the same version. Lucky for us, dpkg allows
++ a .0 extended version to be > one without...dpkg is good for something
++ :)
++
++ -- Ben Collins <bcollins@debian.org> Thu, 28 Dec 2000 08:32:40 -0500
++
++silo (0.9.9-5) unstable; urgency=low
++
++ * Fix typo in cfg.c
++ * Added siloconfcheck to siloconfig
++
++ -- Ben Collins <bcollins@debian.org> Wed, 27 Dec 2000 16:55:50 -0500
++
++silo (0.9.9-4) unstable; urgency=low
++
++ * Created siloconfcheck program that validates a silo.conf file using
++ the same rules (IOW, the exact same functions) used by the silo second
++ stage boot loader. Helpful for validating conf files. closes: #38298
++
++ -- Ben Collins <bcollins@debian.org> Wed, 27 Dec 2000 12:55:09 -0500
++
++silo (0.9.9-3) unstable; urgency=low
++
++ * Changed priority to required, and make essential yes. There are a few
++ cases (netboot) where silo isn't needed, but the thing is, we want
++ people to know they might mess up their systems when removing this. So
++ we force them to take that extra step.
++
++ -- Ben Collins <bcollins@debian.org> Wed, 27 Dec 2000 08:57:29 -0500
++
++silo (0.9.9-2) unstable; urgency=low
++
++ * Taking over this package.
++ * Latest version accepts kernel 2.2 ext2 features. closes: #79823
++ * I believe this is fixed in the latest version. closes: #56500
++ * This bug is already marked fixed. closes: #61389
++ * I don't think SILO will ever understand Solaris boot options. People
++ need to change the PROM commands (or our installer does), so that they
++ don't conflict. closes: #61389
++ * I think the newest version fixed this. closes: #65659
++ * This isn't a bug, but a user goofup. closes: #50729
++
++ -- Ben Collins <bcollins@debian.org> Wed, 27 Dec 2000 07:24:52 -0500
++
++silo (0.9.9-1) unstable; urgency=low
++
++ * New upstream
++ * Took over silo's packaging
++
++ -- Erick Kinnee <cerb@debian.org> Mon, 4 Sep 2000 10:54:23 -0500
++
++silo (0.9.8-1) frozen unstable; urgency=low
++
++ * NMU, requested by the maintainer
++ * New upstream version, fixes some problem with floppy and cdrom boots
++ (helps with boot-floppies and debian-cd), closes: #61389
++
++ -- Ben Collins <bcollins@debian.org> Fri, 31 Mar 2000 08:56:02 -0500
++
++silo (0.9.3-1) unstable; urgency=low
++
++ * New upstream release.
++
++ -- Davide Barbieri <paci@prosa.it> Thu, 28 Oct 1999 03:57:47 -0500
++
++silo (0.8.6-2) unstable; urgency=low
++
++ * Specify sparc architecture in control file. Before
++ it was also i386 (for intelsilo), which I should drop.
++ Comments about intelsilo?
++ This will make the life easier for autobuilder.
++
++ -- Davide Barbieri <paci@prosa.it> Fri, 15 Oct 1999 10:20:24 -0500
++
++silo (0.8.6-1) unstable; urgency=high
++
++ * New upstream release.
++
++ -- Davide Barbieri <paci@prosa.it> Sun, 18 Apr 1999 14:55:52 +0200
++
++silo (0.8.5-4) unstable; urgency=low
++
++ * This version should correct a bug in the upstream version
++ which prevent silo to boot a solaris system on a ultra
++
++ -- Davide Barbieri <paci@debian.org> Mon, 12 Apr 1999 11:55:33 +0200
++
++silo (0.8.5-3) unstable; urgency=low
++
++ * New siloconfig
++ * Changed the rules file to use debhelper
++ * Added the man page
++ * New rules to generate intelsilo by Steve Dunham <dunham@debian.org>
++
++ -- Davide Barbieri <paci@debian.org> Sat, 27 Feb 1999 15:00:52 +0100
++
++silo (0.8.5-2.1) frozen; urgency=low
++
++ * Fix to give kernel more breathing room in front of initrd
++ needed for CDROM booting on Sun4m machines. <dunham@debian.org>
++
++ -- Davide Barbieri <paci@debian.org> Fri, 26 Feb 1999 10:39:43 -0500
++
++silo (0.8.5-2) frozen; urgency=high
++
++ * This release is going to frozen, in order to
++ get debian sparc CD-ROM working.
++
++ -- Davide Barbieri <paci@debian.org> Fri, 29 Jan 1999 19:03:08 +0100
++
++silo (0.8.5-1) unstable; urgency=low
++
++ * new upstream version; it should work with bootable CD
++
++ -- Davide Barbieri <paci@debian.org> Tue, 26 Jan 1999 11:14:38 +0100
++
++silo (0.8.1-2) unstable; urgency=low
++
++ * added a patch to tell silo not to abort on dangling
++ symlinks while scanning /dev; thanks to Eric Delaunay
++ <delaunay@lix.polytechnique.fr>
++
++ -- Davide Barbieri <paci@debian.org> Tue, 24 Nov 1998 12:04:34 +0100
++
++silo (0.8.1-1) unstable; urgency=low
++
++ * new upstream version
++
++ -- Davide Barbieri <paci@debian.org> Sat, 7 Nov 1998 16:45:14 +0100
++
++silo (0.7.2-1) unstable; urgency=low
++
++ * "Added siloconfig script"
++
++ -- Davide Barbieri <paci@debian.org> Mon, 18 May 1998 16:25:53 +0000
++
++silo (0.7.2-0.1) unstable; urgency=low
++
++ * Non-maintainer, new upstream version (glibc based)
++
++ -- Juan Cespedes <cespedes@debian.org> Thu, 30 Apr 1998 12:20:51 +0200
++
++silo (0.6.7-1) unstable; urgency=low
++
++ * Initial Release.
++
++ -- Davide Barbieri <paci@debian.org> Wed, 29 Jan 1997 18:52:04 +0100
++
++Local variables:
++mode: debian-changelog
++End:
++
+--- silo-1.2.5.orig/debian/control
++++ silo-1.2.5/debian/control
+@@ -0,0 +1,17 @@
++Source: silo
++Section: base
++Priority: important
++Maintainer: Ben Collins <bcollins@debian.org>
++Build-Depends: e2fslibs-dev, debhelper
++Standards-Version: 3.2.1.0
++
++Package: silo
++Architecture: sparc
++Depends: ${shlibs:Depends}
++Replaces: sparc-utils (<< 1.8-1)
++Essential: yes
++Description: Sparc Improved Boot Loader
++ Like LILO or MILO, but for SPARC.
++ This is the program you need to use if you plan to boot SPARC/Linux
++ via a hard drive, floppy or CDROM. It installs to the boot block of
++ your system and will allow for booting of Linux, Solaris, and SunOS.
+--- silo-1.2.5.orig/debian/copyright
++++ silo-1.2.5/debian/copyright
+@@ -0,0 +1,47 @@
++This package was debianized by Davide Barbieri paci@prosa.it for
++the first time on:
++Wed, 29 Jan 1997 18:52:04 +0100.
++
++It was downloaded from
++ftp://download.sourceforge.net/pub/sourceforge/silo/
++
++Changes for Debian:
++ * Added Debian files
++
++Copyrights
++----------
++Copyright (C) Jakub Jelinek <jj@sunsite.mff.cuni.cz>
++Copyright (C) Mauricio Plaza <mok@nuclecu.unam.mx>
++Copyright (C) Donnie J. Barnes <djb@redhat.com>
++Copyright (C) Pete A. Zaitcev <Pete.A.Zaitcev@lab.sun.mcst.ru>
++Copyright (C) David S. Miller <davem@vger.rutgers.edu>
++Copyright (C) Miguel de Icaza <miguel@nuclecu.unam.mx>
++Copyright (C) Eddie C. Dost <ecd@skynet.be>
++Copyright (C) Andrew Tridgell <tridge@anu.edu.au>
++Copyright (C) Tom Dyas <tdyas@xenophanes.rutgers.edu>
++Copyright (C) The Sparc Linux Team <sparclinux@vger.rutgers.edu>
++Copyright (C) Ben Collins <bcollins@debian.org>
++
++Modifications for Debian:
++ Copyright (C) 1997 Davide Barbieri <paci@prosa.it>
++ Copyright (C) 1998 Juan Cespedes <cespedes@debian.org>
++
++
++License
++-------
++This program is free software; you can redistribute it and/or modify
++it under the terms of the GNU General Public License as published by
++the Free Software Foundation; either version 2, or (at your option)
++any later version.
++
++This program is distributed in the hope that it will be useful, but
++WITHOUT ANY WARRANTY; without even the implied warranty of
++MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++General Public License for more details.
++
++A copy of the GNU General Public License is available as
++`/usr/share/common-licenses/GPL' in the Debian GNU/Linux distribution or on
++the World Wide Web at `http://www.gnu.org/copyleft/gpl.html'. You can
++also obtain it by writing to the Free Software Foundation, Inc., 59
++Temple Place - Suite 330, Boston, MA 02111-1307, USA
++
+--- silo-1.2.5.orig/debian/rules
++++ silo-1.2.5/debian/rules
+@@ -0,0 +1,50 @@
++#!/usr/bin/make -f
++
++# the dbs rules
++TAR_DIR := silo-1.2.5
++include debian/scripts/dbs-build.mk
++
++build: $(STAMP_DIR)/build
++$(STAMP_DIR)/build: $(STAMP_DIR)/patch
++ dh_testdir
++ cd $(BUILD_TREE) && $(MAKE)
++ touch $(STAMP_DIR)/build
++
++clean:
++ dh_testdir
++ rm -rf $(STAMP_DIR) $(SOURCE_DIR)
++ perl debian/scripts/dh_split clean
++ dh_clean
++
++install: build $(dh_mak_deps)
++ dh_testdir
++ dh_testroot
++ dh_clean -k
++ dh_installdirs
++
++ cd $(BUILD_TREE) && $(MAKE) DESTDIR="$(shell pwd)/debian/tmp" \
++ install
++ install -m755 debian/local/siloconfig debian/tmp/usr/sbin/siloconfig
++ install -d -m755 debian/tmp/usr/lib/silo
++ install -m644 silo1440k* debian/tmp/usr/lib/silo/
++
++ dh_movefiles
++
++binary-indep:
++
++binary-arch: build install $(dh_mak_deps)
++ dh_testdir
++ dh_testroot
++ dh_installdocs $(BUILD_TREE)/docs/{README{,.tilo},CDROM.HOWTO}
++ dh_undocumented
++ dh_installchangelogs $(BUILD_TREE)/ChangeLog
++ dh_strip
++ dh_compress
++ dh_fixperms
++ dh_installdeb
++ dh_shlibdeps
++ dh_gencontrol
++ dh_md5sums
++ dh_builddeb
++
++binary: binary-arch
diff --git a/sys-apps/silo/silo-1.2.5.ebuild b/sys-apps/silo/silo-1.2.5.ebuild
new file mode 100644
index 000000000000..ad3ca86e41d7
--- /dev/null
+++ b/sys-apps/silo/silo-1.2.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Maarten Thibaut <murphy@gentoo.org>
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="http://www.ultralinux.nl/silo/download/${A}"
+HOMEPAGE="http://freshmeat.net/projects/silo/index.html"
+DEPEND="sys-apps/e2fsprogs sys-apps/sparc-utils"
+
+src_compile() {
+
+ try make ${MAKEOPTS}
+
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+
+}