summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-07-19 18:34:28 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-07-19 18:34:28 +0000
commit83ae1fe6832cbfe27880364d9b38acf991a814da (patch)
treef3b9f3c2ced2324432218fda0b1bed74c162d577 /sys-apps
parentStable for baselayout-1.11.13. (diff)
downloadhistorical-83ae1fe6832cbfe27880364d9b38acf991a814da.tar.gz
historical-83ae1fe6832cbfe27880364d9b38acf991a814da.tar.bz2
historical-83ae1fe6832cbfe27880364d9b38acf991a814da.zip
The ifrename utility is now in /sbin/, not /usr/sbin/, bug #96654.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hotplug/ChangeLog8
-rw-r--r--sys-apps/hotplug/files/digest-hotplug-20040923-r11
-rw-r--r--sys-apps/hotplug/files/hotplug-ifrename.patch15
-rw-r--r--sys-apps/hotplug/hotplug-20040923-r1.ebuild74
4 files changed, 97 insertions, 1 deletions
diff --git a/sys-apps/hotplug/ChangeLog b/sys-apps/hotplug/ChangeLog
index 5aeca640845a..58fd5a26d87f 100644
--- a/sys-apps/hotplug/ChangeLog
+++ b/sys-apps/hotplug/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hotplug
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.64 2005/02/05 17:20:25 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.65 2005/07/19 18:34:28 brix Exp $
+
+*hotplug-20040923-r1 (19 Jul 2005)
+
+ 19 Jul 2005; <brix@gentoo.org> +files/hotplug-ifrename.patch,
+ +hotplug-20040923-r1.ebuild:
+ The ifrename utility is now in /sbin/, not /usr/sbin/, bug #96654.
05 Feb 2005; Markus Rothe <corsair@gentoo.org> hotplug-20040923.ebuild:
Stable on ppc64
diff --git a/sys-apps/hotplug/files/digest-hotplug-20040923-r1 b/sys-apps/hotplug/files/digest-hotplug-20040923-r1
new file mode 100644
index 000000000000..9910c869236c
--- /dev/null
+++ b/sys-apps/hotplug/files/digest-hotplug-20040923-r1
@@ -0,0 +1 @@
+MD5 1542af9cbe1053cfde9421007f702cf2 hotplug-2004_09_23.tar.gz 44802
diff --git a/sys-apps/hotplug/files/hotplug-ifrename.patch b/sys-apps/hotplug/files/hotplug-ifrename.patch
new file mode 100644
index 000000000000..969874e1d07f
--- /dev/null
+++ b/sys-apps/hotplug/files/hotplug-ifrename.patch
@@ -0,0 +1,15 @@
+diff -urp hotplug-2004_09_23/etc/hotplug/net.agent hotplug-2004_09_23-ifrename/etc/hotplug/net.agent
+--- hotplug-2004_09_23/etc/hotplug/net.agent 2004-09-21 01:02:34.000000000 +0200
++++ hotplug-2004_09_23-ifrename/etc/hotplug/net.agent 2005-07-19 20:12:15.000000000 +0200
+@@ -53,9 +53,9 @@ add|register)
+ # This needs to be done before ifup otherwise ifup will get
+ # confused by the name changed and because iface need to be
+ # down to change its name.
+- if [ -x /usr/sbin/ifrename ] && [ -r /etc/iftab ]; then
++ if [ -x /sbin/ifrename ] && [ -r /etc/iftab ]; then
+ debug_mesg invoke ifrename for $INTERFACE
+- NEWNAME=`/usr/sbin/ifrename -i $INTERFACE`
++ NEWNAME=`/sbin/ifrename -i $INTERFACE`
+ if [ -n "$NEWNAME" ]; then
+ debug_mesg iface $INTERFACE is remapped to $NEWNAME
+ INTERFACE=$NEWNAME
diff --git a/sys-apps/hotplug/hotplug-20040923-r1.ebuild b/sys-apps/hotplug/hotplug-20040923-r1.ebuild
new file mode 100644
index 000000000000..f1a725a0b9a7
--- /dev/null
+++ b/sys-apps/hotplug/hotplug-20040923-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20040923-r1.ebuild,v 1.1 2005/07/19 18:34:28 brix Exp $
+
+inherit eutils
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="USB and PCI hotplug scripts"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
+IUSE=""
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND=">=sys-apps/pciutils-2.1.9
+ >=sys-apps/usbutils-0.9
+ sys-apps/hotplug-base"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # patches go here if needed...
+ epatch ${FILESDIR}/${PN}-ifrename.patch
+}
+
+src_install() {
+ into /
+ doman *.8
+ dodoc README README.modules ChangeLog
+
+ cd ${S}/etc/hotplug
+ insinto /etc/hotplug
+ doins blacklist hotplug.functions *map
+
+ exeinto /etc/hotplug
+ doexe *.agent *.rc *.permissions
+ # stupid isapnp.rc files...
+ newexe ${FILESDIR}/isapnp.rc.empty isapnp.rc
+
+ dodir /usr/lib/hotplug/firmware
+ dodir /etc/hotplug/usb
+ dodir /etc/hotplug/pci
+ cd ${S}/etc/hotplug.d/default
+ exeinto /etc/hotplug.d/default
+ doexe default.hotplug
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hotplug.rc.empty hotplug
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/usb.confd usb
+ dodir /var/run/usb
+}
+
+pkg_postinst() {
+ ewarn "WARNING: The hotplug init script is now gone (dead and burried.)"
+ ewarn "WARNING: If you want to load modules for hardware that was already"
+ ewarn "WARNING: discovered at boot time, like the old hotplug init script"
+ ewarn "WARNING: did, then emerge the coldplug package, and add coldplug to"
+ ewarn "WARNING: a runlevel, e.g. # rc-update add coldplug boot"
+ echo
+ ewarn "WARNING: All firmware loaded by the hotplug scripts needs to be"
+ ewarn "WARNING: moved to the /lib/firmware directory, as the scripts now"
+ ewarn "WARNING: expect it to be in that location."
+ echo
+ ewarn "If you still have the file /etc/hotplug/isapnp.rc on your system,"
+ ewarn "please delete it by hand, the file /etc/hotplug/pnp.rc superseeds it."
+}