summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-05 17:41:26 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-05 17:41:26 +0000
commitb054ae17c6ed25cf508b396a6330440f1cc865d2 (patch)
tree3d9815a6978dc1c123e1e53598a3e78e2c827af1 /sys-apps
parentarm/s390/sh stable (diff)
downloadhistorical-b054ae17c6ed25cf508b396a6330440f1cc865d2.tar.gz
historical-b054ae17c6ed25cf508b396a6330440f1cc865d2.tar.bz2
historical-b054ae17c6ed25cf508b396a6330440f1cc865d2.zip
old
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/util-linux-2.14.ebuild93
1 files changed, 0 insertions, 93 deletions
diff --git a/sys-apps/util-linux/util-linux-2.14.ebuild b/sys-apps/util-linux/util-linux-2.14.ebuild
deleted file mode 100644
index 699f4f03f4d9..000000000000
--- a/sys-apps/util-linux/util-linux-2.14.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.14.ebuild,v 1.2 2008/06/28 16:19:02 vapier Exp $
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
-inherit eutils
-[[ ${PV} == "9999" ]] && inherit git
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-ng-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
-else
- SRC_URI="http://www.kernel.org/pub/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2
- loop-aes? ( http://loop-aes.sourceforge.net/updates/util-linux-ng-2.14-20080624.diff.bz2 )"
-# loop-aes? ( http://loop-aes.sourceforge.net/loop-AES/loop-AES-v3.2c.tar.bz2 )"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="crypt loop-aes nls old-linux selinux slang unicode"
-
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
- >=sys-fs/e2fsprogs-1.34
- selinux? ( sys-libs/libselinux )
- slang? ( sys-libs/slang )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/os-headers"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- cd "${S}"
- ./autogen.sh || die
- else
- unpack ${A}
- cd "${S}"
- #epatch "${FILESDIR}"/${PN}-2.13-uclibc.patch #203711
- use loop-aes && epatch "${WORKDIR}"/util-linux-ng-2.14-20080624.diff
- epatch "${FILESDIR}"/${PN}-2.13.1-no-a.out.patch #221939
- fi
-}
-
-src_compile() {
- econf \
- --with-fsprobe=blkid \
- $(use_enable nls) \
- --enable-agetty \
- --enable-cramfs \
- $(use_enable old-linux elvtune) \
- --disable-init \
- --disable-kill \
- --disable-last \
- --disable-mesg \
- --enable-partx \
- --enable-raw \
- --enable-rdev \
- --enable-rename \
- --disable-reset \
- --disable-login-utils \
- --enable-schedutils \
- --disable-wall \
- --enable-write \
- --without-pam \
- $(use unicode || echo --with-ncurses) \
- $(use_with selinux) \
- $(use_with slang) \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS NEWS README* TODO docs/*
-
- if use crypt ; then
- newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
- newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
- fi
-}
-
-pkg_postinst() {
- ewarn "USE=crypt has been changed to USE=loop-aes. If you need"
- ewarn "support for it, make sure to update your USE accordingly."
-}