summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2012-10-09 20:04:47 +0000
committerSven Vermeulen <swift@gentoo.org>2012-10-09 20:04:47 +0000
commite105ba2be59a09a3dd7bab6af90b351ac3102d1e (patch)
tree50c12d6fcbf458ee5f73d5c25770ee81051cabdf /sys-apps
parentNew upstream SELinux utilities release (diff)
downloadhistorical-e105ba2be59a09a3dd7bab6af90b351ac3102d1e.tar.gz
historical-e105ba2be59a09a3dd7bab6af90b351ac3102d1e.tar.bz2
historical-e105ba2be59a09a3dd7bab6af90b351ac3102d1e.zip
New upstream SELinux utilities release
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/checkpolicy/ChangeLog7
-rw-r--r--sys-apps/checkpolicy/checkpolicy-2.1.11.ebuild41
-rw-r--r--sys-apps/policycoreutils/ChangeLog7
-rw-r--r--sys-apps/policycoreutils/policycoreutils-2.1.13-r3.ebuild138
4 files changed, 191 insertions, 2 deletions
diff --git a/sys-apps/checkpolicy/ChangeLog b/sys-apps/checkpolicy/ChangeLog
index f68f08d27106..4d8619170366 100644
--- a/sys-apps/checkpolicy/ChangeLog
+++ b/sys-apps/checkpolicy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/checkpolicy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/ChangeLog,v 1.66 2012/05/13 13:05:19 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/ChangeLog,v 1.67 2012/10/09 20:04:47 swift Exp $
+
+*checkpolicy-2.1.11 (09 Oct 2012)
+
+ 09 Oct 2012; <swift@gentoo.org> +checkpolicy-2.1.11.ebuild:
+ Introducing new upstream version
13 May 2012; <swift@gentoo.org> -checkpolicy-2.1.0.ebuild:
Removing obsoleted ebuild
diff --git a/sys-apps/checkpolicy/checkpolicy-2.1.11.ebuild b/sys-apps/checkpolicy/checkpolicy-2.1.11.ebuild
new file mode 100644
index 000000000000..7ef246baa006
--- /dev/null
+++ b/sys-apps/checkpolicy/checkpolicy-2.1.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/checkpolicy-2.1.11.ebuild,v 1.1 2012/10/09 20:04:47 swift Exp $
+
+inherit toolchain-funcs
+
+SEPOL_VER="2.1.8"
+SEMNG_VER="2.1.9"
+
+DESCRIPTION="SELinux policy compiler"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120924/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=sys-libs/libsemanage-${SEMNG_VER}
+ sys-devel/flex
+ sys-devel/bison"
+
+RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" YACC="bison -y" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use debug; then
+ dobin "${S}/test/dismod"
+ dobin "${S}/test/dispol"
+ fi
+}
+
+pkg_postinst() {
+ einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
+}
diff --git a/sys-apps/policycoreutils/ChangeLog b/sys-apps/policycoreutils/ChangeLog
index 987f7d672218..4460a3bb2316 100644
--- a/sys-apps/policycoreutils/ChangeLog
+++ b/sys-apps/policycoreutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/policycoreutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.105 2012/10/06 16:39:54 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.106 2012/10/09 20:03:12 swift Exp $
+
+*policycoreutils-2.1.13-r3 (09 Oct 2012)
+
+ 09 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r3.ebuild:
+ Introducing new upstream release
06 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.10-r5.ebuild:
Stabilize
diff --git a/sys-apps/policycoreutils/policycoreutils-2.1.13-r3.ebuild b/sys-apps/policycoreutils/policycoreutils-2.1.13-r3.ebuild
new file mode 100644
index 000000000000..798cfa599381
--- /dev/null
+++ b/sys-apps/policycoreutils/policycoreutils-2.1.13-r3.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-2.1.13-r3.ebuild,v 1.1 2012/10/09 20:03:12 swift Exp $
+
+EAPI="4"
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="xml"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
+
+inherit multilib python toolchain-funcs eutils
+
+EXTRAS_VER="1.22"
+SEMNG_VER="2.1.9"
+SELNX_VER="2.1.12"
+SEPOL_VER="2.1.8"
+
+IUSE="audit pam dbus sesandbox"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120924/${P}.tar.gz
+ http://dev.gentoo.org/~swift/patches/policycoreutils/patchbundle-${P}-gentoo-r3.tar.gz
+ mirror://gentoo/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPS=">=sys-libs/libselinux-${SELNX_VER}[python]
+ >=sys-libs/glibc-2.4
+ >=sys-libs/libcap-1.10-r10
+ >=sys-libs/libsemanage-${SEMNG_VER}[python]
+ sys-libs/libcap-ng
+ >=sys-libs/libsepol-${SEPOL_VER}
+ sys-devel/gettext
+ dev-python/ipy
+ sesandbox? ( dev-libs/libcgroup )
+ dbus? (
+ sys-apps/dbus
+ dev-libs/dbus-glib
+ )
+ audit? ( >=sys-process/audit-1.5.1 )
+ pam? ( sys-libs/pam )"
+
+### libcgroup -> seunshare
+### dbus -> restorecond
+
+# pax-utils for scanelf used by rlpkg
+RDEPEND="${COMMON_DEPS}
+ dev-python/sepolgen
+ app-misc/pax-utils"
+
+DEPEND="${COMMON_DEPS}"
+
+S2=${WORKDIR}/policycoreutils-extra
+
+src_prepare() {
+ # rlpkg is more useful than fixfiles
+ sed -i -e '/^all/s/fixfiles//' "${S}/scripts/Makefile" \
+ || die "fixfiles sed 1 failed"
+ sed -i -e '/fixfiles/d' "${S}/scripts/Makefile" \
+ || die "fixfiles sed 2 failed"
+
+ EPATCH_MULTI_MSG="Applying policycoreutils patches ... " \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
+ EPATCH_FORCE="yes" \
+ epatch
+
+ # Overwrite gl.po, id.po and et.po with valid PO file
+ cp "${S}/po/sq.po" "${S}/po/gl.po" || die "failed to copy ${S}/po/sq.po to gl.po"
+ cp "${S}/po/sq.po" "${S}/po/id.po" || die "failed to copy ${S}/po/sq.po to id.po"
+ cp "${S}/po/sq.po" "${S}/po/et.po" || die "failed to copy ${S}/po/sq.po to et.po"
+}
+
+src_compile() {
+ local use_audit="n";
+ local use_pam="n";
+ local use_dbus="n";
+ local use_sesandbox="n";
+
+ use audit && use_audit="y";
+ use pam && use_pam="y";
+ use dbus && use_dbus="y";
+ use sesandbox && use_sesandbox="y";
+
+ python_copy_sources semanage sandbox
+ building() {
+ einfo "Compiling policycoreutils"
+ emake -C "${S}" AUDIT_LOG_PRIVS="y" AUDITH="${use_audit}" PAMH="${use_pam}" INOTIFYH="${use_dbus}" SESANDBOX="${use_sesandbox}" CC="$(tc-getCC)" PYLIBVER="python$(python_get_version)" || die
+ einfo "Compiling policycoreutils-extra "
+ emake -C "${S2}" AUDIT_LOG_PRIVS="y" AUDITH="${use_audit}" PAMH="${use_pam}" INOTIFYH="${use_dbus}" SESANDBOX="${use_sesandbox}" CC="$(tc-getCC)" PYLIBVER="python$(python_get_version)" || die
+ }
+ python_execute_function -s --source-dir semanage building
+}
+
+src_install() {
+ local use_audit="n";
+ local use_pam="n";
+ local use_dbus="n";
+ local use_sesandbox="n";
+
+ use audit && use_audit="y";
+ use pam && use_pam="y";
+ use dbus && use_dbus="y";
+ use sesandbox && use_sesandbox="y";
+
+ # Python scripts are present in many places. There are no extension modules.
+ installation() {
+ einfo "Installing policycoreutils"
+ emake -C "${S}" DESTDIR="${T}/images/${PYTHON_ABI}" AUDITH="${use_audit}" PAMH="${use_pam}" INOTIFYH="${use_dbus}" SESANDBOX="${use_sesandbox}" AUDIT_LOG_PRIV="y" PYLIBVER="python$(python_get_version)" install || return 1
+
+ einfo "Installing policycoreutils-extra"
+ emake -C "${S2}" DESTDIR="${T}/images/${PYTHON_ABI}" SHLIBDIR="${D}$(get_libdir)/rc" install || return 1
+ }
+ python_execute_function installation
+ python_merge_intermediate_installation_images "${T}/images"
+
+ # remove redhat-style init script
+ rm -fR "${D}/etc/rc.d"
+
+ # compatibility symlinks
+ dosym /sbin/setfiles /usr/sbin/setfiles
+ dosym /$(get_libdir)/rc/runscript_selinux.so /$(get_libdir)/rcscripts/runscript_selinux.so
+
+ # location for permissive definitions
+ dodir /var/lib/selinux
+ keepdir /var/lib/selinux
+}
+
+pkg_postinst() {
+ python_mod_optimize seobject.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup seobject.py
+}