summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-17 00:54:13 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-17 00:54:13 +0000
commit6ec7c32a278b5a7613076473034493f6f8ffead9 (patch)
tree34a2b76f70b93b330b5e9169f391624357b57e72 /sys-auth/libfprint
parentVersion bump. (diff)
downloadhistorical-6ec7c32a278b5a7613076473034493f6f8ffead9.tar.gz
historical-6ec7c32a278b5a7613076473034493f6f8ffead9.tar.bz2
historical-6ec7c32a278b5a7613076473034493f6f8ffead9.zip
initial import
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'sys-auth/libfprint')
-rw-r--r--sys-auth/libfprint/ChangeLog11
-rw-r--r--sys-auth/libfprint/Manifest6
-rw-r--r--sys-auth/libfprint/libfprint-0.0.6.ebuild45
-rw-r--r--sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild50
-rw-r--r--sys-auth/libfprint/metadata.xml10
5 files changed, 122 insertions, 0 deletions
diff --git a/sys-auth/libfprint/ChangeLog b/sys-auth/libfprint/ChangeLog
new file mode 100644
index 000000000000..a513ce5bc2b2
--- /dev/null
+++ b/sys-auth/libfprint/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-auth/libfprint
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/ChangeLog,v 1.1 2010/10/17 00:54:13 xmw Exp $
+
+*libfprint-0.1.0_pre2 (17 Oct 2010)
+*libfprint-0.0.6 (17 Oct 2010)
+
+ 17 Oct 2010; Michael Weber <xmw@gentoo.org> +libfprint-0.0.6.ebuild,
+ +libfprint-0.1.0_pre2.ebuild, +metadata.xml:
+ Initial import, fixes bug 341107 by Jan Buecken <jb.faq@gmx.de>
+
diff --git a/sys-auth/libfprint/Manifest b/sys-auth/libfprint/Manifest
new file mode 100644
index 000000000000..28b0d3f02e91
--- /dev/null
+++ b/sys-auth/libfprint/Manifest
@@ -0,0 +1,6 @@
+DIST libfprint-0.0.6.tar.bz2 431957 RMD160 3677a0997da641ba3e8586222ca88640e1f6373f SHA1 430af91efbefeb2b98fe30215fb33051e4f8efc5 SHA256 5d16fadaecb432ab52ca97a59301dc8ca83cac75f3b57145266b562a1ebcc5dd
+DIST libfprint-0.1.0-pre2.tar.bz2 447511 RMD160 f7f0f72cc29434d70a97d38995675736d5c64f0b SHA1 4e35bf9f75225a11d2fb0dfe2ddcd32b51afdc25 SHA256 475c059749ef14d464d445aa32fff42e8f1063901d11cc8d02dd486c8df249d2
+EBUILD libfprint-0.0.6.ebuild 1226 RMD160 4612ed954aea9523b7666ebe827672238ae1be53 SHA1 78025ef0388999f975ff822734e94ae7b9cf5da6 SHA256 ca240464aadcdf5a1505e995a10f49c5ffdfb9d31283fef95a8aabebdd7de989
+EBUILD libfprint-0.1.0_pre2.ebuild 1314 RMD160 63bc4f355d5c54bb7ee9f40e9ffdf02b9c586135 SHA1 a10b5ad3ac552e99f1b38175a2ff39a97a126fe2 SHA256 4f49472d25ad1cdc30c84ad24595b9e9b79895f75ba015ced823c5b6ecd05d4c
+MISC ChangeLog 459 RMD160 3740f7530a505dfd537feb46e4401c83b9972d2a SHA1 44d7d8daa5aaef7e96959abbfe21def3ff37985e SHA256 a2248681510ce3e8f3dca3832c72db5d517188c2b8c45273dcddfa2765498586
+MISC metadata.xml 245 RMD160 6b03982a4d5f32d9fa6b9259ae36f9fcb07c8404 SHA1 fb16c7b4c5ab071dd979f761b8bb075f5396b737 SHA256 375a1da02cd2c393ce2378a73c1ce08134bc030b3bb378c6a4d6ca9cd5be1f8d
diff --git a/sys-auth/libfprint/libfprint-0.0.6.ebuild b/sys-auth/libfprint/libfprint-0.0.6.ebuild
new file mode 100644
index 000000000000..29ecec9e8eac
--- /dev/null
+++ b/sys-auth/libfprint/libfprint-0.0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/libfprint-0.0.6.ebuild,v 1.1 2010/10/17 00:54:13 xmw Exp $
+
+EAPI=3
+
+DESCRIPTION="library to add support for consumer fingerprint readers"
+HOMEPAGE="http://www.reactivated.net/fprint/wiki/Libfprint"
+SRC_URI="mirror://sourceforge/${PN/lib/}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X debug examples static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libusb
+ dev-libs/openssl
+ media-gfx/imagemagick
+ X? ( examples? (
+ x11-libs/libX11
+ x11-libs/libXv ) )"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local my_conf="$(use_enable examples examples-build)"
+ if use X ; then
+ my_conf="${my_conf} $(use_enable examples x11-examples-build)"
+ fi
+ econf ${my_conf} \
+ $(use_enable debug debug-log) \
+ $(use_enable static-libs static) || die
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die
+ if use examples ; then
+ dobin examples/.libs/{enroll,img_capture,verify{,_live}} || die
+ if use X ; then
+ dobin examples/.libs/img_capture_continuous || die
+ fi
+ fi
+ dodoc AUTHORS ChangeLog HACKING NEWS README THANKS TODO || die
+}
diff --git a/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild b/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild
new file mode 100644
index 000000000000..9ca81f9fc39c
--- /dev/null
+++ b/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild,v 1.1 2010/10/17 00:54:13 xmw Exp $
+
+EAPI=3
+
+inherit versionator
+
+MY_PV=$(replace_version_separator 3 -)
+DESCRIPTION="library to add support for consumer fingerprint readers"
+HOMEPAGE="http://www.reactivated.net/fprint/wiki/Libfprint"
+SRC_URI="mirror://sourceforge/${PN/lib/}/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X debug examples static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libusb:1
+ dev-libs/openssl
+ media-gfx/imagemagick
+ X? ( examples? (
+ x11-libs/libXv ) )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_configure(){
+ local my_conf="$(use_enable examples examples-build)"
+ if use X ; then
+ my_conf="${my_conf} $(use_enable examples x11-examples-build)"
+ fi
+ econf ${my_conf} \
+ $(use_enable debug debug-log) \
+ $(use_enable static-libs static) || die
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die
+ if use examples ; then
+ dobin examples/.libs/{enroll,img_capture,verify{,_live}} || die
+ if use X ; then
+ dobin examples/.libs/img_capture_continuous || die
+ fi
+ fi
+ dodoc AUTHORS ChangeLog HACKING NEWS README THANKS TODO || die
+}
diff --git a/sys-auth/libfprint/metadata.xml b/sys-auth/libfprint/metadata.xml
new file mode 100644
index 000000000000..02b909e46b7e
--- /dev/null
+++ b/sys-auth/libfprint/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+