summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-11-11 21:24:39 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-11-11 21:24:39 +0000
commitfb4788de6556663d7e99281cdb389d2f2b55fff3 (patch)
tree356bf6a1be3d60fd71de2c46bb9f0ca338394551 /sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild
parentVersion bump. (diff)
downloadhistorical-fb4788de6556663d7e99281cdb389d2f2b55fff3.tar.gz
historical-fb4788de6556663d7e99281cdb389d2f2b55fff3.tar.bz2
historical-fb4788de6556663d7e99281cdb389d2f2b55fff3.zip
Added patch to fix the db schema, ebuild rewritten, removed old version, bug #138034
Package-Manager: portage-2.1.2_rc1-r5
Diffstat (limited to 'sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild')
-rw-r--r--sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild56
1 files changed, 32 insertions, 24 deletions
diff --git a/sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild b/sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild
index 9f8dd3b5839f..4d981f1873ce 100644
--- a/sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild
+++ b/sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild
@@ -1,47 +1,55 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild,v 1.1 2006/03/20 05:59:21 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild,v 1.2 2006/11/11 21:24:39 dev-zero Exp $
-inherit eutils
+inherit autotools eutils multilib
+
+KEYWORDS="~x86"
DESCRIPTION="Name Service Switch module for use with PostgreSQL"
HOMEPAGE="http://pgfoundry.org/projects/sysauth/"
SRC_URI="http://pgfoundry.org/frs/download.php/605/${P}.tgz"
LICENSE="GPL-2"
-
SLOT="0"
-KEYWORDS="~x86"
IUSE=""
-DEPEND="virtual/libc
- dev-db/libpq
- app-text/xmlto"
+
+DEPEND="dev-db/libpq
+ app-text/xmlto"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-schema.patch"
+ eautoreconf
}
src_compile() {
- econf --libdir=/lib || die "econf failure"
- libtoolize --copy --force || die "libtoolize failure"
- emake || die "emake failure"
+ econf \
+ --libdir=/lib \
+ --with-docdir=/usr/share/doc/${PF}/html || die "econf failed"
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die "make install failure"
- dodoc AUTHORS ChangeLog INSTALL NEWS README
- insinto etc && doins conf/nss-pgsql.conf
- docinto conf && dodoc conf/{dbschema.sql,nsswitch.conf}
- docinto doc && dodoc doc/{nss-pgsql.{ps,sgml,txt}}
+ insinto /$(get_libdir)
+ doins src/.libs/libnss_pgsql.so.2.0.0
+ dosym libnss_pgsql.so.2.0.0 /lib/libnss_pgsql.so.2
+ dosym libnss_pgsql.so.2.0.0 /lib/libnss_pgsql.so
+
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml doc/*.{png,html}
+ insinto /usr/share/doc/${PF}/examples
+ doins conf/*
}
pkg_postinst() {
- einfo "Now create the required SQL tables in a database, eg.:"
- einfo " $ zcat /usr/share/doc/${P}/conf/dbschema.sql.gz | psql dbtest"
- einfo "Then edit the config file to match your need:"
- einfo " /etc/nss-pgsql.conf"
- einfo "Now edit /etc/nsswitch.conf to use the NSS service 'pgsql', an"
- einfo "example is available here:"
- einfo " /usr/share/doc/${P}/conf/nsswitch.conf.gz"
+ elog "Next steps:"
+ elog "1. Create the required tables in the database:"
+ elog " $ psql a_database -f ${ROOT}usr/share/${PN}/conf/dbschema.sql"
+ elog "2. Create the configuration file '/etc/nss-pgsql.conf'"
+ elog " You can copy the example from ${ROOT}usr/share/doc/${PF}/examples/nss-pgsql.conf"
+ elog "3. Edit /etc/nsswitch.conf to use the NSS service 'pgsql'"
+ elog " An example is available here: ${ROOT}usr/share/doc/${PF}/examples/nsswitch.conf"
}