summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-31 17:54:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-31 17:54:05 +0000
commit5791fa8cfb0b3d3643cb4561ab215fed123773b0 (patch)
tree4312afb56b1fbdf26f43e889d66182dcd5df280c /sys-auth/pam_ssh/pam_ssh-1.97-r3.ebuild
parentsparc stable wrt #341623 (diff)
downloadhistorical-5791fa8cfb0b3d3643cb4561ab215fed123773b0.tar.gz
historical-5791fa8cfb0b3d3643cb4561ab215fed123773b0.tar.bz2
historical-5791fa8cfb0b3d3643cb4561ab215fed123773b0.zip
Finally fix bug #266603; thanks to Kevin Lyles for reporting, and the anonymous user for the patch.
Package-Manager: portage-2.2.0_alpha2/cvs/Linux x86_64
Diffstat (limited to 'sys-auth/pam_ssh/pam_ssh-1.97-r3.ebuild')
-rw-r--r--sys-auth/pam_ssh/pam_ssh-1.97-r3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-auth/pam_ssh/pam_ssh-1.97-r3.ebuild b/sys-auth/pam_ssh/pam_ssh-1.97-r3.ebuild
new file mode 100644
index 000000000000..809c34776d7c
--- /dev/null
+++ b/sys-auth/pam_ssh/pam_ssh-1.97-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/pam_ssh-1.97-r3.ebuild,v 1.1 2010/10/31 17:54:05 flameeyes Exp $
+
+EAPI=2
+
+inherit pam autotools flag-o-matic
+
+DESCRIPTION="Uses ssh-agent to provide single sign-on"
+HOMEPAGE="http://pam-ssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.bz2"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+
+# Doesn't work on OpenPAM; looks for OpenSSH at build time (bug
+# #282993) and won't work with other implementations either
+RDEPEND="sys-libs/pam
+ net-misc/openssh"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-doublefree.patch"
+ epatch "${FILESDIR}/${P}-EOF.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # hide all the otherwise-exported symbols that may clash with
+ # other software loading the PAM modules (see bug #274924 as an
+ # example).
+ append-ldflags -Wl,--version-script="${FILESDIR}"/pam_symbols.ver
+
+ econf \
+ "--with-pam-dir=$(getpam_mod_dir)" \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+
+ find "${D}" -name '*.la' -delete || die "Unable to remove libtool archives."
+}
+
+pkg_postinst() {
+ elog "You can enable pam_ssh for system authentication by enabling"
+ elog "the ssh USE flag on sys-auth/pambase."
+}