summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-08-15 19:18:44 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-08-15 19:18:44 +0000
commite66be3b7b49d936c8c056429ec7ff24a3c57a632 (patch)
tree4a254124383d0113507a02548d2b1a9541e1965a /sys-block/fio/fio-1.21.ebuild
parentamd64/x86 stable, bug #234483 (diff)
downloadhistorical-e66be3b7b49d936c8c056429ec7ff24a3c57a632.tar.gz
historical-e66be3b7b49d936c8c056429ec7ff24a3c57a632.tar.bz2
historical-e66be3b7b49d936c8c056429ec7ff24a3c57a632.zip
Bug #234433, version bump.
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64
Diffstat (limited to 'sys-block/fio/fio-1.21.ebuild')
-rw-r--r--sys-block/fio/fio-1.21.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-block/fio/fio-1.21.ebuild b/sys-block/fio/fio-1.21.ebuild
new file mode 100644
index 000000000000..12c52db5ba44
--- /dev/null
+++ b/sys-block/fio/fio-1.21.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/fio-1.21.ebuild,v 1.1 2008/08/15 19:18:44 robbat2 Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Jens Axboe's Flexible IO tester"
+HOMEPAGE="http://brick.kernel.dk/snaps/"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libaio"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ append-flags -W
+ emake CC="$(tc-getCC)" OPTFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" || die "emake install failed"
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+ doman fio.1
+}