summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-11-03 21:03:10 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-11-03 21:03:10 +0000
commit5c13f39dde4f82da1c3818d8d537ac6fcde8dfd1 (patch)
treee63b65b9f8ec6ad4984d9b8da5df02aab077fc56 /sys-block/fio/fio-2.0.15.ebuild
parentMask app-emulation/qenv for treecleaning, doesn't build, qemu changed too much. (diff)
downloadhistorical-5c13f39dde4f82da1c3818d8d537ac6fcde8dfd1.tar.gz
historical-5c13f39dde4f82da1c3818d8d537ac6fcde8dfd1.tar.bz2
historical-5c13f39dde4f82da1c3818d8d537ac6fcde8dfd1.zip
Version bump, also change description per bug #466166.
Package-Manager: portage-2.2.7/cvs/Linux x86_64
Diffstat (limited to 'sys-block/fio/fio-2.0.15.ebuild')
-rw-r--r--sys-block/fio/fio-2.0.15.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-block/fio/fio-2.0.15.ebuild b/sys-block/fio/fio-2.0.15.ebuild
new file mode 100644
index 000000000000..34f726ac249b
--- /dev/null
+++ b/sys-block/fio/fio-2.0.15.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/fio-2.0.15.ebuild,v 1.1 2013/11/03 21:03:05 robbat2 Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs flag-o-matic eutils
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Write job files matching the I/O load one wants to simulate."
+HOMEPAGE="http://brick.kernel.dk/snaps/"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libaio"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i \
+ -e '/filter /s:-o:$(LDFLAGS) -o:' \
+ -e '/: depend$/d' \
+ -e '/^DEBUGFLAGS/s, -D_FORTIFY_SOURCE=2,,g' \
+ Makefile || die
+ epatch "$FILESDIR"/fio-2.0.14-pic-clobber-fix.patch
+}
+
+src_configure() {
+ : # not a real configure script
+ ./configure --extra-cflags="${CFLAGS}" --cc="$(tc-getCC)"
+}
+
+src_compile() {
+ append-flags -W
+ emake V=1
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man"
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+ doman fio.1
+}