summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-11-10 09:48:28 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-11-10 09:48:28 +0000
commit505cacc96413d36300047ea4574d9463c1bc5597 (patch)
treefb47bf815ddd60a948a8458a75e0bc644dee634c /sys-block/mpt-status/files
parentuse --pidfile rather than --pid as pointed out by Uberlord (diff)
downloadhistorical-505cacc96413d36300047ea4574d9463c1bc5597.tar.gz
historical-505cacc96413d36300047ea4574d9463c1bc5597.tar.bz2
historical-505cacc96413d36300047ea4574d9463c1bc5597.zip
New version from upstream. Placed into the tree, and used for the new Gentoo bugzilla hardware [IBM HS20 blades] :-).
Package-Manager: portage-2.1.2_rc1-r4
Diffstat (limited to 'sys-block/mpt-status/files')
-rw-r--r--sys-block/mpt-status/files/digest-mpt-status-1.2.06
-rw-r--r--sys-block/mpt-status/files/mpt-status-1.2.0-gentoo.patch51
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-block/mpt-status/files/digest-mpt-status-1.2.0 b/sys-block/mpt-status/files/digest-mpt-status-1.2.0
new file mode 100644
index 000000000000..810db3afe082
--- /dev/null
+++ b/sys-block/mpt-status/files/digest-mpt-status-1.2.0
@@ -0,0 +1,6 @@
+MD5 9fbf08bbc2cc2a1ddbae75af70fd0e7a mpt-status-1.1.6-linux-sources.tar.bz2 32137
+RMD160 d4a78eaffdb978dda3f9ccba985d1c9f9fde9806 mpt-status-1.1.6-linux-sources.tar.bz2 32137
+SHA256 c793393803bfa0dbb8d543788c36bd6d36ec4374f82b06bc88c4b63d4651c337 mpt-status-1.1.6-linux-sources.tar.bz2 32137
+MD5 fae044db1340fd37aa81b4ecef7bbd46 mpt-status-1.2.0.tar.bz2 36060
+RMD160 2bd9294a82469aa51ad7cb76664e8c959261e2c5 mpt-status-1.2.0.tar.bz2 36060
+SHA256 4457c2e3f7b493f20f9527f21dd4f26aa3fc14eaaaeb1ee1ba63a1024369bab4 mpt-status-1.2.0.tar.bz2 36060
diff --git a/sys-block/mpt-status/files/mpt-status-1.2.0-gentoo.patch b/sys-block/mpt-status/files/mpt-status-1.2.0-gentoo.patch
new file mode 100644
index 000000000000..445868a2ef9d
--- /dev/null
+++ b/sys-block/mpt-status/files/mpt-status-1.2.0-gentoo.patch
@@ -0,0 +1,51 @@
+Patch for Gentoo distribution of mpt-status.
+ 1. -I../linux-sources/drivers/message/fusion for our inclusion of the mpt headers.
+ 2. Remove -O2, and use $(CFLAGS) from user instead.
+ 3. Use LDFLAGS
+ 4. -D flag to install is GNU specific.
+ 5. Remove sparc64 specific CFLAGS.
+ 6. Remember to make the sbin directory before installing to it.
+ 7. Don't strip the binary.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar mpt-status-1.2.0.orig/Makefile mpt-status-1.2.0/Makefile
+--- mpt-status-1.2.0.orig/Makefile 2006-11-01 19:02:30.000000000 +0000
++++ mpt-status-1.2.0/Makefile 2006-11-10 08:54:18.000000000 +0000
+@@ -3,28 +3,26 @@
+ KERNEL_PATH := /usr/src/linux
+ KERNEL_PATH_B := /lib/modules/`uname -r`/build
+ KERNEL_PATH_S := /lib/modules/`uname -r`/source
+-CFLAGS := -Iincl -Wall -W -O2 \
++CFLAGS := -Iincl -Wall -W \
++ -I../linux-sources/drivers/message/fusion \
+ -I${KERNEL_PATH}/drivers/message/fusion \
+ -I${KERNEL_PATH_B}/drivers/message/fusion \
+- -I${KERNEL_PATH_S}/drivers/message/fusion
++ -I${KERNEL_PATH_S}/drivers/message/fusion \
++ $(CFLAGS)
+ DFLAGS := #-DSANITIZED_KERNEL_HEADERS
+-LDFLAGS :=
++LDFLAGS := $(LDFLAGS)
+ DESTDIR :=
+ MANDIR := /usr/share/man
+ CC := gcc
+-INSTALL := install -D
++INSTALL := install
+ ARCH := $(shell uname -m)
+
+-ifeq "${ARCH}" "sparc64"
+- CFLAGS := -Iincl -Wall -W -O2 -m64 -pipe \
+- -mcpu=ultrasparc -mcmodel=medlow
+-endif
+-
+ ${PROG}: ${PROG}.c ${PROG}.h
+ ${CC} ${DFLAGS} ${CFLAGS} -o $@ $< ${LDFLAGS}
+
+ install: ${PROG}
+- ${INSTALL} -s -o root -g root -m 0500 $< \
++ ${INSTALL} -d ${DESTDIR}${PREFIX}/sbin/
++ ${INSTALL} -o root -g root -m 0500 $< \
+ ${DESTDIR}${PREFIX}/sbin
+
+ install_doc: man/${PROG}.8