summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-05-24 07:29:46 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-05-24 07:29:46 +0000
commit3a9b04179d3a3c41e5c8895a8360004389f12998 (patch)
tree0d4494737f4007cebe8f887088eb25d63dd83c0d /sys-block/scsirastools/scsirastools-1.5.4.ebuild
parentAdded shutdown hook to check if there are hanging long running noad process a... (diff)
downloadhistorical-3a9b04179d3a3c41e5c8895a8360004389f12998.tar.gz
historical-3a9b04179d3a3c41e5c8895a8360004389f12998.tar.bz2
historical-3a9b04179d3a3c41e5c8895a8360004389f12998.zip
Version bump.
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'sys-block/scsirastools/scsirastools-1.5.4.ebuild')
-rw-r--r--sys-block/scsirastools/scsirastools-1.5.4.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-block/scsirastools/scsirastools-1.5.4.ebuild b/sys-block/scsirastools/scsirastools-1.5.4.ebuild
new file mode 100644
index 000000000000..c2b4729ed7fb
--- /dev/null
+++ b/sys-block/scsirastools/scsirastools-1.5.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/scsirastools/scsirastools-1.5.4.ebuild,v 1.1 2007/05/24 07:29:46 robbat2 Exp $
+
+inherit autotools
+
+DESCRIPTION="Serviceability for SCSI Disks and Arrays"
+HOMEPAGE="http://scsirastools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+DEPEND="virtual/libc
+ sys-apps/rescan-scsi-bus
+ sys-apps/sg3_utils"
+#RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ # this builds a really old mdadm
+ sed -i.orig \
+ -e '/^SUBDIRS/s,mdadm.d,,' \
+ -e '/^SUBDIRS/s,files,,' \
+ ${S}/Makefile.am || die "sed Makefile.am failed"
+ cd ${S}
+ eautoreconf
+ # i386 ELF binaries in tarball = bad
+ rm -f ${S}/files/alarms*
+
+ # Fix up /sbin instances to be /usr/sbin instead
+ for i in src/sgraidmon.c src/sgdiskmon.c ; do
+ sed -i ${S}/${i} \
+ -e '/evtcmd\[\].*\"\/sbin\//s,/sbin/,/usr/sbin/,' \
+ || die "Failed to set /sbin in sources"
+ done
+}
+
+src_compile() {
+ econf --sbindir=/usr/sbin \
+ || die "econf failed"
+ emake \
+ || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ docdir="/usr/share/doc/${PF}/"
+ emake install DESTDIR="${D}" datato="${D}${docdir}" \
+ || "emake install failed"
+ dosbin files/sgevt
+ dosbin files/mdevt
+ # unneeded files
+ rm ${D}${docdir}/{SCSIRAS,COPYING}
+ # install modepage files
+ insinto /usr/share/${PN}
+ doins files/*.mdf
+ # new docs
+ dodoc ChangeLog AUTHORS TODO
+ # ensure that other docs from the emake install are compressed too.
+ prepalldocs
+}