summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-03-17 19:01:21 +0000
committerNed Ludd <solar@gentoo.org>2004-03-17 19:01:21 +0000
commit182b15121ce4287a7d8a566f4d07b124abab40d1 (patch)
tree94e92cef9ff00c4199f99cd76fafda8801e967f9 /sys-boot/grub/grub-0.94-r1.ebuild
parentPull old versions. (diff)
downloadhistorical-182b15121ce4287a7d8a566f4d07b124abab40d1.tar.gz
historical-182b15121ce4287a7d8a566f4d07b124abab40d1.tar.bz2
historical-182b15121ce4287a7d8a566f4d07b124abab40d1.zip
grub will end up with a 100+ meg stage2 file if the user has LDFLAGS=-pie, so lets filter that flag out in the src_compile
Diffstat (limited to 'sys-boot/grub/grub-0.94-r1.ebuild')
-rw-r--r--sys-boot/grub/grub-0.94-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-boot/grub/grub-0.94-r1.ebuild b/sys-boot/grub/grub-0.94-r1.ebuild
index 115620b6da7d..eefd7e6713c2 100644
--- a/sys-boot/grub/grub-0.94-r1.ebuild
+++ b/sys-boot/grub/grub-0.94-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.1 2004/02/26 07:38:10 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.2 2004/03/17 19:01:21 solar Exp $
inherit mount-boot eutils flag-o-matic gcc
@@ -46,7 +46,7 @@ src_compile() {
unset CFLAGS
filter-flags -fstack-protector
-
+ filter-ldflags -pie
append-flags -DNDEBUG
[ `gcc-major-version` -eq 3 ] && append-flags -minline-all-stringops
use static && append-ldflags -static