summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-21 20:47:00 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-21 20:47:00 +0000
commit576c4be7e8a5a26875116f139fb2d0edf8852b78 (patch)
treedc9e4ed050a4b89c30fbac29d5494c2003234c15 /sys-boot/palo/palo-1.18-r1.ebuild
parentVersion bump (diff)
downloadhistorical-576c4be7e8a5a26875116f139fb2d0edf8852b78.tar.gz
historical-576c4be7e8a5a26875116f139fb2d0edf8852b78.tar.bz2
historical-576c4be7e8a5a26875116f139fb2d0edf8852b78.zip
Add missing include. Bump version that upstream non-maintainer commit missed. Respect LDFLAGS.
Package-Manager: portage-2.2.0_alpha30/cvs/Linux i686
Diffstat (limited to 'sys-boot/palo/palo-1.18-r1.ebuild')
-rw-r--r--sys-boot/palo/palo-1.18-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-boot/palo/palo-1.18-r1.ebuild b/sys-boot/palo/palo-1.18-r1.ebuild
new file mode 100644
index 000000000000..8c39be9d6ee6
--- /dev/null
+++ b/sys-boot/palo/palo-1.18-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.18-r1.ebuild,v 1.1 2011/04/21 20:47:00 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ http://packages.qa.debian.org/p/palo.html"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-remove-HOME-TERM.patch \
+ "${FILESDIR}"/${PN}-1.16_p1-build.patch \
+ "${FILESDIR}"/${P}-include.patch
+ sed -i lib/common.h -e '/^#define PALOVERSION/{s|".*"|"'${PV}'"|g}' || die
+ sed -i palo/Makefile -e '/^LDFLAGS=/d' || die
+}
+
+src_compile() {
+ tc-export CC
+ emake -C palo || die "make palo failed"
+ emake -C ipl || die "make ipl failed"
+ emake MACHINE=parisc iplboot || die "make iplboot failed"
+}
+
+src_install() {
+ into /
+ dosbin palo/palo || die
+
+ doman palo.8
+ dohtml README.html
+ dodoc README palo.conf
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf || die
+
+ insinto /usr/share/palo
+ doins iplboot || die
+}