summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Longland <redhatter@gentoo.org>2006-03-25 15:57:58 +0000
committerStuart Longland <redhatter@gentoo.org>2006-03-25 15:57:58 +0000
commitcd35146b9ecffea5f2252326f88d8fc0c4c70d69 (patch)
tree33e875b8a528783ece59d53ff0f68ff05ce7260b /sys-boot
parentRemove ebuilds that refer to ebuilds no longer in portage. Add 1.7 which sho... (diff)
downloadhistorical-cd35146b9ecffea5f2252326f88d8fc0c4c70d69.tar.gz
historical-cd35146b9ecffea5f2252326f88d8fc0c4c70d69.tar.bz2
historical-cd35146b9ecffea5f2252326f88d8fc0c4c70d69.zip
Removed old 1.16 ebuild. Added 1.21 as new unstable release.
Package-Manager: portage-2.0.54
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/colo/ChangeLog9
-rw-r--r--sys-boot/colo/Manifest11
-rw-r--r--sys-boot/colo/colo-1.21.ebuild109
-rw-r--r--sys-boot/colo/files/digest-colo-1.161
-rw-r--r--sys-boot/colo/files/digest-colo-1.211
5 files changed, 123 insertions, 8 deletions
diff --git a/sys-boot/colo/ChangeLog b/sys-boot/colo/ChangeLog
index dc448096932b..9717a27bfd38 100644
--- a/sys-boot/colo/ChangeLog
+++ b/sys-boot/colo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/colo
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.15 2005/12/07 07:33:43 redhatter Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.16 2006/03/25 15:57:58 redhatter Exp $
+
+*colo-1.21 (25 Mar 2006)
+
+ 25 Mar 2006; Stuart Longland <redhatter@gentoo.org> +colo-1.21.ebuild:
+ Removed old 1.16 ebuild. Added 1.21 as new unstable release.
07 Dec 2005; Stuart Longland <redhatter@gentoo.org>
-files/colo-linker-overlap-fix.patch, +files/menu.colo,
diff --git a/sys-boot/colo/Manifest b/sys-boot/colo/Manifest
index 26e50a00f0e7..e144614cba4d 100644
--- a/sys-boot/colo/Manifest
+++ b/sys-boot/colo/Manifest
@@ -1,9 +1,10 @@
-MD5 e94b1ad8680ca914dd66b9abc00cc4b4 ChangeLog 2781
+MD5 1868a8c7e579f0572539189496c92c29 ChangeLog 2945
MD5 dfd928b47271f3bf83c8c6fa46ed4f7c colo-1.16.ebuild 4197
MD5 f8b862ca0599d9f3bfc82301b688f8b5 colo-1.19.ebuild 3480
-MD5 821bbe104fd36eab5f08495277bc5adb metadata.xml 364
-MD5 90a0baf918f815c9b6d3daafcc77c960 files/digest-colo-1.16 61
+MD5 a0e1222a784485b90a8dd67ad5b1ee9f colo-1.21.ebuild 3481
+MD5 887b7cc9e154a546edceffc8ecedc9fd files/default.colo 840
MD5 b2c42788147b311d818a159f61096aff files/digest-colo-1.19 61
-MD5 a37a355fc348836db5c3f839279fdcf4 files/simple.colo 648
+MD5 e796c3c34fa8e21501c299847d990fe8 files/digest-colo-1.21 61
MD5 4d75488cb1bd321232419a55d21d940d files/menu.colo 1624
-MD5 887b7cc9e154a546edceffc8ecedc9fd files/default.colo 840
+MD5 a37a355fc348836db5c3f839279fdcf4 files/simple.colo 648
+MD5 821bbe104fd36eab5f08495277bc5adb metadata.xml 364
diff --git a/sys-boot/colo/colo-1.21.ebuild b/sys-boot/colo/colo-1.21.ebuild
new file mode 100644
index 000000000000..32f33d26bc90
--- /dev/null
+++ b/sys-boot/colo/colo-1.21.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/colo-1.21.ebuild,v 1.1 2006/03/25 15:57:58 redhatter Exp $
+
+inherit eutils
+
+DESCRIPTION="CObalt LOader - Modern bootloader for Cobalt MIPS machines"
+HOMEPAGE="http://www.colonel-panic.org/cobalt-mips/"
+SRC_URI="http://www.colonel-panic.org/cobalt-mips/colo/colo-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~mips"
+IUSE=""
+DEPEND=""
+RESTRICT="nostrip"
+
+
+pkg_setup() {
+ # See if we're on a cobalt system (must use the cobalt-mips profile)
+ if [ "${PROFILE_ARCH}" != "cobalt" ]; then
+ echo -e ""
+ eerror "This package is only intended for the Cobalt Microserver MIPS-based"
+ eerror "systems. It will not function on any other MIPS-based system or any"
+ eerror "other architecture"
+ echo -e ""
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ echo -e ""
+ einfo ">>> Building the CoLo Bootloader ..."
+ cd ${S}
+ make clean || die # emake breaks the build
+ make || die
+}
+
+src_install() {
+ # bins
+ cd ${S}
+ dodir /usr/lib/colo
+ cp binaries/colo-chain.elf ${D}/usr/lib/colo
+ cp binaries/colo-rom-image.bin ${D}/usr/lib/colo
+
+ # docs
+ dodoc CHANGES COPYING INSTALL README README.{restore,shell,netcon} tools/README.tools TODO
+
+ # all tools except lcdtools (see below)
+ local tool
+ for tool in flash-tool colo-perm copy-rom elf2rfx; do
+
+ einfo "Installing ${tool} binary to ${D}/usr/sbin"
+ dosbin tools/${tool}/${tool}
+ if [ -f tools/${tool}/${tool}.8 ]; then
+ einfo "Installing ${tool} manpage to ${D}/usr/share/man"
+ doman tools/flash-tool/flash-tool.8
+ fi
+
+ done
+
+ # lcdtools
+ for tool in paneld putlcd e2fsck-lcd; do
+ einfo "Installing ${tool} binary and manpage to ${D}/usr/sbin"
+ dosbin tools/lcdtools/${tool}/${tool}
+ doman tools/lcdtools/${tool}/${tool}.8
+ done
+ dolib.a tools/lcdtools/liblcd/liblcd.a
+
+ # bootscripts
+ dodir /usr/lib/colo/scripts
+ cp ${FILESDIR}/*.colo ${D}/usr/lib/colo/scripts
+}
+
+pkg_postinst() {
+ echo -e ""
+ einfo "Install locations:"
+ einfo " Binaries:\t/usr/lib/${PN}"
+ einfo " Docs:\t/usr/share/doc/${PF}"
+ einfo " Tools:\t/usr/sbin/{flash-tool,colo-perm,copy-rom,"
+ einfo " \tputlcd,paneld,e2fsck-lcd,elf2rfx}"
+ einfo " Scripts:\t/usr/lib/${PN}/scripts"
+ echo -e ""
+ einfo "Please read the docs to fully understand the behavior of this bootloader, and"
+ einfo "edit the boot scripts to suit your needs."
+ echo -e ""
+ ewarn "Users installing ${PN} for the first time need to be aware that newer"
+ ewarn "versions of ${PN} disable the serial port by default. If the serial port"
+ ewarn "is needed, select it from the boot menu. Users using the example boot"
+ ewarn "scripts provided will have the serial port automatically enabled."
+ echo -e ""
+ ewarn "Note: It is HIGHLY recommended that you use the chain"
+ ewarn "bootloader (colo-chain.elf) first before attempting to"
+ ewarn "write the bootloader to the flash chip to verify that"
+ ewarn "it will work for you. It is also recommended that"
+ ewarn "you read the documentation in /usr/share/doc/${PF}"
+ ewarn "as it explains how to properly use this package."
+ echo -e ""
+ eerror "Warning: Make sure that IF you plan on flashing the"
+ eerror "bootloader into the flash chip that you are using a"
+ eerror "modern 2.4 Linux kernel (i.e., >2.4.18), otherwise"
+ eerror "you run a risk of destroying the contents of the"
+ eerror "flash chip and rendering the machine unusable."
+ echo -e ""
+ echo -e ""
+}
diff --git a/sys-boot/colo/files/digest-colo-1.16 b/sys-boot/colo/files/digest-colo-1.16
deleted file mode 100644
index 9bdd764a236b..000000000000
--- a/sys-boot/colo/files/digest-colo-1.16
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7e00fb1a68e185c03152dc161cecb8d4 colo-1.16.tar.gz 242604
diff --git a/sys-boot/colo/files/digest-colo-1.21 b/sys-boot/colo/files/digest-colo-1.21
new file mode 100644
index 000000000000..dd18a6fee136
--- /dev/null
+++ b/sys-boot/colo/files/digest-colo-1.21
@@ -0,0 +1 @@
+MD5 9d8a37ad4984ec6660ff159e83f15404 colo-1.21.tar.gz 255205