summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-24 18:15:25 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-24 18:15:25 +0000
commita23e7ecee493371c14ee3fa049d0386ece2f4527 (patch)
treeb6e3f0aa6d7e3b7708018d39e6fe2555ea096369 /sys-cluster/mpich2/mpich2-1.0.3.ebuild
parentVersion bump, now supports symlinks for ex, view, and man pages. (diff)
downloadhistorical-a23e7ecee493371c14ee3fa049d0386ece2f4527.tar.gz
historical-a23e7ecee493371c14ee3fa049d0386ece2f4527.tar.bz2
historical-a23e7ecee493371c14ee3fa049d0386ece2f4527.zip
(#148719) Use WANT_AUTOCONF instead of need-autoconf() from kde-functions.eclass.
Package-Manager: portage-2.1.2_pre1-r1
Diffstat (limited to 'sys-cluster/mpich2/mpich2-1.0.3.ebuild')
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.3.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/sys-cluster/mpich2/mpich2-1.0.3.ebuild b/sys-cluster/mpich2/mpich2-1.0.3.ebuild
index 80c1faccfbfd..2897fd377e78 100644
--- a/sys-cluster/mpich2/mpich2-1.0.3.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3.ebuild,v 1.7 2006/08/28 16:45:22 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3.ebuild,v 1.8 2006/09/24 18:15:25 dberkholz Exp $
-inherit eutils autotools kde-functions
+inherit eutils autotools
DESCRIPTION="MPICH2 - A portable MPI implementation"
HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich2"
@@ -35,7 +35,6 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd ${S}
- need-autoconf 2.5
ebegin "Reconfiguring"
./maint/updatefiles
eend "Reconfigure failed"
@@ -70,8 +69,13 @@ src_compile() {
myconf="${myconf} --with-thread-package=none"
fi
- ./configure --prefix=/usr --enable-sharedlibs=gcc \
- ${myconf} --enable-rlog=no --enable-slog2=no \
+ WANT_AUTOCONF="2.5" \
+ ./configure \
+ --prefix=/usr \
+ --enable-sharedlibs=gcc \
+ ${myconf} \
+ --enable-rlog=no \
+ --enable-slog2=no \
$(use_enable cxx) \
$(use_enable mpe) \
$(use_enable threads) \