summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-07-27 04:19:17 +0000
committerMike Frysinger <vapier@gentoo.org>2009-07-27 04:19:17 +0000
commit60ca6e332290c5bbf046e0bb4f7286b892033523 (patch)
treed92f610acf274ce7a9d08f86c3323aa90757aa98 /sys-devel/autoconf/autoconf-2.64.ebuild
parentStabilize for everyone (only change is sh-specific). (diff)
downloadhistorical-60ca6e332290c5bbf046e0bb4f7286b892033523.tar.gz
historical-60ca6e332290c5bbf046e0bb4f7286b892033523.tar.bz2
historical-60ca6e332290c5bbf046e0bb4f7286b892033523.zip
Version bump.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/autoconf/autoconf-2.64.ebuild')
-rw-r--r--sys-devel/autoconf/autoconf-2.64.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-devel/autoconf/autoconf-2.64.ebuild b/sys-devel/autoconf/autoconf-2.64.ebuild
new file mode 100644
index 000000000000..ccfea2b5de14
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.64.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.64.ebuild,v 1.1 2009/07/27 04:19:17 vapier Exp $
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="emacs"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ >=sys-devel/m4-1.4.6
+ dev-lang/perl"
+RDEPEND="${DEPEND}
+ >=sys-devel/autoconf-wrapper-7"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+src_compile() {
+ # Disable Emacs in the build system since it is in a separate package.
+ export EMACS=no
+ econf --program-suffix="-${PV}" || die
+ # econf updates config.{sub,guess} which forces the manpages
+ # to be regenerated which we dont want to do #146621
+ touch man/*.1
+ # From configure output:
+ # Parallel builds via `make -jN' do not work.
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README TODO THANKS \
+ ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+}