summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-14 19:19:01 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-14 19:19:01 +0000
commit51182796bdc14a50ceddbe88f9861d31ae27eeb3 (patch)
tree4fdc5de5ebc8463f40ee56ac85e12fe4eb611436 /sys-devel/autoconf
parentversion bump (diff)
downloadhistorical-51182796bdc14a50ceddbe88f9861d31ae27eeb3.tar.gz
historical-51182796bdc14a50ceddbe88f9861d31ae27eeb3.tar.bz2
historical-51182796bdc14a50ceddbe88f9861d31ae27eeb3.zip
fix 2.5x info page not in DIR, closing bug #12085
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/ChangeLog6
-rw-r--r--sys-devel/autoconf/autoconf-2.54.ebuild18
-rw-r--r--sys-devel/autoconf/files/autoconf-2.5-infopage-namechange.patch95
3 files changed, 114 insertions, 5 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 560835b89fa9..be5b7c8af2b2 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/autoconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.12 2002/12/12 22:21:14 tuxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.13 2002/12/14 19:19:01 azarah Exp $
+
+ 14 Dec 2002; Martin Schlemmer <azarah@gentoo.org> autoconf-2.54.ebuild :
+ Also get autoconf-2.5x info page to show up in DIR index, closing
+ bug #12085.
12 Dec 2002; Jan Seidel <tuxus@gentoo.org> autoconf-2.53a.ebuild :
Added mips to keywords.
diff --git a/sys-devel/autoconf/autoconf-2.54.ebuild b/sys-devel/autoconf/autoconf-2.54.ebuild
index 72e01030294d..1b9d37ac1af3 100644
--- a/sys-devel/autoconf/autoconf-2.54.ebuild
+++ b/sys-devel/autoconf/autoconf-2.54.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.54.ebuild,v 1.4 2002/12/09 22:29:51 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.54.ebuild,v 1.5 2002/12/14 19:19:01 azarah Exp $
+
+IUSE=""
+
+inherit eutils
OLD_PV="2.13"
OLD_P="${PN}-${OLD_PV}"
@@ -22,9 +26,15 @@ DEPEND=">=sys-devel/m4-1.4p
src_unpack() {
unpack ${A}
+
cd ${OLD_S}
- patch -p0 < ${FILESDIR}/${OLD_P}-configure-gentoo.diff || die
- patch -p0 < ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff || die
+ epatch ${FILESDIR}/${OLD_P}-configure-gentoo.diff
+ epatch ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff
+
+ cd ${S}
+ # Enable both autoconf-2.1 and autoconf-2.5 info pages
+ epatch ${FILESDIR}/${PN}-2.5-infopage-namechange.patch
+ ln -snf ${S}/doc/autoconf.texi ${S}/doc/autoconf25.texi
}
src_compile() {
@@ -76,7 +86,7 @@ src_install() {
# new in 2.5x
dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
- mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+# mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
docinto ${PV}
dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
diff --git a/sys-devel/autoconf/files/autoconf-2.5-infopage-namechange.patch b/sys-devel/autoconf/files/autoconf-2.5-infopage-namechange.patch
new file mode 100644
index 000000000000..52e1bee0a933
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.5-infopage-namechange.patch
@@ -0,0 +1,95 @@
+--- autoconf-2.54/doc/autoconf.texi.orig 2002-12-14 20:17:38.000000000 +0200
++++ autoconf-2.54/doc/autoconf.texi 2002-12-14 20:18:09.000000000 +0200
+@@ -1,9 +1,9 @@
+ \input texinfo @c -*-texinfo-*-
+ @comment ========================================================
+ @comment %**start of header
+-@setfilename autoconf.info
++@setfilename autoconf25.info
+ @include version.texi
+-@settitle Autoconf
++@settitle Autoconf v2.5
+ @setchapternewpage odd
+ @setcontentsaftertitlepage
+ @finalout
+@@ -96,30 +96,30 @@
+
+-@dircategory GNU programming tools
++@dircategory Miscellaneous
+ @direntry
+-* Autoconf: (autoconf). Create source code configuration scripts
++* Autoconf v2.5: (autoconf25). Create source code configuration scripts
+ @end direntry
+
+ @dircategory Individual utilities
+ @direntry
+-* autoscan: (autoconf)autoscan Invocation.
++* autoscan: (autoconf25)autoscan Invocation.
+ Semi-automatic @file{configure.ac} writing
+-* ifnames: (autoconf)ifnames Invocation.
++* ifnames: (autoconf25)ifnames Invocation.
+ Listing the conditionals in source code
+-* autoconf: (autoconf)autoconf Invocation.
++* autoconf: (autoconf25)autoconf Invocation.
+ How to create configuration scripts
+-* autoreconf: (autoconf)autoreconf Invocation.
++* autoreconf: (autoconf25)autoreconf Invocation.
+ Remaking multiple @command{configure} scripts
+-* autoheader: (autoconf)autoheader Invocation.
++* autoheader: (autoconf25)autoheader Invocation.
+ How to create configuration templates
+-* autom4te: (autoconf)Invoking autom4te.
++* autom4te: (autoconf25)Invoking autom4te.
+ The Autoconf executables backbone
+-* configure: (autoconf)configure Invocation.
++* configure: (autoconf25)configure Invocation.
+ Configuring a package
+-* autoupdate: (autoconf)autoupdate Invocation.
++* autoupdate: (autoconf25)autoupdate Invocation.
+ Automatic update of @file{configure.ac}
+-* config.status: (autoconf)config.status Invocation.
++* config.status: (autoconf25)config.status Invocation.
+ Recreating a configuration
+-* testsuite: (autoconf)testsuite Invocation.
++* testsuite: (autoconf25)testsuite Invocation.
+ Running an Autotest test suite
+ @end direntry
+
+--- autoconf-2.54/doc/Makefile.in.orig 2002-12-14 20:26:08.000000000 +0200
++++ autoconf-2.54/doc/Makefile.in 2002-12-14 20:28:12.000000000 +0200
+@@ -95,7 +95,7 @@
+ TEXI2HTML = texi2html
+ TEXI2HTML_FLAGS = -split_chapter
+
+-info_TEXINFOS = autoconf.texi standards.texi
++info_TEXINFOS = autoconf25.texi standards.texi
+ autoconf_TEXINFOS = fdl.texi install.texi
+ standards_TEXINFOS = make-stds.texi
+
+@@ -112,7 +112,7 @@
+ DIST_SOURCES =
+ TEXINFO_TEX = $(top_srcdir)/config/texinfo.tex
+ am__TEXINFO_TEX_DIR = $(top_srcdir)/config
+-INFO_DEPS = autoconf.info standards.info
++INFO_DEPS = autoconf25.info standards.info
+ DVIS = autoconf.dvi standards.dvi
+ PDFS = autoconf.pdf standards.pdf
+ PSS = autoconf.ps standards.ps
+@@ -143,13 +143,13 @@
+ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
+ MAKEINFO='$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir)' \
+ $(TEXI2PDF) `test -f '$<' || echo '$(srcdir)/'`$<
+-autoconf.info: version.texi $(autoconf_TEXINFOS)
++autoconf25.info: version.texi $(autoconf_TEXINFOS)
+ autoconf.dvi: version.texi $(autoconf_TEXINFOS)
+ autoconf.pdf: version.texi $(autoconf_TEXINFOS)
+ version.texi: stamp-vti
+-stamp-vti: autoconf.texi $(top_srcdir)/configure.ac
+- @(dir=.; test -f ./autoconf.texi || dir=$(srcdir); \
+- set `$(SHELL) $(top_srcdir)/config/mdate-sh $$dir/autoconf.texi`; \
++stamp-vti: autoconf25.texi $(top_srcdir)/configure.ac
++ @(dir=.; test -f ./autoconf25.texi || dir=$(srcdir); \
++ set `$(SHELL) $(top_srcdir)/config/mdate-sh $$dir/autoconf25.texi`; \
+ echo "@set UPDATED $$1 $$2 $$3"; \
+ echo "@set UPDATED-MONTH $$2 $$3"; \
+ echo "@set EDITION $(VERSION)"; \