summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-12-23 23:02:39 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-12-23 23:02:39 +0000
commit4a8b67394da38422f2f7b6003fde3cc9964eadb4 (patch)
treea28dc3287be8b3cc63f9c9c4b86cd2b49e3f278e /sys-devel/binutils
parentadded rc-script to save and restore mixer settings (diff)
downloadhistorical-4a8b67394da38422f2f7b6003fde3cc9964eadb4.tar.gz
historical-4a8b67394da38422f2f7b6003fde3cc9964eadb4.tar.bz2
historical-4a8b67394da38422f2f7b6003fde3cc9964eadb4.zip
add missing manpages, and also add info pages
Diffstat (limited to 'sys-devel/binutils')
-rw-r--r--sys-devel/binutils/binutils-2.11.90.0.31.ebuild97
1 files changed, 62 insertions, 35 deletions
diff --git a/sys-devel/binutils/binutils-2.11.90.0.31.ebuild b/sys-devel/binutils/binutils-2.11.90.0.31.ebuild
index 7cb7578796fc..7588e26f7186 100644
--- a/sys-devel/binutils/binutils-2.11.90.0.31.ebuild
+++ b/sys-devel/binutils/binutils-2.11.90.0.31.ebuild
@@ -1,40 +1,58 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.90.0.31.ebuild,v 1.1 2001/12/22 05:10:25 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.90.0.31.ebuild,v 1.2 2001/12/23 23:02:39 azarah Exp $
S=${WORKDIR}/${P}
-DESCRIPTION="Tools necessary to build programs"
+DESCRIPTION="GNU development tools - necessary to build programs"
SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.gz http://www.ibiblio.org/${PN}-manpages-${PV}.tar.bz2"
DEPEND="virtual/glibc"
src_unpack() {
unpack ${P}.tar.gz
+
cd ${S}
#man pages are tarred up seperately because building them depends on perl, which isn't installed at
#Gentoo Linux bootstrap time.
mkdir man; cd man
- tar xjf ${DISTDIR}/${PN}-manpages-${PV}.tar.bz2
+ tar xjf ${DISTDIR}/${PN}-manpages-${PV}.tar.bz2 || die
}
src_compile() {
- ./configure --enable-shared --enable-64-bit-bfd --prefix=/usr --mandir=/usr/share/man --host=${CHOST} --without-included-gettext || die
- if [ "`use static`" ]
- then
- emake -e LDFLAGS=-all-static || die
- else
- emake || die
- fi
+ ./configure --enable-shared \
+ --enable-64-bit-bfd \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ --without-included-gettext || die
+
+ if [ "`use static`" ]
+ then
+ emake -e LDFLAGS=-all-static || die
+ else
+ emake || die
+ fi
+
+ if [ -z "`use build`" ]
+ then
+ #make the info pages (makeinfo included with gcc is used)
+ make info || die
+ fi
}
src_install() {
- make prefix=${D}/usr mandir=${D}/usr/share/man install || die
- #c++filt is included with gcc -- what are these GNU people thinking?
- rm ${D}/usr/bin/c++filt ${D}/usr/share/man/man1/c++filt*
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
- #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip; we should reverse
- #it:
+ #c++filt is included with gcc -- what are these GNU people thinking?
+ #but not the manpage, so leave that!
+ rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
+
+ #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip
+ #we should reverse it:
rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
#the strip symlink gets created in the loop below
@@ -46,7 +64,7 @@ src_install() {
local x
for x in * strip
do
- if [ ! -e ../${CHOST}/bin/${x} ]
+ if [ ! -e ../${CHOST}/bin/${x} ]
then
mv $x ../${CHOST}/bin/${x}
else
@@ -54,29 +72,38 @@ src_install() {
fi
ln -s ../${CHOST}/bin/${x} ${x}
done
+
cd ${S}
if [ -z "`use build`" ]
- then
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
+ then
+ #install info pages
+ make infodir=${D}/usr/share/info \
+ install-info || die
+
+ dodoc COPYING* README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
+ docinto ld
+ dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog*
+ #install new updated manpages
rm -f ${D}/usr/share/man/man1/*
doman ${S}/man/*.1
- else
- rm -rf ${D}/usr/share/man
- fi
+ #next two is missing from the new manpages
+ doman ${S}/ld/ld.1
+ doman ${S}/gas/doc/as.1
+ else
+ rm -rf ${D}/usr/share/man
+ fi
}