summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-10-30 03:58:47 +0000
committerAron Griffis <agriffis@gentoo.org>2004-10-30 03:58:47 +0000
commitcc7996a3633e1040d9e8faeaa1f343df81b05206 (patch)
tree27ac0292feaa7e8751551564b753d9dada3c72e3 /sys-devel/bison/bison-1.875d.ebuild
parentAdd ebuild for Jim Jozwiak's nutrition program. Thanks to Chris Houser (Chous... (diff)
downloadhistorical-cc7996a3633e1040d9e8faeaa1f343df81b05206.tar.gz
historical-cc7996a3633e1040d9e8faeaa1f343df81b05206.tar.bz2
historical-cc7996a3633e1040d9e8faeaa1f343df81b05206.zip
Update to 1.875d for the sake of toolchain.org builds
Diffstat (limited to 'sys-devel/bison/bison-1.875d.ebuild')
-rw-r--r--sys-devel/bison/bison-1.875d.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sys-devel/bison/bison-1.875d.ebuild b/sys-devel/bison/bison-1.875d.ebuild
new file mode 100644
index 000000000000..0b031663d6de
--- /dev/null
+++ b/sys-devel/bison/bison-1.875d.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875d.ebuild,v 1.1 2004/10/30 03:58:47 agriffis Exp $
+
+inherit gcc flag-o-matic eutils gnuconfig
+
+DESCRIPTION="A yacc-compatible parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/bison/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="nls static"
+
+DEPEND="sys-devel/m4
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.32-extfix.patch
+ gnuconfig_update
+}
+
+src_compile() {
+ # Bug 39842 says that bison segfaults when built on amd64 with
+ # optimizations. This will probably be fixed in a future gcc
+ # version, but for the moment just disable optimizations for that
+ # arch (04 Feb 2004 agriffis)
+ [ "$ARCH" == "amd64" ] && append-flags -O0
+
+ # Bug 29017 says that bison has compile-time issues with
+ # -march=k6* prior to 3.4CVS. Use -march=i586 instead
+ # (04 Feb 2004 agriffis)
+ #
+ if (( $(gcc-major-version) == 3 && $(gcc-minor-version) < 4 )) ; then
+ replace-cpu-flags k6 k6-1 k6-2 i586
+ fi
+
+ econf $(use_enable nls) || die
+ use static && append-ldflags -static
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ datadir=/usr/share \
+ mandir=/usr/share/man \
+ infodir=/usr/share/info \
+ install || die
+
+ # This one is installed by dev-util/yacc
+ mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
+
+ # We do not need this.
+ rm -f ${D}/usr/lib/liby.a
+
+ dodoc AUTHORS NEWS ChangeLog README REFERENCES OChangeLog doc/FAQ
+}
+
+pkg_postinst() {
+ if [ ! -e "${ROOT}/usr/bin/yacc" ] ; then
+ ln -s yacc.bison /usr/bin/yacc
+ fi
+}