summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-05-13 04:32:52 +0000
committerMike Frysinger <vapier@gentoo.org>2006-05-13 04:32:52 +0000
commitbc09710b361f98ae0408d2744ad44bcb75297a9f (patch)
treed5ec2b1eeddd17dc8c6dcc43b96373635e2128b7 /sys-devel/gcc
parentfix patch to work on gcc-4.0.x #133098 by John Bachan (diff)
downloadhistorical-bc09710b361f98ae0408d2744ad44bcb75297a9f.tar.gz
historical-bc09710b361f98ae0408d2744ad44bcb75297a9f.tar.bz2
historical-bc09710b361f98ae0408d2744ad44bcb75297a9f.zip
Split off cross-compile patch since new changes are incompat from old gcc-4.0.x #133098 by John Bachan.
Package-Manager: portage-2.1_pre10-r5
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/files/4.1.0/gcc-4.1.0-cross-compile.patch40
-rw-r--r--sys-devel/gcc/gcc-4.1.0.ebuild4
3 files changed, 48 insertions, 3 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index f07178ae186b..497239244569 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.534 2006/05/12 23:55:54 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.535 2006/05/13 04:32:52 vapier Exp $
+
+ 13 May 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/4.1.0/gcc-4.1.0-cross-compile.patch, gcc-4.1.0.ebuild:
+ Split off cross-compile patch since new changes are incompat from old
+ gcc-4.0.x #133098 by John Bachan.
11 May 2006; Joshua Kinard <kumba@gentoo.org> gcc-3.4.6-r1.ebuild:
Marked stable on mips.
diff --git a/sys-devel/gcc/files/4.1.0/gcc-4.1.0-cross-compile.patch b/sys-devel/gcc/files/4.1.0/gcc-4.1.0-cross-compile.patch
new file mode 100644
index 000000000000..523caa48a3c8
--- /dev/null
+++ b/sys-devel/gcc/files/4.1.0/gcc-4.1.0-cross-compile.patch
@@ -0,0 +1,40 @@
+Some notes on the 'bootstrap with or without libc headers' debate:
+http://linuxfromscratch.org/pipermail/lfs-dev/2005-July/052409.html
+http://gcc.gnu.org/ml/gcc/2005-07/msg01195.html
+
+--- gcc/unwind-dw2.c
++++ gcc/unwind-dw2.c
+@@ -253,9 +253,11 @@
+ }
+ #endif
+
++#ifndef inhibit_libc
+ #ifdef MD_UNWIND_SUPPORT
+ #include MD_UNWIND_SUPPORT
+ #endif
++#endif
+
+ /* Extract any interesting information from the CIE for the translation
+ unit F belongs to. Return a pointer to the byte after the augmentation,
+--- gcc/configure
++++ gcc/configure
+@@ -12857,7 +12857,7 @@ then
+ | powerpc*-*-*,powerpc64*-*-*)
+ CROSS="$CROSS -DNATIVE_CROSS" ;;
+ esac
+-elif test "x$TARGET_SYSTEM_ROOT" != x; then
++elif test "x$TARGET_SYSTEM_ROOT" != x -o $build != $host; then
+ SYSTEM_HEADER_DIR=$build_system_header_dir
+ fi
+
+--- gcc/configure.ac
++++ gcc/configure.ac
+@@ -1717,7 +1717,7 @@ then
+ | powerpc*-*-*,powerpc64*-*-*)
+ CROSS="$CROSS -DNATIVE_CROSS" ;;
+ esac
+-elif test "x$TARGET_SYSTEM_ROOT" != x; then
++elif test "x$TARGET_SYSTEM_ROOT" != x -o $build != $host; then
+ SYSTEM_HEADER_DIR=$build_system_header_dir
+ fi
+
diff --git a/sys-devel/gcc/gcc-4.1.0.ebuild b/sys-devel/gcc/gcc-4.1.0.ebuild
index 844c0895de17..31eaf39ebe8b 100644
--- a/sys-devel/gcc/gcc-4.1.0.ebuild
+++ b/sys-devel/gcc/gcc-4.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0.ebuild,v 1.17 2006/04/28 04:54:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0.ebuild,v 1.18 2006/05/13 04:32:52 vapier Exp $
PATCH_VER="1.3"
UCLIBC_VER="1.1"
@@ -60,7 +60,7 @@ src_unpack() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
# Fix cross-compiling
- epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-cross-compile.patch
+ epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
}