summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-06 05:27:28 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-06 05:27:28 +0000
commite7d052192f29b94296dd5ebd017702d5cd9e0dd2 (patch)
tree521105daacc2e86d23edd2427a93fb6acc79f38c /sys-devel/gdb
parent*** empty log message *** (diff)
downloadhistorical-e7d052192f29b94296dd5ebd017702d5cd9e0dd2.tar.gz
historical-e7d052192f29b94296dd5ebd017702d5cd9e0dd2.tar.bz2
historical-e7d052192f29b94296dd5ebd017702d5cd9e0dd2.zip
*** empty log message ***
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/gdb-5.0-r2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sys-devel/gdb/gdb-5.0-r2.ebuild b/sys-devel/gdb/gdb-5.0-r2.ebuild
index 87afa4fcd25d..c1b966e5102b 100644
--- a/sys-devel/gdb/gdb-5.0-r2.ebuild
+++ b/sys-devel/gdb/gdb-5.0-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-5.0-r2.ebuild,v 1.4 2001/02/07 21:04:43 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-5.0-r2.ebuild,v 1.5 2001/03/06 05:27:28 achim Exp $
A=${P}.tar.bz2
S=${WORKDIR}/${P}
@@ -10,15 +10,21 @@ SRC_URI="ftp://sourceware.cygnus.com/pub/gdb/releases/${A}
ftp://ftp.freesoftware.com/pub/sourceware/gdb/releases/${A}"
DEPEND=">=sys-libs/ncurses-5.2-r2
- sys-devel/gettext"
+ nls? ( sys-devel/gettext )"
RDEPEND=">=sys-libs/ncurses-5.2-r2"
HOMEPAGE="http://www.gnu.org/software/gdb/gdb.html"
src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
try ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
- --without-included-regex --without-included-gettext --host=${CHOST}
+ --without-included-regex --without-included-gettext --host=${CHOST} ${myconf}
try make ${MAKEOPTS}
}