summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-07-21 00:07:08 +0000
committerJeroen Roovers <jer@gentoo.org>2010-07-21 00:07:08 +0000
commit7e2b5f0ca7b6b2c86b64e6aff4618e9e58a54c51 (patch)
treee84a644c296d206f175e5ca1d914d16cc5e27e14 /sys-devel/kgcc64/kgcc64-4.4.4.ebuild
parentadded amd64 keyword + ebuild cleanup. (diff)
downloadhistorical-7e2b5f0ca7b6b2c86b64e6aff4618e9e58a54c51.tar.gz
historical-7e2b5f0ca7b6b2c86b64e6aff4618e9e58a54c51.tar.bz2
historical-7e2b5f0ca7b6b2c86b64e6aff4618e9e58a54c51.zip
Version bump.
Package-Manager: portage-2.2_rc67/cvs/Linux i686
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-4.4.4.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-4.4.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/kgcc64-4.4.4.ebuild b/sys-devel/kgcc64/kgcc64-4.4.4.ebuild
new file mode 100644
index 000000000000..fa72aaa9ea44
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-4.4.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.4.4.ebuild,v 1.1 2010/07/21 00:07:08 jer Exp $
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.0"
+ETYPE="gcc-compiler"
+GCC_FILESDIR=${FILESDIR/${PN}/gcc}
+
+inherit toolchain eutils
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on mips and sparc; all other archs, refer to bug #228115
+KEYWORDS="~hppa"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}