summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-15 12:11:25 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-15 12:11:25 +0000
commitf2b861cc4638bb3356b9948708dc4a01288e8093 (patch)
tree41d28b8a99c178827e35997dfa1a28ee938a0313 /sys-devel/libtool
parentversion bump as per bug #81826 thanks to Marco Morales <soulse@gmail.com> (diff)
downloadhistorical-f2b861cc4638bb3356b9948708dc4a01288e8093.tar.gz
historical-f2b861cc4638bb3356b9948708dc4a01288e8093.tar.bz2
historical-f2b861cc4638bb3356b9948708dc4a01288e8093.zip
Add a catch for infer tags with CC=cc just like CC=gcc.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/ChangeLog6
-rw-r--r--sys-devel/libtool/Manifest4
-rw-r--r--sys-devel/libtool/files/1.5.6/libtool-1.5-filter-host-tags.patch12
3 files changed, 16 insertions, 6 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index 713984cdaa98..9ef3391ef125 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/libtool
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.71 2005/02/07 04:27:02 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.72 2005/02/15 12:11:25 vapier Exp $
+
+ 15 Feb 2005; Mike Frysinger <vapier@gentoo.org>
+ files/1.5.6/libtool-1.5-filter-host-tags.patch:
+ Add a catch for infer tags with CC=cc just like CC=gcc.
06 Feb 2005; Joshua Kinard <kumba@gentoo.org> libtool-1.5.10-r4.ebuild:
Marked stable on mips.
diff --git a/sys-devel/libtool/Manifest b/sys-devel/libtool/Manifest
index 4230fc65cd7c..33663ed707ac 100644
--- a/sys-devel/libtool/Manifest
+++ b/sys-devel/libtool/Manifest
@@ -1,4 +1,4 @@
-MD5 928d9c78269a4a81c4cfdc2db5338ab7 ChangeLog 12465
+MD5 47722b32229e3aa6e2d9ea2a65f3de8c ChangeLog 12625
MD5 a536bb0ae982e0a2e3360ed28c93cee0 libtool-1.5.10-r4.ebuild 5186
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 c941fdf418f07781f32ec26b239a6a65 libtool-1.3.5.ebuild 1487
@@ -29,7 +29,7 @@ MD5 94591cd9fb847704a323c0faf31fdbf2 files/1.4.3/libtool-1.4.3-ltmain-SED.patch
MD5 a9be6866b7096092613595ccff0fd773 files/1.4.3/libtool-1.4.3-pass-thread-flags.patch 494
MD5 c4fd959743953818fe6ab06c7d84e795 files/1.4.3/libtool-1.4.3-quotes.patch 12951
MD5 5fc838faf61964397b525e579783c190 files/1.4.3/libtool-1.4.3-uclibc.patch 5911
-MD5 dca7915553521b5ada0669cafb35537c files/1.5.6/libtool-1.5-filter-host-tags.patch 995
+MD5 2badc5a56ce45a238edbef00b20677f7 files/1.5.6/libtool-1.5-filter-host-tags.patch 1146
MD5 5e84c0a07a77ed6408b25453373914ab files/1.5.6/libtool-1.5.6-ltmain-SED.patch 431
MD5 ec9cd0c9953bac111564122a5c209278 files/1.5.2/libtool-1.5-filter-host-tags.patch 1846
MD5 6ef585a59058c79f3601bbd7787f2683 files/1.5.2/libtool-1.5-libtool.m4-x86_64.patch 466
diff --git a/sys-devel/libtool/files/1.5.6/libtool-1.5-filter-host-tags.patch b/sys-devel/libtool/files/1.5.6/libtool-1.5-filter-host-tags.patch
index ce1cb4698dd6..e418b43ea4f3 100644
--- a/sys-devel/libtool/files/1.5.6/libtool-1.5-filter-host-tags.patch
+++ b/sys-devel/libtool/files/1.5.6/libtool-1.5-filter-host-tags.patch
@@ -1,6 +1,11 @@
---- libtool-1.5.10/ltmain.in.orig 2004-11-09 13:43:24.290875562 -0500
-+++ libtool-1.5.10/ltmain.in 2004-11-09 13:45:51.250048464 -0500
-@@ -242,7 +242,16 @@
+Make the infer tag logic a bit more magical since a lot of old packages still
+exist which utilize this functionality.
+
+http://bugs.gentoo.org/show_bug.cgi?id=77921
+
+--- libtool-1.5.10/ltmain.in
++++ libtool-1.5.10/ltmain.in
+@@ -242,7 +242,17 @@
esac
CC_quoted="$CC_quoted $arg"
done
@@ -9,6 +14,7 @@
+ # and sometimes libtool has CC=<HOST>-gcc but user does CC=gcc
+ extendcc=${host}-${CC}
case "$@ " in
++ "cc "* | " cc "* | "${host}-cc "* | " ${host}-cc "*|\
+ "gcc "* | " gcc "* | "${host}-gcc "* | " ${host}-gcc "*)
+ tagname=CC
+ break ;;