summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-04-21 09:24:25 +0000
committerFabian Groffen <grobian@gentoo.org>2011-04-21 09:24:25 +0000
commit16f97cb37a9fae305ab55b65fd4d794177ed4f36 (patch)
tree2cad640d0743dbc8cabab655e9b305b382c8b05a /sys-devel/llvm/llvm-9999.ebuild
parentmedia-gfx/blender: Integrate patch for CVE-2009-3850 (bug #293130) (diff)
downloadhistorical-16f97cb37a9fae305ab55b65fd4d794177ed4f36.tar.gz
historical-16f97cb37a9fae305ab55b65fd4d794177ed4f36.tar.bz2
historical-16f97cb37a9fae305ab55b65fd4d794177ed4f36.zip
Fix broken reference that I missed yesterday
Package-Manager: portage-2.2.01.18091-prefix/cvs/SunOS i386
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index b3235a6f3dad..91451fd5beb0 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.11 2011/04/20 18:08:52 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.12 2011/04/21 09:24:25 grobian Exp $
EAPI="3"
inherit subversion eutils multilib toolchain-funcs
@@ -169,7 +169,7 @@ src_install() {
for f in "${ED}"/usr/bin/* "${ED}"/usr/lib/${PN}/libLTO.dylib ; do
ebegin "fixing install_name reference to libLLVM-${PV}.dylib of ${f##*/}"
install_name_tool \
- -change "${S}"/Release/lib/libLLVM-${PV}.dylib \
+ -change "@executable_path/../lib/libLLVM-${PV}.dylib" \
"${EPREFIX}"/usr/lib/${PN}/libLLVM-${PV}.dylib \
"${f}"
eend $?