summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-02-07 15:04:14 +0000
committerAron Griffis <agriffis@gentoo.org>2004-02-07 15:04:14 +0000
commit89d6be4f6bafe85359fed628f92c83bab3594acc (patch)
tree0f674af097c99c5e11dd9d99236c16ae19edf6a9 /sys-devel/pmake
parentClean up this ebuild. Fix the arch support, which was messy and (I think) wr... (diff)
downloadhistorical-89d6be4f6bafe85359fed628f92c83bab3594acc.tar.gz
historical-89d6be4f6bafe85359fed628f92c83bab3594acc.tar.bz2
historical-89d6be4f6bafe85359fed628f92c83bab3594acc.zip
Clean up this ebuild. Fix the arch support, which was messy and (I think) wrong because CFLAGS was being overridden without including the defines. This fixes bug 39159
Diffstat (limited to 'sys-devel/pmake')
-rw-r--r--sys-devel/pmake/Manifest4
-rw-r--r--sys-devel/pmake/files/digest-pmake-1.45-r31
-rw-r--r--sys-devel/pmake/pmake-1.45-r3.ebuild58
3 files changed, 61 insertions, 2 deletions
diff --git a/sys-devel/pmake/Manifest b/sys-devel/pmake/Manifest
index d64bcc25847f..67b531b73aea 100644
--- a/sys-devel/pmake/Manifest
+++ b/sys-devel/pmake/Manifest
@@ -1,6 +1,6 @@
-MD5 4b57bbca577e83366ac9559101eda733 ChangeLog 1048
+MD5 fe3aff122289ba7c2ede049ed5726304 ChangeLog 1315
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 1ef9787141052c385c46d37d42a4c632 pmake-1.45-r3.ebuild 1532
+MD5 5095ef814a21698c2018b234cca91da2 pmake-1.45-r3.ebuild 1534
MD5 619d0976672df7e89310bd147ea2a106 pmake-1.45-r2.ebuild 1669
MD5 56b250e5c99455640556fcb776b9bd7e files/01_all_groffpatch.patch 485
MD5 1095ca9c07bda375bf9674fe20d79ba6 files/02_all_mktemp.patch 406
diff --git a/sys-devel/pmake/files/digest-pmake-1.45-r3 b/sys-devel/pmake/files/digest-pmake-1.45-r3
new file mode 100644
index 000000000000..110fde3e22d0
--- /dev/null
+++ b/sys-devel/pmake/files/digest-pmake-1.45-r3
@@ -0,0 +1 @@
+MD5 c0f21ad413abbb2fc76ec0d4d426578f pmake_1.45-11.tar.gz 252673
diff --git a/sys-devel/pmake/pmake-1.45-r3.ebuild b/sys-devel/pmake/pmake-1.45-r3.ebuild
new file mode 100644
index 000000000000..86a6dfb1dbac
--- /dev/null
+++ b/sys-devel/pmake/pmake-1.45-r3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.45-r3.ebuild,v 1.1 2004/02/07 15:04:07 agriffis Exp $
+
+IUSE=""
+
+inherit eutils
+EPATCH_SOURCE="${FILESDIR}"
+EPATCH_SUFFIX="patch"
+
+DESCRIPTION="BSD build tool to create programs in parallel"
+HOMEPAGE="http://www.netbsd.org/"
+SRC_URI="mirror://gentoo/${PN}_${PV}-11.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 alpha ia64 amd64"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND} >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A} && cd ${S} || die
+
+ # We do not want all patches in ${FILESDIR}, as 01_all_groffpatch.patch is
+ # not longer valid for this version.
+ epatch ${FILESDIR}/02_all_mktemp.patch
+
+ # Clean up headers to reduce warnings
+ sed -i -e 's|^#endif.*|#endif|' *.h */*.h
+}
+
+src_compile() {
+ local a=$ARCH
+ [[ $a = x86 ]] && a=i386
+
+ # The following CFLAGS are almost directly from Red Hat 8.0 and
+ # debian/rules, so assume it's okay to void out the __COPYRIGHT
+ # and __RCSID. I've checked the source and don't see the point,
+ # but whatever... (07 Feb 2004 agriffis)
+ CFLAGS="${CFLAGS} -Wall -D_GNU_SOURCE \
+ -D__COPYRIGHT\(x\)= -D__RCSID\(x\)= -I. \
+ -DMACHINE=\\\"gentoo\\\" -DMACHINE_ARCH=\\\"${a}\\\""
+ make -f Makefile.boot CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dodir /usr/share/mk
+ insinto /usr/share/mk
+ rm -f mk/*~
+ doins mk/*
+
+ mv bmake pmake
+ dobin pmake
+ dobin mkdep
+ mv make.1 pmake.1
+ doman mkdep.1 pmake.1
+ dodoc PSD.doc/tutorial.ms
+}