summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-12-04 09:27:00 +0000
committerPeter Volkov <pva@gentoo.org>2009-12-04 09:27:00 +0000
commitefe5a9e02fbf0f279ed382a105a2b7c729ca5e39 (patch)
tree17dd0aaf8b1d117b2db034e03c0be330fc66d0b1 /sys-devel/qconf/qconf-1.5_pre717.ebuild
parentreset WANT_AUTOMAKE to avoid "latest" warnings (diff)
downloadhistorical-efe5a9e02fbf0f279ed382a105a2b7c729ca5e39.tar.gz
historical-efe5a9e02fbf0f279ed382a105a2b7c729ca5e39.tar.bz2
historical-efe5a9e02fbf0f279ed382a105a2b7c729ca5e39.zip
Initial import. Used by net-im/psi.
Package-Manager: portage-2.2_rc51/cvs/Linux i686
Diffstat (limited to 'sys-devel/qconf/qconf-1.5_pre717.ebuild')
-rw-r--r--sys-devel/qconf/qconf-1.5_pre717.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-devel/qconf/qconf-1.5_pre717.ebuild b/sys-devel/qconf/qconf-1.5_pre717.ebuild
new file mode 100644
index 000000000000..a27a9aed5f0d
--- /dev/null
+++ b/sys-devel/qconf/qconf-1.5_pre717.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/qconf/qconf-1.5_pre717.ebuild,v 1.1 2009/12/04 09:27:00 pva Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="./configure like generator for qmake-based projects"
+HOMEPAGE="http://delta.affinix.com/qconf/"
+SRC_URI="http://delta.affinix.com/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-core"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Fake ./configure. Fails on unknown options
+ ./configure \
+ --prefix=/usr/ \
+ --qtdir=/usr/$(get_libdir)/ || die "./configure failed"
+
+ [ ! -f Makefile ] && die "./configure failed"
+}
+
+src_install() {
+ dobin qconf || die
+ dodoc README TODO || die
+ insinto /usr/share/${PN}
+ doins -r conf modules
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+}