summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-08 22:10:32 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-08 22:10:32 +0000
commita8a7054f08a2dd170481cd3cc27634ee9caa6073 (patch)
tree1b954f305cac3033de158c45224b6f64099270ad /sys-devel/smatch/smatch-9999.ebuild
parentVersion bump. Add linux context manager using netlink. (diff)
downloadhistorical-a8a7054f08a2dd170481cd3cc27634ee9caa6073.tar.gz
historical-a8a7054f08a2dd170481cd3cc27634ee9caa6073.tar.bz2
historical-a8a7054f08a2dd170481cd3cc27634ee9caa6073.zip
Initial ebuild.
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/smatch/smatch-9999.ebuild')
-rw-r--r--sys-devel/smatch/smatch-9999.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-devel/smatch/smatch-9999.ebuild b/sys-devel/smatch/smatch-9999.ebuild
new file mode 100644
index 000000000000..6a2ce508c7b3
--- /dev/null
+++ b/sys-devel/smatch/smatch-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/smatch-9999.ebuild,v 1.1 2011/09/08 22:10:32 vapier Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://repo.or.cz/smatch.git"
+ inherit git
+fi
+
+DESCRIPTION="static analysis tool for C"
+HOMEPAGE="http://smatch.sourceforge.net/"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI=""
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-db/sqlite"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions:${CPPFLAGS}:}' \
+ Makefile || die
+}
+
+src_compile() {
+ emake PREFIX=/usr V=1 CC="$(tc-getCC)" smatch || die
+}
+
+src_install() {
+ # default install target installs a lot of sparse cruft
+ dobin smatch || die
+ insinto /usr/share/smatch/smatch_data
+ doins smatch_data/* || die
+ dodoc FAQ README
+}