summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-09-23 18:28:25 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-09-23 18:28:25 +0000
commit35aa3855f5dc43829a3bdae49b7328520133e69b (patch)
treee65135cf5bac04c7afb6803e77836f02ba77f5ae /sys-devel
parentChanged GPL to GPL-2 in LICENSE (diff)
downloadhistorical-35aa3855f5dc43829a3bdae49b7328520133e69b.tar.gz
historical-35aa3855f5dc43829a3bdae49b7328520133e69b.tar.bz2
historical-35aa3855f5dc43829a3bdae49b7328520133e69b.zip
wrapper updates
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog8
-rw-r--r--sys-devel/autoconf/files/ac-wrapper.pl8
-rw-r--r--sys-devel/automake/ChangeLog7
-rw-r--r--sys-devel/automake/automake-1.6.1-r6.ebuild24
-rw-r--r--sys-devel/automake/files/am-wrapper.pl-1.629
5 files changed, 54 insertions, 22 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 49184b795a70..3411f9e1378c 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/autoconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.6 2002/05/22 22:51:59 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.7 2002/09/23 18:28:10 azarah Exp $
+
+ 23 Sep 2002; Martin Schlemmer <azarah@gentoo.org> ac-wrapper.pl :
+
+ Firstly i should mention that the perl wrapper 'ac-wrapper.pl', is
+ based on great work by Guillaume Cottenceau (gc@mandrakesoft.com).
+ This updates it to correctly detect if automake-1.6 was used.
autoconf-2.53a (22 May 2002)
diff --git a/sys-devel/autoconf/files/ac-wrapper.pl b/sys-devel/autoconf/files/ac-wrapper.pl
index 9ab810604a21..29005d259501 100644
--- a/sys-devel/autoconf/files/ac-wrapper.pl
+++ b/sys-devel/autoconf/files/ac-wrapper.pl
@@ -23,6 +23,12 @@
# -or-
# - `configure.in' contains AC_PREREQ and the value's 3 first letters
# are stringwise greater than '2.1'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.1'
+# -or-
+# - `Makefile.in' was generated by automake-1.6 or superior, which
+# specifically needs autoconf-2.5x
#
#use MDK::Common;
@@ -37,6 +43,8 @@ if (!$ENV{WANT_AUTOCONF_2_1}) {
&& ($ENV{WANT_AUTOCONF_2_5}
|| -r 'configure.ac'
|| (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
|| (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1')) {
$ENV{WANT_AUTOCONF_2_5} = 1; # to prevent further "cats" and to enhance consistency (possible cwd etc)
$binary = $binary_new;
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index 5839cdf10849..1d1f10db2a32 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/automake
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.12 2002/06/28 23:03:08 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.13 2002/09/23 18:28:25 azarah Exp $
+
+ 23 Sep 2002; Martin Schlemmer <azarah@gentoo.org> am-wrapper.pl-1.6 :
+ Firstly, 'am-wrapper.pl' is based on 'ac-wrapper.pl'. This is a nifty
+ script by Guillaume Cottenceau (gc@mandrakesoft.com). This release
+ adds updates for automake-1.6 detection.
automake-1.6.1-r6 (28 Jun 2002)
diff --git a/sys-devel/automake/automake-1.6.1-r6.ebuild b/sys-devel/automake/automake-1.6.1-r6.ebuild
index e10eee079419..03cc3aca4267 100644
--- a/sys-devel/automake/automake-1.6.1-r6.ebuild
+++ b/sys-devel/automake/automake-1.6.1-r6.ebuild
@@ -76,9 +76,8 @@ src_compile() {
cd ${S}
- cp automake.texi automake.texi.orig
- sed -e "s:setfilename automake.info:setfilename automake-1.6.info:" \
- automake.texi.orig >automake.texi
+ perl -pi -e "s:setfilename automake.info:setfilename automake-1.6.info:" \
+ automake.texi
./configure --prefix=/usr \
--infodir=/usr/share/info \
@@ -93,9 +92,8 @@ src_compile() {
cd ${OLD15_S}
- cp automake.texi automake.texi.orig
- sed -e "s:setfilename automake.info:setfilename automake-1.5.info:" \
- automake.texi.orig >automake.texi
+ perl -pi -e "s:setfilename automake.info:setfilename automake-1.5.info:" \
+ automake.texi
./configure --prefix=/usr \
--infodir=/usr/share/info \
@@ -124,24 +122,22 @@ fix_bins() {
for x in aclocal automake
do
- cp ${x} ${x}.orig
- sed -e "s:share/automake\":share/automake-${1}\":g" \
- -e "s:share/aclocal\":share/aclocal-${1}\":g" \
- ${x}.orig >${x}
+ perl -pi -e "s:share/automake\":share/automake-${1}\":g" ${x}
+ perl -pi -e "s:share/aclocal\":share/aclocal-${1}\":g" ${x}
done
# add "/usr/share/aclocal" to m4 search patch
cp aclocal aclocal.orig
sed -e '/&scan_m4_files (@dirlist);/i \push (@dirlist, \"/usr/share/aclocal\");' \
- aclocal.orig >aclocal
+ aclocal.orig > aclocal
# same as above, but 1.4 looks a bit differently
cp aclocal aclocal.orig
sed -e '/&scan_m4_files ($acdir, @dirlist);/i \push (@dirlist, \"/usr/share/aclocal\");' \
- aclocal.orig >aclocal
- cp aclocal aclocal.orig
+ aclocal.orig > aclocal
# "aclocal --print-ac-dir" should return "/usr/share/aclocal"
+ cp aclocal aclocal.orig
sed -e 's:print $acdir:print "/usr/share/aclocal":' \
- aclocal.orig >aclocal
+ aclocal.orig > aclocal
}
src_install() {
diff --git a/sys-devel/automake/files/am-wrapper.pl-1.6 b/sys-devel/automake/files/am-wrapper.pl-1.6
index 4aa266cc6d13..bb397c72f114 100644
--- a/sys-devel/automake/files/am-wrapper.pl-1.6
+++ b/sys-devel/automake/files/am-wrapper.pl-1.6
@@ -17,14 +17,24 @@
#
# - defaults to automake-1.4
# - runs automake-1.6x if it exists and...
-# - envvar WANT_AUTOMAKE_1_6 is set to `1'
+# - envvar WANT_AUTOMAKE_1_6 is set to `1'
+# -or-
+# - `Makefile.in' was generated by automake-1.6 or superior, which
+# specifically needs automake-1.6x
# - runs automake-1.5x if it exists and...
-# - envvar WANT_AUTOMAKE_1_5 is set to `1'
-# or - configure.ac is present
-# or - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# - envvar WANT_AUTOMAKE_1_5 is set to `1'
+# -or-
+# - configure.ac is present
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
# are stringwise greater than '2.1'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.1'
+# -or-
+# - `Makefile.in' was generated by automake-1.5x or superior, which
+# specifically needs automake-1.5x
#
-
#use MDK::Common;
sub cat_ { local *F; open F, $_[0] or return; my @l = <F>; wantarray ? @l : join '', @l }
@@ -33,14 +43,21 @@ my $binary = "$0-1.4";
my $binary_new = "$0-1.5x";
my $binary_vnew = "$0-1.6x";
+# question here is do we really want 1.5 or 1.6? Out of a KDE outlook, it
+# should rather be 1.5, and since most people would rather have migrated to
+# 1.5, and then stay with it for a bit (those 1.4 die hards ..), only have
+# the 'configure.ac' test for 1.5 ...
if (!$ENV{WANT_AUTOMAKE_1_4}) {
if (-x $binary_vnew # user may not have _1_6
- && ($ENV{WANT_AUTOMAKE_1_6}) ) {
+ && ($ENV{WANT_AUTOMAKE_1_6}
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6')) {
$binary = $binary_vnew;
} elsif (-x $binary_new # user may have only 2.13
&& ($ENV{WANT_AUTOMAKE_1_5}
|| -r 'configure.ac'
|| (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.5'
|| (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1')) {
$ENV{WANT_AUTOMAKE_1_5} = 1; # to prevent further "cats" and to enhance consistency (possible cwd etc)
$binary = $binary_new;