summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-01-16 04:50:23 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-01-16 04:50:23 +0000
commit41f9cae0000aa9582925e93f45a2f069a509b01e (patch)
tree647c0deb791afc7a70d1d40e2d108f2bfb16062f /sys-devel
parentInitial import. (diff)
downloadhistorical-41f9cae0000aa9582925e93f45a2f069a509b01e.tar.gz
historical-41f9cae0000aa9582925e93f45a2f069a509b01e.tar.bz2
historical-41f9cae0000aa9582925e93f45a2f069a509b01e.zip
Version bump, added new init script thanks to Eric Andresen (Ndiin).
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog9
-rw-r--r--sys-devel/distcc/distcc-1.0.ebuild28
-rw-r--r--sys-devel/distcc/files/digest-distcc-1.01
-rw-r--r--sys-devel/distcc/files/distccd.128
4 files changed, 65 insertions, 1 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 9e2c5a5f0ea1..578f074dae41 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/distcc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.16 2002/12/16 21:17:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.17 2003/01/16 04:50:23 bcowan Exp $
+
+*distcc-1.0 (15 Jan 2003)
+
+ 15 Jan 2003; Brad Cowan <bcowan@gentoo.org> distcc-1.0.ebuild,
+ files/digest-distcc-1.0:
+
+ Bumped version. Added new init script thanks to Eric Andreson (Ndiin).
16 Dec 2002; Aron Griffis <agriffis@gentoo.org> distcc-0.15.ebuild:
Added ~alpha to KEYWORDS
diff --git a/sys-devel/distcc/distcc-1.0.ebuild b/sys-devel/distcc/distcc-1.0.ebuild
new file mode 100644
index 000000000000..8c545003a13b
--- /dev/null
+++ b/sys-devel/distcc/distcc-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-1.0.ebuild,v 1.1 2003/01/16 04:50:23 bcowan Exp $
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+
+DEPEND="dev-libs/popt"
+
+src_compile() {
+ econf
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall
+
+ cd ${D}/usr/share/info
+ rm -f distcc.info.gz
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/distccd.1 distccd
+}
diff --git a/sys-devel/distcc/files/digest-distcc-1.0 b/sys-devel/distcc/files/digest-distcc-1.0
new file mode 100644
index 000000000000..982f3f53a158
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-1.0
@@ -0,0 +1 @@
+MD5 109b6af458bf780702e03747a5a2581a distcc-1.0.tar.bz2 203227
diff --git a/sys-devel/distcc/files/distccd.1 b/sys-devel/distcc/files/distccd.1
new file mode 100644
index 000000000000..cc132d7ae9b5
--- /dev/null
+++ b/sys-devel/distcc/files/distccd.1
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ rm -rf /var/tmp/distccd.pid
+ ebegin "Starting distccd"
+ PATH=`gcc-config --get-bin-path` /sbin/start-stop-daemon --start --quiet --startas /usr/bin/distccd \
+ -c nobody --pidfile /var/tmp/distccd.pid \
+ -- --pid-file /var/tmp/distccd.pid
+ eend $? "Failed to Start distccd"
+}
+
+stop() {
+ ebegin "Stopping distccd"
+ start-stop-daemon --stop --quiet --pidfile /var/tmp/distccd.pid
+ rm -rf /var/tmp/distccd.pid
+ eend $? "Failed to Stop distccd"
+}
+
+restart() {
+ ebegin "Restarting distccd"
+ svc_stop
+ svc_start
+ eend $? "Failed to Restart distccd"
+}