summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-09-03 17:52:05 +0000
committerFabian Groffen <grobian@gentoo.org>2010-09-03 17:52:05 +0000
commit56be924848ba6de7e882ba8304c067de5549b7b3 (patch)
tree9749cfa6d1a458ffdb06f94b963566da5d94ac35 /sys-devel
parentVersion bump: 655 is released (diff)
downloadhistorical-56be924848ba6de7e882ba8304c067de5549b7b3.tar.gz
historical-56be924848ba6de7e882ba8304c067de5549b7b3.tar.bz2
historical-56be924848ba6de7e882ba8304c067de5549b7b3.zip
Marked ~amd64-linux
Package-Manager: portage-2.2.01.15553-prefix/cvs/Darwin powerpc
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog5
-rw-r--r--sys-devel/clang/clang-2.7-r2.ebuild4
-rw-r--r--sys-devel/llvm/ChangeLog5
-rw-r--r--sys-devel/llvm/llvm-2.7.ebuild4
4 files changed, 12 insertions, 6 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index cd97f657bad8..58d04beb18d4 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.20 2010/08/26 07:07:43 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.21 2010/09/03 17:52:05 grobian Exp $
+
+ 03 Sep 2010; Fabian Groffen <grobian@gentoo.org> clang-2.7-r2.ebuild:
+ Marked ~amd64-linux
26 Aug 2010; Fabian Groffen <grobian@gentoo.org> clang-2.7-r2.ebuild,
clang-9999.ebuild:
diff --git a/sys-devel/clang/clang-2.7-r2.ebuild b/sys-devel/clang/clang-2.7-r2.ebuild
index 26922eb68241..fcf9f0c8c2fb 100644
--- a/sys-devel/clang/clang-2.7-r2.ebuild
+++ b/sys-devel/clang/clang-2.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.7-r2.ebuild,v 1.3 2010/08/28 14:06:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.7-r2.ebuild,v 1.4 2010/09/03 17:52:05 grobian Exp $
EAPI=3
@@ -17,7 +17,7 @@ SRC_URI="http://llvm.org/releases/${PV}/llvm-${PV}.tgz
LICENSE="UoI-NCSA"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~ppc-macos"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos"
IUSE="debug +static-analyzer system-cxx-headers test"
# Note: for LTO support, clang will depend on binutils with gold plugins, and LLVM built after that - http://llvm.org/docs/GoldPlugin.html
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 4864232c7237..d859e63f7157 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.16 2010/08/26 07:00:53 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.17 2010/09/03 17:49:49 grobian Exp $
+
+ 03 Sep 2010; Fabian Groffen <grobian@gentoo.org> llvm-2.7.ebuild:
+ Marked ~amd64-linux
26 Aug 2010; Fabian Groffen <grobian@gentoo.org> llvm-2.7.ebuild,
llvm-9999.ebuild:
diff --git a/sys-devel/llvm/llvm-2.7.ebuild b/sys-devel/llvm/llvm-2.7.ebuild
index f6a7ef800f30..36112354298f 100644
--- a/sys-devel/llvm/llvm-2.7.ebuild
+++ b/sys-devel/llvm/llvm-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.7.ebuild,v 1.5 2010/08/28 14:07:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.7.ebuild,v 1.6 2010/09/03 17:49:49 grobian Exp $
EAPI="3"
inherit eutils multilib toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="http://llvm.org/releases/${PV}/${P}.tgz"
LICENSE="UoI-NCSA"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~ppc-macos"
IUSE="alltargets debug +libffi llvm-gcc ocaml test udis86"
DEPEND="dev-lang/perl