summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-06 06:41:08 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-06 06:41:08 +0000
commit605a25f44164495958065e4c0828510ad1fbbb1e (patch)
tree96195fe0968a314121d6e0a4dd1c60b320d0094a /sys-devel
parentNew version, marked 2.8.1 x86 (diff)
downloadhistorical-605a25f44164495958065e4c0828510ad1fbbb1e.tar.gz
historical-605a25f44164495958065e4c0828510ad1fbbb1e.tar.bz2
historical-605a25f44164495958065e4c0828510ad1fbbb1e.zip
cross-compile fixes
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bc/bc-1.06-r5.ebuild6
-rw-r--r--sys-devel/flex/flex-2.5.4a-r5.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/sys-devel/bc/bc-1.06-r5.ebuild b/sys-devel/bc/bc-1.06-r5.ebuild
index e1bdbbb94bcf..682fbe4e43b9 100644
--- a/sys-devel/bc/bc-1.06-r5.ebuild
+++ b/sys-devel/bc/bc-1.06-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06-r5.ebuild,v 1.18 2004/11/13 05:48:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06-r5.ebuild,v 1.19 2004/12/06 06:38:38 vapier Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="Handy console-based calculator utility"
HOMEPAGE="http://www.gnu.org/software/bc/bc.html"
@@ -25,6 +25,7 @@ src_unpack() {
epatch ${FILESDIR}/bc-1.06-info-fix.diff
epatch ${FILESDIR}/bc-1.06-readline42.diff
+ sed -i -e '/^AR =/s:.*::' lib/Makefile.in
# Command line arguments for flex changed from the old
# 2.5.4 to 2.5.22, so fix configure if we are using the
@@ -49,6 +50,7 @@ src_compile() {
x86) replace-flags -Os -O2;;
amd64) replace-flags -O? -O0;;
esac
+ tc-export CC AR RANLIB
local myconf=""
use static && append-ldflags -static
diff --git a/sys-devel/flex/flex-2.5.4a-r5.ebuild b/sys-devel/flex/flex-2.5.4a-r5.ebuild
index 0dec5b252b5e..e38553cbe157 100644
--- a/sys-devel/flex/flex-2.5.4a-r5.ebuild
+++ b/sys-devel/flex/flex-2.5.4a-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/flex-2.5.4a-r5.ebuild,v 1.29 2004/11/12 15:51:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/flex-2.5.4a-r5.ebuild,v 1.30 2004/12/06 06:41:08 vapier Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="GNU lexical analyser generator"
HOMEPAGE="http://lex.sourceforge.net/"
@@ -29,6 +29,8 @@ src_unpack() {
}
src_compile() {
+ export CC="$(tc-getCC)"
+
./configure \
--prefix=/usr \
--host=${CHOST} \