summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-03-21 07:50:11 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-03-21 07:50:11 +0000
commit6887338211649336a77bf170f3a67cd0e1607c9e (patch)
tree152092834ba17d7a2e75484a6cb8f9b3d887bb33 /sys-devel
parentchanged sys-libs/glib to dev-libs/glib -- error caught by Frogger (diff)
downloadhistorical-6887338211649336a77bf170f3a67cd0e1607c9e.tar.gz
historical-6887338211649336a77bf170f3a67cd0e1607c9e.tar.bz2
historical-6887338211649336a77bf170f3a67cd0e1607c9e.zip
new version
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog9
-rw-r--r--sys-devel/autoconf/autoconf-2.53.ebuild118
-rw-r--r--sys-devel/autoconf/files/ac-wrapper.pl52
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.532
4 files changed, 180 insertions, 1 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 1f5648f4a239..334adb58cd9c 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/autoconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.2 2002/03/21 07:50:11 azarah Exp $
+
+*autoconf-2.53 (21 March 2002)
+
+ 21 March 2002; M.Schlemmer <azarah@gentoo.org> :
+
+ Add dual ebuild which contain 2.13 and 2.53, and autodetect the
+ correct version to use.
*autoconf-2.13-r2 (1 Feb 2002)
diff --git a/sys-devel/autoconf/autoconf-2.53.ebuild b/sys-devel/autoconf/autoconf-2.53.ebuild
new file mode 100644
index 000000000000..b6e17a05e111
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.53.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.53.ebuild,v 1.1 2002/03/21 07:50:11 azarah Exp $
+
+OLD_PV=2.13
+OLD_P=${PN}-${OLD_PV}
+S=${WORKDIR}/${P}
+OLD_S=${WORKDIR}/${OLD_P}
+DESCRIPTION="Used to create autoconfiguration files"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.bz2
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+DEPEND=">=sys-devel/automake-1.5
+ >=sys-devel/m4-1.4o-r2
+ sys-devel/perl"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${OLD_S}
+ patch -p0 < ${FILESDIR}/${OLD_P}-configure-gentoo.diff || die
+ patch -p0 < ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff || die
+}
+
+src_compile() {
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ doexe ${FILESDIR}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-2.5x
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+ mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PF}/${PV}
+ dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${PF}/${OLD_PV}
+ dodoc COPYING AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/autoconf/files/ac-wrapper.pl b/sys-devel/autoconf/files/ac-wrapper.pl
new file mode 100644
index 000000000000..b0235ce96983
--- /dev/null
+++ b/sys-devel/autoconf/files/ac-wrapper.pl
@@ -0,0 +1,52 @@
+#!/usr/bin/perl
+#
+#
+# Guillaume Cottenceau (gc@mandrakesoft.com)
+#
+# Copyright 2001 MandrakeSoft
+#
+# This software may be freely redistributed under the terms of the GNU
+# public license.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#
+#
+# Executes the correct autoconf version.
+#
+# - defaults to autoconf-2.13
+# - runs autoconf-2.5x if it exists and...
+# - envvar WANT_AUTOCONF_2_5 is set to `1'
+# -or-
+# - configure.ac is present
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.1'
+#
+
+#use MDK::Common;
+
+sub cat_ { local *F; open F, $_[0] or return; my @l = <F>; wantarray ? @l : join '', @l }
+
+my $binary = "$0-2.13";
+my $binary_new = "$0-2.5x";
+
+if (!$ENV{WANT_AUTOCONF_2_1}) {
+ if (-x $binary_new # user may have only 2.13
+ && ($ENV{WANT_AUTOCONF_2_5}
+ || -r 'configure.ac'
+ || (cat_('configure.in') =~ /^\s*AC_PREREQ\(([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1'
+ || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1')) {
+ $ENV{WANT_AUTOCONF_2_5} = 1; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_new;
+ } else {
+ $ENV{WANT_AUTOCONF_2_1} = 1; # for further consistency
+ }
+}
+
+$ENV{WANT_ACWRAPPER_DEBUG} and print STDERR "ac-wrapper: will execute <$binary>\n";
+
+exec $binary, @ARGV;
+
+die "ac-wrapper: ouch, couldn't call binary ($binary).\n";
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.53 b/sys-devel/autoconf/files/digest-autoconf-2.53
new file mode 100644
index 000000000000..349fb5d53f21
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.53
@@ -0,0 +1,2 @@
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844
+MD5 c121b003f51e293c2bf5a6105c721388 autoconf-2.53.tar.bz2 756398