summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-04-02 16:16:30 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-04-02 16:16:30 +0000
commit6b04c01040a46b21cc23f98c882ddfd08204f5a0 (patch)
tree300ecd0d1ec5bf9ccb5390c15e84ff74f190aa17 /sys-devel
parentupdated version, removed old (diff)
downloadhistorical-6b04c01040a46b21cc23f98c882ddfd08204f5a0.tar.gz
historical-6b04c01040a46b21cc23f98c882ddfd08204f5a0.tar.bz2
historical-6b04c01040a46b21cc23f98c882ddfd08204f5a0.zip
make install tweaks
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/ChangeLog12
-rw-r--r--sys-devel/bison/bison-1.34-r1.ebuild53
-rw-r--r--sys-devel/bison/files/digest-bison-1.34-r11
3 files changed, 65 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index b1f3a90ea89c..05f98b98a244 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-devel/bison
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.2 2002/04/02 16:16:30 azarah Exp $
+
+*bison-1.34-r1 (2 Apr 2002)
+
+ 2 Apr 2002; M.Schlemmer <azarah@gentoo.org> :
+
+ Change "make install" in src_install() to use $DESTDIR and not
+ $prefix, as some packages have the nasty habit of hardcoding
+ $prefix in "make install". Hopefully this will fix an invalid
+ search patch for bison.{hairy,simple} some users experienced
+ (${D}/usr/...).
*bison-1.28-r3 (1 Feb 2002)
diff --git a/sys-devel/bison/bison-1.34-r1.ebuild b/sys-devel/bison/bison-1.34-r1.ebuild
new file mode 100644
index 000000000000..03312f7887cd
--- /dev/null
+++ b/sys-devel/bison/bison-1.34-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.34-r1.ebuild,v 1.1 2002/04/02 16:16:30 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A yacc-compatible parser generator"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/bison/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --prefix=/usr \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ if [ -z "`use static`" ]
+ then
+ emake ${MAKEOPTS} || die
+ else
+ emake ${MAKEOPTS} LDFLAGS=-static || die
+ fi
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ datadir=/usr/share \
+ mandir=/usr/share/man \
+ infodir=/usr/share/info \
+ install || die
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING AUTHORS NEWS ChangeLog README REFERENCES OChangeLog
+ docinto txt
+ dodoc doc/FAQ
+ else
+ rm -rf ${D}/usr/share/man ${D}/usr/share/info
+ fi
+}
+
diff --git a/sys-devel/bison/files/digest-bison-1.34-r1 b/sys-devel/bison/files/digest-bison-1.34-r1
new file mode 100644
index 000000000000..f46fb398d41d
--- /dev/null
+++ b/sys-devel/bison/files/digest-bison-1.34-r1
@@ -0,0 +1 @@
+MD5 33ec6e34914a62ef5c4617efba9f3f30 bison-1.34.tar.gz 731400