summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-08-27 17:59:25 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-08-27 17:59:25 +0000
commitf881a837b79e0d8b33d497b51354eb011c2c1afd (patch)
tree895d8a30bf84712bb9162f2743db356965fec8d3 /sys-devel
parentversion bump. currently masked for the freeze. updated for gcc3 bug (diff)
downloadhistorical-f881a837b79e0d8b33d497b51354eb011c2c1afd.tar.gz
historical-f881a837b79e0d8b33d497b51354eb011c2c1afd.tar.bz2
historical-f881a837b79e0d8b33d497b51354eb011c2c1afd.zip
Corrects perl installs on fresh machines
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/perl/ChangeLog6
-rw-r--r--sys-devel/perl/files/stat.t289
-rw-r--r--sys-devel/perl/perl-5.6.1-r6.ebuild29
-rw-r--r--sys-devel/perl/perl-5.8.0-r1.ebuild4
-rw-r--r--sys-devel/perl/perl-5.8.0-r2.ebuild12
5 files changed, 309 insertions, 31 deletions
diff --git a/sys-devel/perl/ChangeLog b/sys-devel/perl/ChangeLog
index 3f59a030174d..8c883d423bbe 100644
--- a/sys-devel/perl/ChangeLog
+++ b/sys-devel/perl/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-devel/perl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.10 2002/08/16 02:12:50 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.11 2002/08/27 17:59:25 mcummings Exp $
*perl-5.8.0-r2 (16 Aug 2002)
@@ -22,6 +22,10 @@
*perl-5.6.1-r6 (04 Aug 2002)
+ 27 Aug 2002; mcummings <mcummings@gentoo.org> : Added stat.t fix,
+ fixes compile problems on boxes with no suid's in the */bin's
+ bug 7120, affects fresh installs only
+
05 Aug 2002; pvdabeel <pvdabee@gentoo.org> : Added ppc keyword
05 Aug 2002; pvdabeel <pvdabee@gentoo.org> : changelog entry
diff --git a/sys-devel/perl/files/stat.t b/sys-devel/perl/files/stat.t
new file mode 100644
index 000000000000..839108fc9397
--- /dev/null
+++ b/sys-devel/perl/files/stat.t
@@ -0,0 +1,289 @@
+#!./perl
+
+# $RCSfile: stat.t,v $$Revision: 1.1 $$Date: 2002/08/27 17:59:25 $
+
+BEGIN {
+ chdir 't' if -d 't';
+ @INC = '../lib';
+}
+
+use Config;
+
+print "1..58\n";
+
+$Is_MSWin32 = $^O eq 'MSWin32';
+$Is_Dos = $^O eq 'dos';
+$Is_Dosish = $Is_Dos || $^O eq 'os2' || $Is_MSWin32;
+$Is_Cygwin = $^O eq 'cygwin';
+chop($cwd = ($Is_MSWin32 ? `cd` : `pwd`));
+
+$DEV = `ls -l /dev` unless $Is_Dosish or $Is_Cygwin;
+
+unlink "Op.stat.tmp";
+if (open(FOO, ">Op.stat.tmp")) {
+ # hack to make Apollo update link count:
+ $junk = `ls Op.stat.tmp` unless ($Is_MSWin32 || $Is_Dos);
+
+ ($dev,$ino,$mode,$nlink,$uid,$gid,$rdev,$size,$atime,$mtime,$ctime,
+ $blksize,$blocks) = stat(FOO);
+ if ($nlink == 1) {
+ print "ok 1\n";
+ }
+ else {
+ print "# res=$res, nlink=$nlink.\nnot ok 1\n";
+ }
+ if ($Is_MSWin32 or $Is_Cygwin or $Is_Dos || ($mtime && $mtime == $ctime)) {
+ print "ok 2\n";
+ }
+ else {
+ print "# |$mtime| vs |$ctime|\nnot ok 2\n";
+ }
+
+ my $funky_FAT_timestamps = $Is_Cygwin;
+
+ sleep 3 if $funky_FAT_timestamps;
+
+ print FOO "Now is the time for all good men to come to.\n";
+ close(FOO);
+
+ sleep 2 unless $funky_FAT_timestamps;
+
+} else {
+ print "# open failed: $!\nnot ok 1\nnot ok 2\n";
+}
+
+if ($Is_Dosish) { unlink "Op.stat.tmp2"}
+else {
+ `rm -f Op.stat.tmp2;ln Op.stat.tmp Op.stat.tmp2; chmod 644 Op.stat.tmp`;
+}
+
+($dev,$ino,$mode,$nlink,$uid,$gid,$rdev,$size,$atime,$mtime,$ctime,
+ $blksize,$blocks) = stat('Op.stat.tmp');
+
+if ($Is_Dosish || $Config{dont_use_nlink})
+ {print "ok 3 # skipped: no link count\n";}
+elsif ($nlink == 2)
+ {print "ok 3\n";}
+else {print "# \$nlink is |$nlink|\nnot ok 3\n";}
+
+if ( $Is_Dosish
+ # Solaris tmpfs bug
+ || ($cwd =~ m#^/tmp# and $mtime && $mtime==$ctime && $^O eq 'solaris')
+ || $cwd =~ m#/afs/#
+ || $^O eq 'amigaos') {
+ print "ok 4 # skipped: different semantic of mtime/ctime\n";
+}
+elsif ( ($mtime && $mtime != $ctime) ) {
+ print "ok 4\n";
+}
+else {
+ print "not ok 4\n";
+ print "#4 If test op/stat.t fails test 4, check if you are on a tmpfs\n";
+ print "#4 of some sort. Building in /tmp sometimes has this problem.\n";
+ print "#4 Also building on the ClearCase VOBS filesystem may cause this failure.\n";
+}
+print "#4 :$mtime: should != :$ctime:\n";
+
+unlink "Op.stat.tmp" or print "# unlink failed: $!\n";
+if ($Is_MSWin32) { open F, '>Op.stat.tmp' and close F }
+else { `touch Op.stat.tmp` }
+
+if (-z 'Op.stat.tmp') {print "ok 5\n";} else {print "not ok 5\n";}
+if (! -s 'Op.stat.tmp') {print "ok 6\n";} else {print "not ok 6\n";}
+
+$Is_MSWin32 ? `cmd /c echo hi > Op.stat.tmp` : `echo hi >Op.stat.tmp`;
+if (! -z 'Op.stat.tmp') {print "ok 7\n";} else {print "not ok 7\n";}
+if (-s 'Op.stat.tmp') {print "ok 8\n";} else {print "not ok 8\n";}
+
+unlink 'Op.stat.tmp' or print "# unlink failed: $!\n";
+$olduid = $>; # can't test -r if uid == 0
+$Is_MSWin32 ? `cmd /c echo hi > Op.stat.tmp` : `echo hi >Op.stat.tmp`;
+chmod 0,'Op.stat.tmp';
+eval '$> = 1;'; # so switch uid (may not be implemented)
+if (!$> || $Is_Dos || ! -r 'Op.stat.tmp') {print "ok 9\n";} else {print "not ok 9\n";}
+if (!$> || ! -w 'Op.stat.tmp') {print "ok 10\n";} else {print "not ok 10\n";}
+eval '$> = $olduid;'; # switch uid back (may not be implemented)
+print "# olduid=$olduid, newuid=$>\n" unless ($> == $olduid);
+
+if (! -x 'Op.stat.tmp') {print "ok 11\n";}
+else {print "not ok 11\n";}
+
+foreach ((12,13,14,15,16,17)) {
+ print "ok $_\n"; #deleted tests
+}
+
+# in ms windows, Op.stat.tmp inherits owner uid from directory
+# not sure about os/2, but chown is harmless anyway
+eval { chown $>,'Op.stat.tmp'; 1 } or print "# $@" ;
+chmod 0700,'Op.stat.tmp';
+if (-r 'Op.stat.tmp') {print "ok 18\n";} else {print "not ok 18\n";}
+if (-w 'Op.stat.tmp') {print "ok 19\n";} else {print "not ok 19\n";}
+if ($Is_Dosish) {print "ok 20 # skipped: -x by extension\n";}
+elsif (-x 'Op.stat.tmp') {print "ok 20\n";}
+else {print "not ok 20\n";}
+
+if (-f 'Op.stat.tmp') {print "ok 21\n";} else {print "not ok 21\n";}
+if (! -d 'Op.stat.tmp') {print "ok 22\n";} else {print "not ok 22\n";}
+
+if (-d '.') {print "ok 23\n";} else {print "not ok 23\n";}
+if (! -f '.') {print "ok 24\n";} else {print "not ok 24\n";}
+
+if (!$Is_Dosish and `ls -l perl` =~ /^l.*->/) {
+ if (-l 'perl') {print "ok 25\n";} else {print "not ok 25\n";}
+}
+else {
+ print "ok 25\n";
+}
+
+if (-o 'Op.stat.tmp') {print "ok 26\n";} else {print "not ok 26\n";}
+
+if (-e 'Op.stat.tmp') {print "ok 27\n";} else {print "not ok 27\n";}
+unlink 'Op.stat.tmp2';
+if (! -e 'Op.stat.tmp2') {print "ok 28\n";} else {print "not ok 28\n";}
+
+if ($Is_MSWin32 || $Is_Dos)
+ {print "ok 29\n";}
+elsif ($DEV !~ /\nc.* (\S+)\n/)
+ {print "ok 29\n";}
+elsif (-c "/dev/$1")
+ {print "ok 29\n";}
+else
+ {print "not ok 29\n";}
+if (! -c '.') {print "ok 30\n";} else {print "not ok 30\n";}
+
+if ($Is_MSWin32 || $Is_Dos)
+ {print "ok 31\n";}
+elsif ($DEV !~ /\ns.* (\S+)\n/)
+ {print "ok 31\n";}
+elsif (-S "/dev/$1")
+ {print "ok 31\n";}
+else
+ {print "not ok 31\n";}
+if (! -S '.') {print "ok 32\n";} else {print "not ok 32\n";}
+
+if ($Is_MSWin32 || $Is_Dos)
+ {print "ok 33\n";}
+elsif ($DEV !~ /\nb.* (\S+)\n/)
+ {print "ok 33\n";}
+elsif (-b "/dev/$1")
+ {print "ok 33\n";}
+else
+ {print "not ok 33\n";}
+if (! -b '.') {print "ok 34\n";} else {print "not ok 34\n";}
+
+if ($^O eq 'mpeix' or $^O eq 'amigaos' or $Is_Dosish or $Is_Cygwin) {
+ print "ok 35 # skipped: no -u\n"; goto tty_test;
+}
+
+$cnt = $uid = 0;
+
+die "Can't run op/stat.t test 35 without pwd working" unless $cwd;
+my @bin = grep {-d} ($^O eq 'machten' ?
+ qw(/usr/bin /bin) :
+ qw(/sbin /usr/sbin /bin /usr/bin));
+unless (@bin) { print ("not ok 35\n"), goto tty_test; }
+for my $bin (@bin) {
+ opendir BIN, $bin or die "Can't opendir $bin: $!";
+ while (defined($_ = readdir BIN)) {
+ $_ = "$bin/$_";
+ $cnt++;
+ $uid++ if -u;
+ last if $uid && $uid < $cnt;
+ }
+}
+closedir BIN;
+
+# I suppose this is going to fail somewhere...
+if ($uid > 0 && $uid < $cnt)
+ {print "ok 35\n";}
+elsif ($uid == 0)
+ {print ("not ok 35\n"), goto tty_test; }
+else
+ {print "not ok 35 \n# ($uid $cnt)\n";}
+
+tty_test:
+
+# To assist in automated testing when a controlling terminal (/dev/tty)
+# may not be available (at, cron rsh etc), the PERL_SKIP_TTY_TEST env var
+# can be set to skip the tests that need a tty.
+unless($ENV{PERL_SKIP_TTY_TEST}) {
+ if ($Is_MSWin32) {
+ print "ok 36\n";
+ print "ok 37\n";
+ }
+ else {
+ my $TTY = "/dev/tty";
+
+ $TTY = "/dev/ttyp0" if $^O eq 'rhapsody';
+
+ if (defined $TTY) {
+ unless (open(TTY, $TTY)) {
+ print STDERR "Can't open $TTY--run t/TEST outside of make.\n";
+ }
+ if (-t TTY) {print "ok 36\n";} else {print "not ok 36\n";}
+ if (-c TTY) {print "ok 37\n";} else {print "not ok 37\n";}
+ close(TTY);
+ } else { # if some platform completely undefines $TTY
+ print "ok 36 # skipped\n";
+ print "ok 37 # skipped\n";
+ }
+ }
+ if (! -t TTY) {print "ok 38\n";} else {print "not ok 38\n";}
+ if (-t) {print "ok 39\n";} else {print "not ok 39\n";}
+}
+else {
+ print "ok 36\n";
+ print "ok 37\n";
+ print "ok 38\n";
+ print "ok 39\n";
+}
+open(null,"/dev/null");
+if (! -t null || -e '/xenix' || $^O eq 'machten' || $Is_MSWin32)
+ {print "ok 40\n";} else {print "not ok 40\n";}
+close(null);
+
+# These aren't strictly "stat" calls, but so what?
+
+if (-T 'op/stat.t') {print "ok 41\n";} else {print "not ok 41\n";}
+if (! -B 'op/stat.t') {print "ok 42\n";} else {print "not ok 42\n";}
+
+if (-B './perl' || -B './perl.exe') {print "ok 43\n";} else {print "not ok 43\n";}
+if (! -T './perl' && ! -T './perl.exe') {print "ok 44\n";} else {print "not ok 44\n";}
+
+open(FOO,'op/stat.t');
+eval { -T FOO; };
+if ($@ =~ /not implemented/) {
+ print "# $@";
+ for (45 .. 54) {
+ print "ok $_\n";
+ }
+}
+else {
+ if (-T FOO) {print "ok 45\n";} else {print "not ok 45\n";}
+ if (! -B FOO) {print "ok 46\n";} else {print "not ok 46\n";}
+ $_ = <FOO>;
+ if (/perl/) {print "ok 47\n";} else {print "not ok 47\n";}
+ if (-T FOO) {print "ok 48\n";} else {print "not ok 48\n";}
+ if (! -B FOO) {print "ok 49\n";} else {print "not ok 49\n";}
+ close(FOO);
+
+ open(FOO,'op/stat.t');
+ $_ = <FOO>;
+ if (/perl/) {print "ok 50\n";} else {print "not ok 50\n";}
+ if (-T FOO) {print "ok 51\n";} else {print "not ok 51\n";}
+ if (! -B FOO) {print "ok 52\n";} else {print "not ok 52\n";}
+ seek(FOO,0,0);
+ if (-T FOO) {print "ok 53\n";} else {print "not ok 53\n";}
+ if (! -B FOO) {print "ok 54\n";} else {print "not ok 54\n";}
+}
+close(FOO);
+
+if (-T '/dev/null') {print "ok 55\n";} else {print "not ok 55\n";}
+if (-B '/dev/null') {print "ok 56\n";} else {print "not ok 56\n";}
+
+# and now, a few parsing tests:
+$_ = 'Op.stat.tmp';
+if (-f) {print "ok 57\n";} else {print "not ok 57\n";}
+if (-f()) {print "ok 58\n";} else {print "not ok 58\n";}
+
+unlink 'Op.stat.tmp' or print "# unlink failed: $!\n";
diff --git a/sys-devel/perl/perl-5.6.1-r6.ebuild b/sys-devel/perl/perl-5.6.1-r6.ebuild
index 5d7e1e7492f5..8a49760bc982 100644
--- a/sys-devel/perl/perl-5.6.1-r6.ebuild
+++ b/sys-devel/perl/perl-5.6.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r6.ebuild,v 1.3 2002/08/14 02:44:23 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r6.ebuild,v 1.4 2002/08/27 17:59:25 mcummings Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
@@ -51,6 +51,7 @@ src_compile() {
-e 's#^all: $(FIRSTMAKEFILE) #all: README #' \
Makefile_orig > Makefile
export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
+ # fixes a bug in the make/testing on new systems
make -f Makefile depend || die
mv makefile makefile_orig
mv x2p/makefile x2p/makefile_orig
@@ -121,6 +122,7 @@ EOF
egrep -v "(<built-in>|<command line>)" makefile_orig >makefile
egrep -v "(<built-in>|<command line>)" x2p/makefile_orig >x2p/makefile
make -f Makefile || die
+ cp ${O}/files/stat.t ./t/op/
# Parallel make fails
# dont use the || die since some tests fail on bootstrap
if [ `expr "$PARCH" ":" "sparc"` -gt 4 ]; then
@@ -139,31 +141,10 @@ src_install() {
dosym /usr/lib/perl5/${PV}/${PARCH}/CORE/libperl.so /usr/lib/libperl.so
- make -f Makefile INSTALLMAN1DIR=${D}/usr/share/man/man1 INSTALLMAN3DIR=${D}/usr/share/man/man3 install || die
+# make -f Makefile INSTALLMAN1DIR=${D}/usr/share/man/man1 INSTALLMAN3DIR=${D}/usr/share/man/man3 install || die
+ make DESTDIR=${D} INSTALLMAN1DIR=${D}/usr/share/man/man1 INSTALLMAN3DIR=${D}/usr/share/man/man3 install || die "Unable to make install"
install -m 755 utils/pl2pm ${D}/usr/bin/pl2pm
-make all -f - <<EOF
-STDH =\$(wildcard /usr/include/linux/*.h) \$(wildcard /usr/include/asm/*.h) \
- \$(wildcard /usr/include/scsi/*.h)
-GCCDIR = \$(shell gcc --print-file-name include)
-
-PERLLIB = \$(D)/usr/lib/perl5/%{perlver}%{perlrel}
-PERL = PERL5LIB=\$(PERLLIB) \$(D)/usr/bin/perl
-PHDIR = \$(PERLLIB)/\${PARCH}-linux
-H2PH = \$(PERL) \$(D)/usr/bin/h2ph -d \$(PHDIR)/
-
-all: std-headers gcc-headers fix-config
-
-std-headers: \$(STDH)
- cd /usr/include && \$(H2PH) \$(STDH:/usr/include/%%=%%)
-
-gcc-headers: \$(GCCH)
- cd \$(GCCDIR) && \$(H2PH) \$(GCCH:\$(GCCDIR)/%%=%%)
-
-fix-config: \$(PHDIR)/Config.pm
- \$(PERL) -i -p -e "s|\$(D)||g;" \$<
-
-EOF
#man pages
diff --git a/sys-devel/perl/perl-5.8.0-r1.ebuild b/sys-devel/perl/perl-5.8.0-r1.ebuild
index f1b63c982c27..88e3f8e31cd4 100644
--- a/sys-devel/perl/perl-5.8.0-r1.ebuild
+++ b/sys-devel/perl/perl-5.8.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r1.ebuild,v 1.2 2002/08/14 11:56:44 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r1.ebuild,v 1.3 2002/08/27 17:59:25 mcummings Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
@@ -26,7 +26,7 @@ src_compile() {
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
-
+ myconf="${myconf} DEFINE=-DPERL5"
cd ${S}
diff --git a/sys-devel/perl/perl-5.8.0-r2.ebuild b/sys-devel/perl/perl-5.8.0-r2.ebuild
index 9ed164b9f5bc..abe96783f5ab 100644
--- a/sys-devel/perl/perl-5.8.0-r2.ebuild
+++ b/sys-devel/perl/perl-5.8.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r2.ebuild,v 1.2 2002/08/16 02:13:17 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r2.ebuild,v 1.3 2002/08/27 17:59:25 mcummings Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
@@ -110,8 +110,6 @@ src_install () {
dosym /usr/lib/perl5/${PV}/${PARCH}-thread-multi/CORE/libperl.so /usr/lib/libperl.so
#Fix for "stupid" modules and programs
dosym /usr/lib/perl5/${PV}/${PARCH}-thread-multi /usr/lib/perl5/${PV}/${PARCH}
- dodir /usr/lib/perl5/site_perl/${PV}/${PARCH}-thread-multi
- dosym /usr/lib/perl5/site_perl/${PV}/${PARCH}-thread-multi /usr/lib/perl5/site_perl/${PV}/${PARCH}
#This is to fix a missing c flag for backwards compat
make DESTDIR=${D} INSTALLMAN1DIR=${D}/usr/share/man/man1 INSTALLMAN3DIR=${D}/usr/share/man/man3 install || die "Unable to make install"
@@ -120,7 +118,6 @@ src_install () {
sed -e "s:ccflags=':ccflags='-DPERL5 :" ${D}/usr/lib/perl5/${PV}/${PARCH}-thread-multi/Config.pm.bak > ${D}/usr/lib/perl5/${PV}/${PARCH}-thread-multi/Config.pm
cp ${D}/usr/lib/perl5/${PV}/${PARCH}-thread-multi/Config.pm ${D}/usr/lib/perl5/${PV}/${PARCH}-thread-multi/Config.pm.bak
sed -e "s:cppflags=':cppflags='-DPERL5 :" ${D}/usr/lib/perl5/${PV}/${PARCH}-thread-multi/Config.pm.bak > ${D}/usr/lib/perl5/${PV}/${PARCH}-thread-multi/Config.pm
- rm -f ${D}/usr/lib/perl5/${PV}/${PARCH}-thread-multi/Config.pm.bak
./perl installman --man1dir=${D}/usr/share/man/man1 --man1ext=1 --man3dir=${D}/usr/share/man/man3 --man3ext=3
@@ -147,3 +144,10 @@ src_install () {
}
+pkg_postinst {
+ ln -s /usr/lib/perl5/site_perl/${PV}/${PARCH}-thread-multi
+/usr/lib/perl5/site_perl/${PV}/${PARCH}
+ rm -f $/usr/lib/perl5/${PV}/${PARCH}-thread-multi/Config.pm.bak
+
+
+}