summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-28 08:19:30 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-28 08:19:30 +0000
commit48ab65379c1ae2945bad2a1aa219a75bff95f9e6 (patch)
tree4fd3fa4010eebb1a48aee90647428eececb62d21 /sys-fs/e2fsprogs
parentstatic support #45055 (diff)
downloadhistorical-48ab65379c1ae2945bad2a1aa219a75bff95f9e6.tar.gz
historical-48ab65379c1ae2945bad2a1aa219a75bff95f9e6.tar.bz2
historical-48ab65379c1ae2945bad2a1aa219a75bff95f9e6.zip
ver bump #40624
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/ChangeLog7
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.35.ebuild112
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.351
3 files changed, 119 insertions, 1 deletions
diff --git a/sys-fs/e2fsprogs/ChangeLog b/sys-fs/e2fsprogs/ChangeLog
index 47a8bec535cc..e4d0c315dbfe 100644
--- a/sys-fs/e2fsprogs/ChangeLog
+++ b/sys-fs/e2fsprogs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/e2fsprogs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.17 2004/02/03 01:18:53 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.18 2004/03/28 08:19:30 vapier Exp $
+
+*e2fsprogs-1.35 (28 Mar 2004)
+
+ 28 Mar 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #40624 by Nicolas Boichat.
03 Feb 2004; Bartosch Pixa <darkspecter@gentoo.org>
e2fsprogs-1.34-r1.ebuild:
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.35.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.35.ebuild
new file mode 100644
index 000000000000..b432fcfefdb6
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.35.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.35.ebuild,v 1.1 2004/03/28 08:19:30 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~hppa ~ppc ~ia64 ~sparc ~mips ~ppc64 ~s390"
+IUSE="nls static"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ sys-apps/texinfo"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ # Fix a cosmetic error in mk_cmds's help output.
+ cd ${S}; epatch ${FILESDIR}/e2fsprogs-1.32-mk_cmds-cosmetic.patch
+ # Userpriv fix. Closes #27348
+ chmod u+w po/*.po
+ # Patch to make the configure and sed scripts more friendly to,
+ # for example, the Estonian locale
+ epatch ${FILESDIR}/${PN}-sed-locale.patch
+}
+
+src_compile() {
+ local myconf
+
+ use static \
+ && myconf="${myconf} --with-ldopts=-static" \
+ || myconf="${myconf} --enable-dynamic-e2fsck --enable-elf-shlibs"
+
+ econf \
+ `use_enable nls` \
+ ${myconf} || die
+
+ # Parallel make sometimes fails
+ emake -j1 || die
+}
+
+src_install() {
+ einstall libdir=zapme || die
+ #evil e2fsprogs makefile -- I'll get you!
+ rm -rf ${D}/zapme
+
+ make DESTDIR=${D} install-libs || die
+
+ #There is .po file b0rkage with 1.33; commenting this out (drobbins, 21 Apr 2003)
+ #if use nls; then
+ # make -C po DESTDIR=${D} install || die
+ #fi
+
+ dodoc ChangeLog README RELEASE-NOTES SHLIBS
+ docinto e2fsck
+ dodoc e2fsck/ChangeLog e2fsck/CHANGES
+
+ dodir /lib /bin /sbin
+ cd ${D}/usr/lib
+ mv * ../../lib
+ cd ${D}/lib
+ mv *.a ../usr/lib
+ local mylib=""
+ local x=""
+ #install ldscripts to fix bug #4411
+ cd ${D}/usr/lib
+ for x in *.a
+ do
+ [ ! -f ${x} ] && continue
+ gen_usr_ldscript ${x/a}so
+ done
+ #normalize evil symlinks
+ cd ${D}/lib
+ for x in *
+ do
+ [ ! -L ${x} ] && continue
+ mylib="`readlink ${x}`"
+ mylib="`basename ${mylib}`"
+ ln -sf ${mylib} ${x}
+ done
+
+ mv ${D}/usr/sbin/* ${D}/sbin
+ cd ${D}/usr/bin
+ mv lsattr chattr uuidgen ../../bin
+ cd ${D}/sbin
+ mv mklost+found ../usr/sbin
+ #time to convert hard links/duplicates to symbolic links
+ cd ${D}/sbin
+ rm fsck.*
+ ln -sf e2fsck fsck.ext2
+ ln -sf e2fsck fsck.ext3
+ rm mkfs.*
+ ln -sf mke2fs mkfs.ext2
+ ln -sf mke2fs mkfs.ext3
+
+ # 03 Aug 2002 <raker@gentoo.org>
+ # There are awk files that don't get installed when doing
+ # a 'make install'. They are the template files for
+ # /bin/compile_et.
+
+ cd ${S}/lib/et
+ insinto /usr/share/et
+ doins et_c.awk et_h.awk
+ cd ${S}/lib/ss
+ insinto /usr/share/ss
+ doins ct_c.awk
+}
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.35 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.35
new file mode 100644
index 000000000000..38322e76f0f4
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.35
@@ -0,0 +1 @@
+MD5 8d25ffd60d405ef32d341704a2323807 e2fsprogs-1.35.tar.gz 3152299